PDA

View Full Version : Synaptics Touchpad activation on Fedora7



stipi69
16th January 2008, 09:59 PM
I get error:

GSynaptics Could't initialize.
You have to set'SHMConfig' 'true' in xorg,conf or XF86Config to use GSynaptics

Please advice

Bslagowski
16th January 2008, 10:35 PM
First we need to open xorg.conf, this is the Xorg X server configuration file. Xserver handles the mouse, keyboard, screen, etc. We'll use the editor nano (you can use anything else - vi, vim, pico, etc.).


su -
nano /etc/X11/xorg.conf

Now find the section that says :


Section "InputDevice"
Identifier "Synaptics"

This controls the touchpad. At the bottom of this section add the line:


Option "SHMConfig" "true"

Press CTRL+X, y at the prompt, and then enter to save. I believe this should work for most users. However, it didn't for me though. What I had to do was simply not add the "true" part. So it would read 'Option "SHMConfig"' Restart X Server after this (CTRL+ALT+DEL) and try whatever you were trying before.

If you get an error and X won't start, no worries. Simply log back into the virtual terminal and remove that line and post back here. :)

Cheers,
Ben :D