PDA

View Full Version : Netmos 9835 PCI



nacross
16th January 2008, 05:44 PM
Hello,

I am a bit frustrated trying to install a PCI card to expand 2 new serial ports and one new parallel port. I found some hints on the different forums, but not enough for me.

I have a AMD box with Fedora 8 recently installed. From some post I came with the following information.

I typed: /sbin/lspci -vvvx
- - - - - - - - - -

00:0a.0 Communication controller: NetMos Technology PCI 9835 Multi-I/O Controller (rev 01)
Subsystem: LSI Logic / Symbios Logic 1P2S
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 19
Region 0: I/O ports at eb00 [size=8]
Region 1: I/O ports at ec00 [size=8]
Region 2: I/O ports at dc00 [size=8]
Region 3: I/O ports at dd00 [size=8]
Region 4: I/O ports at de00 [size=8]
Region 5: I/O ports at df00 [size=16]
Kernel driver in use: parport_serial
Kernel modules: parport_serial
00: 10 97 35 98 03 00 80 02 01 00 80 07 08 20 00 00
10: 01 eb 00 00 01 ec 00 00 01 dc 00 00 01 dd 00 00
20: 01 de 00 00 01 df 00 00 00 00 00 00 00 10 12 00
30: 00 00 00 00 00 00 00 00 00 00 00 00 03 01 00 00
- - - - - - - - - - - -

Then I typed: /bin/setserial -avg /dev/ttyS*

- - - - - - - - - -

/dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4
Baud_base: 115200, close_delay: 50, divisor: 0
closing_wait: 3000
Flags: spd_normal skip_test

/dev/ttyS1, Line 1, UART: 16550A, Port: 0xeb00, IRQ: 19
Baud_base: 115200, close_delay: 50, divisor: 0
closing_wait: 3000
Flags: spd_normal skip_test

/dev/ttyS2, Line 2, UART: 16550A, Port: 0xec00, IRQ: 19
Baud_base: 115200, close_delay: 50, divisor: 0
closing_wait: 3000
Flags: spd_normal skip_test

/dev/ttyS3, Line 3, UART: unknown, Port: 0x02e8, IRQ: 3
Baud_base: 115200, close_delay: 50, divisor: 0
closing_wait: 3000
Flags: spd_normal auto_irq
- - - - - - - -

I found some tips like adding a comment to the boot like " 8250.nr_uarts=9 " to get more ports ready to setup. I guess I will need to do it, but not sure exactly where.

I also find that the instructions that came with the card are for kernel 2.4 or earlier, and that for a kernel 2.6 onward I need to do a " partport ". Apparently it has worked successfully, but again that is beyond my skills. It mixed up with some posting saying parport_pc grabbing resources before parport. Some post mention modules and I am not sure if they mean compiling a new kernel. Finally It is like five or six posting on the subject and the refer to each other. So I find myself in running in circles.

Can anyone help me? Ideally I wish for a general explanation to make sense of the setup and then some steps.

Thanks in advance

Neville

bradchaus
17th January 2008, 04:37 AM
how many parallel and serial ports do you actually have? ... on the surface of it is seems you have 4 serial in total ... plug something into the new ports and try it out.

nacross
18th January 2008, 04:31 AM
Thanks for your input.

I was so frustrated that I didn't realize what I have in front of me. You're right. Apparently it is working, the info from "/sbin/lspci -vvvx" suggest that parport module has been loaded and the card is using IRQ=19. The info from "/bin/setserial -avg /dev/ttyS*" suggest 3 ports working, one from the motherboard and 2 ports sharing IRQ=19.

I want to use a program called xastir that deals with a TNC-2 (a sort of serial modem). I can not make it work. What I got from the terminal monitorin comments was: " Interface Error! Error opening interface 0 Hard Fail".

This is complex stuff so I went for simple approach. I use "/sbin/mgetty -r -s 9600 /dev/ttyS2" and tried on every ttys0, ttyS1 and ttyS2. I cycled the modem on and off, to se if I captured any input. The only thing I got was that the terminal windows closed by itself in ttyS1.

Apparently is there, but not sure if it working. Any idea how to test the serial ports?

Neville

bradchaus
18th January 2008, 05:08 AM
well if you have an old external RS232 modem, you can use minicom to communicate with it. thats the best test. It tests RS232.

alternatively you can use a serial RS232 loopback plug to test the ports. google for info.

nacross
18th January 2008, 05:12 AM
I got more in deep with mgetty. The logs did not said much, get to the web page that has the manual and apparently mgetty will not help me as a dumb terminal to see what is going on with the TNC (wich is more o less a serial modem).

I even tried a hint from a web page: "echo -e '\r\033@K\r' > /dev/ttyS1" but it didn't work.

Any ideas?

Neville

nacross
18th January 2008, 04:06 PM
I am really happy today.
the mgetty was a disaster, but the minicom was wonderful
That was the kind of application that I was looking for to test if I was communicating with the serial port. Still I have to fine tuning the settings for minicom but it is working. Everything is working. The Netmos PCI card with the 2 serial ports, and the communication with the external serial device.

Thanks for your help

Neville