PDA

View Full Version : Mouse, keyboard issues .. and X config



The Madcap
15th January 2008, 11:06 AM
Hi,
After F8 installation on compaq nc8430 and "plays" with ATI driver (X1600) i'm finally in a more or less stable situation.
While attempting to let the maximum resolution works (1680x1050) I’ve removed xorg server driver and I thing that I’ve mess up xserver.
Now, everytime I boot system after the login windows and while loading desktop a warning windows appears saying that system was expecting a US pc105 keyboard but a FR pc105 has been found(the right one) and asks me if I want to keep x configuration or GNOME details.
Mouse (touchpad), basically it works but sometimes it become little be “crazy” (previously wasn’t) and the “right click menu” appears even if I didn’t press any button.
Then, you know that on laptop touchpad you have on the right part an area supposed to be used for the scroll , previously it works properly now it doesn’t.
LCD resolution: every boot I need to increase up because system set at boot time the resolution to 1024x768 and no way to keep it defined.
Laptop special buttons (volume +, volume -, mute) at the first boot (when I’ve installed Fedora without playing with flgrx driver) they work properly now are not more defined and I manually configure them because all set on x86free.

Do you have an idea how to reconfigure correctly my system without these errors?
Otherwise, there is a way to reinstall “base system” driver (all) without reinstalling completely OS?

Thanks in advance, again..

Xorg.0.log (WW e EE) e Xorg.conf

Xorg.0.log

(WW) No monitor specified for screen "Screen0".
Using a default monitor configuration.
(WW) The core pointer device wasn't specified explicitly in the layout.
Using the default mouse configuration.
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): More than one displays are connected,so clone mode is enabled
(WW) <default pointer>: No Device specified, looking for one...
(EE) fglrx(0): [drm] failed to remove DRM signal handler

Xorg.conf


# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

leigh123linux
15th January 2008, 11:24 AM
Try typing in a terminal as non-root


gnome-keyboard-properties


And select the France keyboard layout

The Madcap
15th January 2008, 12:17 PM
Hi leigh123@linux,
thanks, i will try this evening (i'm in office now) .. but i think that i've already done this step selecting keyboard from the system config on desktop.
I will try using terminal and i'll let you know.

thanks

Frank616
15th January 2008, 04:53 PM
Leigh and others:

Anyone notice something strange about Madcap's xorg.conf file? There IS NO mouse or touchpad section! Yet he says he has both.

His xorg.conf was written by livna-config-display, same as mine. Mine does not have mouse or touchpad sections either, yet my wireless USB mouse and integrated touchpad work just fine -- in fact, too well, as even breathing on the touchpad sends the cursor all over the screen....

So, what IS controlling the mouse and touchpad?

I tried loading ksynaptics (KDE equivalent to gsynaptics) to reduce the sensitivity of my touchpad, but it complains that it needs to have 'SHMConfig yes' set in the touchpad section of xorg.conf. As noted, I HAVE NO TOUCHPAD SECTION in xorg.conf (attached below)


# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Now, I tried adding the line:


Option "SHMConfig" "true"

to the input device section (for the keyboard) and there was no effect. I tried adding the whole section here below:


Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
Option "Touchpad Off" "1"
Option "SHMConfig" "true"
EndSection

and again, xorg just seems to ignore it.

I don't even know for sure if I HAVE a synaptics touchpad or not. I am unable to locate anything in this install of F8 that seems to control the touchpad, or my wireless mouse.

Is xorg.conf split into two files by livna-config-display and then one is appended to the other at boot? What IS controlling my mouse and touchpad?

This just seems weird. Can anyone shed some light on this?

Thanks.

Frank.

Mariano Suárez-
15th January 2008, 04:58 PM
xorg's server does a great deal of autodetection. For sufficientely supported hardware, an empty xorg.conf should work fine.

The Madcap
15th January 2008, 05:05 PM
Franck,
i've tried adding the synaptics details and others.. but seems that while booting xorg.conf is completely ignored by the system (see the resolution and keyboard issue....)
I've tried also the option of the empty xorg.conf but final output is not a good one as i miss all the setup of my card.

...

The Madcap
15th January 2008, 07:21 PM
I've tested gnome-keyboard-properties ... no success...

Frank616
15th January 2008, 10:30 PM
Mariano:

Thanks for the response, but what does that mean? Where is the mouse and keypad being controlled from? I assume that, as you say, this is autodetected by xorg's server. However, how does one get at that to adjust it? There must be a utility or a config file somewhere that can be tweaked to give what is needed, no?

Madcap:

I'm working with you on this, and as yet, I don't know the answers either. Seems we both have the same basic problems, however. Solve one, and we should be able to solve the other.

Frank.

The Madcap
15th January 2008, 11:10 PM
Hi Franck,
i"ve finally solved both my problems (for the moment mouse and keyboard... i'm still on 1280x1024 not so good on 17inch screen) and this what i did

disable livna.

and then i've set xorg in this way

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "AlwaysCore"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "synaptics"
Load "dri"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3***ons" "yes"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3***ons" "yes"
Option "SHMConfig" "on"
EndSection


Now i've scroll on touchpad and synaptics correctly loaded while loading xorg.conf


Hope it helps.

Frank616
16th January 2008, 01:50 AM
Madcap:

>disable livna.<

I'm coming to that conclusion myself. :) Seems the helper app is worse than the problem.

If I don't get another answer, then I'll give this a try.

Merci bien pour ton aide. J'espere que tu reussira avec le 1680 x 1050.

Frank.