View Full Version : Printing to a Windows computer over a network

9th May 2004, 04:24 AM

I've searched the forums for other posts on this subject, but everything that I can find seems to talk about sharing Linux resources (via Samba) with a Windows computer.

First off, I am running FC2T3 on this computer. It's connected, via a simple network, to two other computers running Windows XP Home, one of them with a printer attatched to it. I want to be able to print to that printer from Linux.

I am fairly sure that the network is set up properly. I also have Win XP on this computer (dual boot) and it has no problems seeing and printing to the printer.

I'm a bit of a Linux newbie, so don't assume that I've tried the "obvious" fixes. Let me have it all.

9th May 2004, 05:30 PM
Run "redhat-config-printer" and follow the wizard... (Yes, it's that easy).

10th May 2004, 02:48 AM
Ok, I tried typing that into a terminal window and got the error message "redhat-config-printer: command not found." I tried running it as root and as a non-root user.

What I can do, however, is (in Gnome desktop) go in the "hat" menu to "System Settings" to "Printing". I think that this is a gui frontend to whatever command I was trying to get to work earlier.

I have tried two things. First, if you go to the "Action" menu, and then "Sharing", there is an option to "Automatically find remote queues" (This enables CUPS IPP browsing according to the hover text). This box is and always has been checked.

The second thing that I have tried is to add a new printer queue. This does not seem to detect any sort of printers. The wizard asks for the queue type and selects "Locally-connected" as the default. This is obviously wrong as the printer is on another computer on the network and I choose "Networked Windows" instead. This option can't find the printer. I also tried "Networked CUPS" and entered the name of the computer to which the printer is connected in the "Server" data box.

I'm still stuck. Any ideas of how I might get this to work?

Here's some more info in case it's relevant:
DHCP assigned IP of computer with printer:
Hostname of computer: COMPUTER1
Printer: HP Deskjet 932C

10th May 2004, 03:58 AM
I'm surprised you couldn't run it from a terminal:

$ which redhat-config-printer

But machts nichts - you found the right one anyway (same program).

From there, do as you did up until you selected "Networked Windows (SMB)". Click on "Select" (if you don't see your remote printer) and enter the information in there. The reason it may not immediately find the remote printer are varied and too numerous to list here, but this should get you going in the right direction. I can't help any further because I don't have any Windows boxes to check against.