PDA

View Full Version : Speedstep issues on Dell M170 Laptop



leenookx
13th January 2008, 10:23 PM
I have a Dell M170 laptop with Fedora 8 installed. I am having problems with speedstep / CPU Frequency Scheduler. Basically I am unable to get the laptop out of the lowest speed (800MHz), Other speeds are shown, but selecting them doesn't make any difference. I also have 2 governors installed: on-demand, and performance.

I can see messages in the system log to tell me that the speed change is requested, but I can't see anything happening.

I have also tried issuing:

cpufreq-selector -c 0 -f 2267000

again, with no problems.


Does anyone have any suggestions?

marko
13th January 2008, 10:47 PM
What method did you use to see if it's changing?
Did you look in the /proc/cpuinfo file?

Mark

leenookx
13th January 2008, 10:56 PM
I am running the gnome cpu frequency scaling applet.

But, doing what you suggested shows no change:

[root@localhost ~]# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 2.26GHz
stepping : 8
cpu MHz : 800.000
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx up bts est tm2
bogomips : 4524.89
clflush size : 64

marko
13th January 2008, 11:03 PM
Well, yeah, what I mean is, if you're running "on-demand" then to catch it in
the "act of working", the only way is to monitor the cpu freq while starting
up something that uses lots of cpu. On-demand when you're sitting there
idle will just sit at the lowest frequency.

Do you have a game or something you can turn on and then monitor
the gnome tool? ps. Sorry if you know that on-demand works
dynamically, this issue of people getting confused with on-demand
running their PC slow when it's really just slow because they
aren't running anything comes up a lot.

Mark

leenookx
13th January 2008, 11:24 PM
Yes, I have tried that. Even though I can see that the processor is maxed out it still won't switch up the speed. I've even tried scaling the speed up from the command line, and that has no effect earlier.

The thing is I am pretty sure that it worked when I first installed fedora 8 (and it worked previously under fc4), but I can't see anything obvious that could have broken it...