PDA

View Full Version : F8 - Dual Monitors



bioflash
18th December 2007, 03:26 PM
Hey All,

I'm trying to get dual monitors set up on a new F8 system. I'm using a Dell D630 laptop, with two DELL 1907FPV monitors. I've been playing with this A LOT, and I can get EITHER screen to work, but not both at the same time. I'm running the livna nvidia driver right now. If I try to take the easy route and use nvidia-settings, the 2nd screen gets disabled. Here's my conf and log files. If somebody could give me a hand getting this working, it would be greatly appreciated. =)

hellork
18th December 2007, 04:43 PM
Looks like you went and tried to set up Xinerama manually. You have two video cards configured but I'm pretty sure you don't have two video cards in the laptop. Just get rid of that xorg.conf and start with a fresh one. Then using the latest driver from the nvidia web site the nvidia-settings tool works fine. Set up twinview or separate X screens, not xinerama.

bioflash
18th December 2007, 07:21 PM
Looks like you went and tried to set up Xinerama manually. You have two video cards configured but I'm pretty sure you don't have two video cards in the laptop. Just get rid of that xorg.conf and start with a fresh one. Then using the latest driver from the nvidia web site the nvidia-settings tool works fine. Set up twinview or separate X screens, not xinerama.

Yes, I only have 1 video card in the laptop. Both entries should reference the same card. It's possible I've got that set up wrong. The first thing I tried was using the nvidia-settings tool on a fresh driver install, but it doesn't work right. The second screen is disabled every time X starts. That's why I've been trying to manually configure it.

HaMBoNE79
19th December 2007, 02:51 AM
Don't know if it will help, but here is the xorg.conf file for my dual LCD setup on Fedora 8:



# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "SceptreX9G-NagaV"
HorizSync 30.0 - 81.0
VertRefresh 40.0 - 76.0
EndSection

Section "Device"

# Removed Option "TwinView" "True"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7300 LE"
Option "RenderAccel" "True"
Option "Coolbits" "1"
Option "HWCursor" "True"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1280+0; CRT-0: 1280x1024 +0+0, CRT1: NULL;"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

bioflash
19th December 2007, 03:15 PM
Thanks for the help guys. After some more playing around, I have a better idea of what is going on. FYI, I did reinstall the driver and run the nvidia config. It still didn't do too much. After poking around, I figured out that X was sending my second display to a screen called "AUO". I have no idea what this is, or where it came from, but after I disabled this screen, and enabled my second monitor in twinview mode, both displays started working.

So, the only thing is that, I really don't want "twinview". I want to have desktop1 on my first monitor and desktop 2 on my second monitor. I tried setting the displays to use separate X windows, with both Xineram on and off. My first screen is black, and the second screen has a blinking "_" in the top left corner. After that, the system seems to lock up. I can't restart X (ctrl+alt+backspace) or even switch terminals (ctrl+alt+fx). The only way I've found is to restart the system entirely, the boot into runlevel 3 and restore my old xorg.conf. Any ideas on where to go from here?

Thanks again! :cool: