PDA

View Full Version : Need help finding and installing a wmv decoder for Fedora 7



andy bill
18th December 2007, 06:05 AM
This is my 2nd install of Fedora linux. I had Fedora 5 for about 6 months and lost my cpu, I have just installed Fedor 7 on my Dell Inspiron 2650. I had a program in previous box but am unable to locate a free, reliable download that I can do myself. Argh! I am a heart transplant and gees, find myself forgetting some things. Can't remember how I accomplished before. Can someone guide me to a download that I can understand with out a computer science background?? I am new to a chat room and forum, I tried to search wmv in the Fedora Forum window and got lost trying to see an answer to my delima. Acck, also I am troubled that I was unsuccessfull in installling the Mozilla email program. I downloaded from Mozilla org. and could not see how to continue the install.
signed; I feel asleep at the keyboard!!!!!!
ps am I supposed to put in my email or watch the thread???
babmarsh@verizon.net
And gees louise, what is it to post a poll?

andy bill
18th December 2007, 07:44 AM
I am replying to my own message about the wmv inability.... Please disregard this 'Q" as I am following
"I want to see mpg, mov, asf, wmv files" posting in the Forum. I followed some directions and got, I think partial success as here copied from my terminal-
bash-3.1# yum list | grep -F gstreamer
http://mirrors.reflected.net/fedora/linux/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://mirror.anl.gov/pub/fedora/linux/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://fedora.secsup.org/linux/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://fedora.omnispring.com/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://mirror.cc.vt.edu/pub/fedora/linux/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://mirrors.cat.pdx.edu/fedora/linux/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://limestone.uoregon.edu/ftp/fedora/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://mirrors.kernel.org/fedora/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
ftp://ftp.software.umn.edu/linux/fedora/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
http://mirror.lib.ucdavis.edu/fedora/linux/core/updates/6/i386/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
gstreamer.i386 0.10.11-1.fc6 installed
gstreamer-plugins-base.i386 0.10.11-1.fc6 installed
gstreamer-plugins-good.i386 0.10.4-3.fc6 installed
gstreamer-tools.i386 0.10.11-1.fc6 installed
gstreamer-devel.i386 0.10.11-1.fc6 updates
gstreamer-plugins-base.i386 0.10.10-1.fc6 updates
gstreamer-plugins-base-devel.i386 0.10.10-1.fc6 updates
gstreamer-plugins-farsight.i386 0.10.2-2.fc6 extras
gstreamer-plugins-good-devel.i386 0.10.4-3.fc6 updates
gstreamer-plugins-pulse.i386 0.9.4-4.fc6 extras
gstreamer-python.i386 0.10.7-2.fc6 extras
gstreamer08.i386 0.8.12-8.fc6 extras
gstreamer08-devel.i386 0.8.12-8.fc6 extras
gstreamer08-plugins.i386 0.8.12-7.fc6 extras
gstreamer08-plugins-devel.i386 0.8.12-7.fc6 extras
bash-3.1# yum list | grep -F mplayer
bash-3.1# yum list | grep -F mplayer
bash-3.1# yum list | grep -F mplayer
bash-3.1#

But as you see I am stuck at 2nd step.
I am going back to the thread and reading more....Pretty cool deal ...this forum stuff THANKS TO ALL USERS OF FEDORA LINUX!!!!!!!!!!!!!!

Will try to search out help with Mozilla Email program.... if anyone knows quick hints for same please input.
Thanks all...bigandybill

Seve
18th December 2007, 08:05 AM
Hello:
Are you sure that you are running F7 ?
From what you have posted in No.2 it appears to be FC6, which is no longer supported ?

From a terminal, what is the output of

cat /etc/fedora-release

Seve

andy bill
18th December 2007, 09:10 AM
Crimmeny...It is Fedora 6....what does "no longer supported mean to me?"
Here is edited copy of activity in my terminal:
Installed: gstreamer-devel.i386 0:0.10.11-1.fc6 gstreamer-plugins-base-devel.i386 0:0.10.11-1.fc6 gstreamer-plugins-farsight.i386 0:0.10.2-2.fc6 gstreamer-plugins-good-devel.i386 0:0.10.4-3.fc6 gstreamer-plugins-pulse.i386 0:0.9.4-4.fc6 gstreamer-python.i386 0:0.10.7-2.fc6 gstreamer08.i386 0:0.8.12-8.fc6 gstreamer08-devel.i386 0:0.8.12-8.fc6 gstreamer08-plugins.i386 0:0.8.12-7.fc6 gstreamer08-plugins-devel.i386 0:0.8.12-7.fc6
Dependency Installed: aalib.i386 0:1.4.0-0.11.rc5.fc6 libjingle.i386 0:0.3.10-1.fc6 libsidplay.i386 0:1.36.57-11.fc6 pulseaudio-lib.i386 0:0.9.6-2.fc6
Complete!

bash-3.1# rpm -ivh http://rpm.livna.org/livna-release-6.rpm
Retrieving http://rpm.livna.org/livna-release-6.rpm
warning: /var/tmp/rpm-xfer.Ns3s0r: Header V3 DSA signature: NOKEY, key ID a109b1ec
Preparing... ########################################### [100%]
1:livna-release ########################################### [100%]
bash-3.1# yum install mplayer* mplayerplug-in gstreamer*
Loading "priorities" plugin

warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID a109b1ec
Importing GPG key 0xA109B1EC "Livna.org rpms <rpm-key@livna.org>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-livna
Is this ok [y/N]: y
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded

Installed: gstreamer-ffmpeg.i386 0:0.10.2-2.lvn6 gstreamer-plugins-bad.i386 0:0.10.3-3.lvn6 gstreamer-plugins-bad-devel.i386 0:0.10.3-3.lvn6 gstreamer-plugins-ugly.i386 0:0.10.5-1.lvn6 gstreamer-plugins-ugly-devel.i386 0:0.10.5-1.lvn6 mplayer.i386 0:1.0-0.73.20070612svn.lvn6 mplayer-doc.i386 0:1.0-0.73.20070612svn.lvn6 mplayer-fonts.noarch 0:1.1-4.lvn6 mplayer-gui.i386 0:1.0-0.73.20070612svn.lvn6 mplayerplug-in.i386 0:3.45-1.lvn6
Dependency Installed: a52dec.i386 0:0.7.4-10.lvn6 enca.i386 0:1.9-3.fc6 faac.i386 0:1.25-2.lvn6 faad2.i386 0:2.0-19.20050131.lvn6 ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn6 freeglut.i386 0:2.4.0-11.fc6 gsm.i386 0:1.0.12-3.fc6 imlib2.i386 0:1.3.0-3.fc6 lame-libs.i386 0:3.97-4.lvn6 libcaca.i386 0:0.99-0.1.beta11.fc6 libdca.i386 0:0.0.2-3.lvn6 libdvdnav.i386 0:0.1.10-4.20070503.lvn6 libdvdread.i386 0:0.9.7-2.fc6 libid3tag.i386 0:0.15.1b-3.fc6 libmad.i386 0:0.15.1b-4.lvn6 libmms.i386 0:0.3-3.lvn6 libmp4v2.i386 0:1.5.0.1-3.fc6 libmpcdec.i386 0:1.2.2-4.fc6 lirc.i386 0:0.8.1-1.fc6 mpeg2dec.i386 0:0.4.1-2.lvn6 soundtouch.i386 0:1.3.1-6.fc6 x264.i386 0:0-0.8.20061028.lvn6 xvidcore.i386 0:1.1.3-1.lvn6
Complete!

bash-3.1# wget http://www4.mplayerhq.hu/MPlayer/re...0061022.tar.bz2
--23:34:19-- http://www4.mplayerhq.hu/MPlayer/re...0061022.tar.bz2
Resolving www4.mplayerhq.hu... 69.63.177.230
Connecting to www4.mplayerhq.hu|69.63.177.230|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
23:34:36 ERROR 404: Not Found.

bash-3.1# cat /etc/fedora-release
Fedora Core release 6 (Zod)
bash-3.1#

I thought I was doing great for a minute, eek!
One of my best friends wrote some 26 computer books including Maxium Security and I wanted to do this myself and I appreciate your reply.......bigandybill

Seve
18th December 2007, 09:25 AM
Crimmeny...It is Fedora 6....what does "no longer supported mean to me?"
Hello:
It means that any security or package updates will no longer be available from fedora. i.e anything from the fedora fedora-updates or fedora-extras repositories.

It does appear that you are finding livna still alive and well :)

You can grab the latest codecs here :
ftp://ftp1.mplayerhq.hu/MPlayer/releases/codecs/all-20071007.tar.bz2

You might also want to install, if you have not already. ffmpeg ffmpep-devel ffmpeg-libs

Seve

andy bill
18th December 2007, 09:44 AM
Seve, I downloaded from my browser the codecs (all-20071007) and then extracted in my root folder. There are many files. What do I do next?
signed; waking up at my keyboard
And how do I install "ffmpeg ffmpep-devel ffmpeg-libs"....Do I type this into terminal after the "bash-3.1#" ???
Thanks for your patience and assistance.....bigandybill

ps also should I update to Fedora 7? If so, I would go to the Fedora home page to begin this?

Seve
18th December 2007, 09:53 AM
Hello:
To install the codecs you can follow this guide ( a little dated, but still applies )
http://stanton-finley.net/fedora_core_5_installation_notes.html#Codecs
you also want to place the codecs in your /usr/lib/codecs

If you have the livna repository installed .. then open a terminal and
su -
yum install ffmpeg ffmpep-devel ffmpeg-libs

Should you upgrade ...?

That's up to you, I would say yes, upgrade or even better to a fresh install of Fedora 8. Fresh installs are really the best way to go.
http://forum.fedoraforum.org/showthread.php?t=174492
Most if not all the information is available here : http://fedoraproject.org/

Seve

andy bill
18th December 2007, 10:31 AM
Seve,
Gees, when you replied that I would be best served by installing a "fresh" install of Fedora 8 I felt a bit , ahh, queazy....You see I installed 6 (as you helped me remember!) and had to go to my pal's house and we spent hours with yum and add software to install programs to do some of the stuffs needed for me to do "work" with and for him (I am a novice at working in 'terminal') I spent some DAYS doing this with a bit of consternation (I cannot remember the couple of pitfalls I encountered but I learned how to resolve them, thus improving my computer skills---um-ah..wishful thinking here, hehe. Anyway it was worth the effort to get Windows XP off my laptop!!! Yahoo!
If I choose to install 8 I would be starting from scratch, right? I presume all the extras and such would be added by me all over again? Phew, seems like a big decision for me!!!!?
I am inclined to do as you suggest concerning immediate wmv desire...to get going right now.
Following this I will then show these threads to my pal for his input and then start over if that is my best solution for continued Linux use. Any input you may give me to the advantage of a fresh install would be appreciated.
Meanwhile may I thank you for your guidance and assistance with my Linux EXPERIENCE.
bigandybill

andy bill
18th December 2007, 10:41 AM
Seve,
I successfully went to terminal and installed ffmpeg ffmpep-devel ffmpeg-libs.

However I pasted "http://stanton-finley.net/fedora_co...tes.html#Codecs" into my browser and got "404 not found" Phttt and darn!

bigandybill

andy bill
18th December 2007, 10:45 AM
Seve
Oh, all this is swiming in my head... I went back to browser and pasted http://stanton-finley.net/fedora_core_5_installation_notes.html#Codecs
from my email box and successfully got the instructions.
Thanks.

andy bill
18th December 2007, 10:57 AM
Seve,
I went to http://stanton-finley.net/fedora_co...tes.html#Codecs and there was instructed:
To get the most out of Xine and other media players such as MPlayer you will need to install additional codecs. In order to do this open Firefox, go to http://www4.mplayerhq.hu/MPlayer/releases/codecs/ and download (save to disk) all-20060611.tar.bz2. .................................
To my chagrin "all-20060611.tar.bz2." is not there.
I still am having "fun" doing and learning but eyes are gone at this early am and am going to retire.
Will return and review all the threads after repose.
Again, thanks for effort.
bigandybill