PDA

View Full Version : Need Help with wine



Spikey123
18th December 2007, 06:05 AM
NOTE: Before you say anything I already tried to get help from the Wine help and even on thier IRC channel they will not give help to anyone without the Latest release of wine 0.9.51. So I came here

I had to reinstall Fedora Core 8 I got everything going exept wine I try winecfg and I get this


[Spike@localhost ~]$ winecfg
wine: creating configuration directory '/home/Spike/.wine'...
wait event returned -14
wine: wineprefixcreate failed while creating '/home/Spike/.wine'.
[Spike@localhost ~]$ wineserver: could not save registry branch to /home/Spike/.wine-DkccTc/system.reg : No such file or directory
wineserver: could not save registry branch to /home/Spike/.wine-DkccTc/user.reg : No such file or directory

glennzo
18th December 2007, 10:00 AM
Hi Spikey, would winecfg be something that needs to be run as root?

HaydnH
18th December 2007, 01:41 PM
Glenzo - no, it should be run as the user who will use wine.

Spikey - seems like a strange message, does the Spike user have the correct permissions on his home directory? Is there a /home/Spike/.wine directory already there & owned by someone else? Can you create the ~/.wine directory manually?

Spikey123
18th December 2007, 08:22 PM
Hayduh no bad premissons on the spike username did same in root, 2nd both don't have a .wine folder yes I did create it manually it also did an error. I did the wine install through YUM.

Also when I did the reinstall of fedora core 8 the installer crashed on me several times with some of the apps like vncserver and a few others.

spog
21st December 2007, 09:16 PM
Hi Spikey,

do you get the same "wait event returned -14" by running glxinfo. i do, and i belive this is related to Xorg driver or some GL libs above.
Also thing like ppracer or blender do not work for me and blender outputs the same "wait event..." message at failed startup.

Here is the end of my glxinfo output:

write(1, " GL_NV_light_max_exponent, GL"..., 76 GL_NV_light_max_exponent, GL_NV_texgen_reflection, GL_OES_read_format,
) = 76
write(1, " GL_SGI_color_matrix, GL_SGI_"..., 74 GL_SGI_color_matrix, GL_SGI_color_table, GL_SGIS_texture_edge_clamp,
) = 74
write(1, " GL_SGIS_texture_lod\n", 24 GL_SGIS_texture_lod
) = 24
ioctl(4, 0x4008642a, 0xbfc85044) = 0
ioctl(4, 0xc0086442, 0xbfc850ac) = 0
ioctl(4, 0xc0086443, 0xbfc850cc) = -1 EFAULT (Bad address)
write(2, "wait event returned -14\n", 24wait event returned -14
) = 24
exit_group(1) = ?

ggulik
25th December 2007, 07:09 AM
Is there a solution to this problem? I upgraded my father's PC to Fedora 8 specifically so he could run ies4linux because a bank he uses requires IE and I'm getting the same error.

The video card is an S3 card if and glxgears returns the same error.

czecher023
26th December 2007, 11:28 AM
it seems, i've got the same problem and i've got S3 graphic card, too

nh-
27th December 2007, 03:36 PM
Probably you have the same problem as I do, and it was recently reported.
http://bugzilla.redhat.com/show_bug.cgi?id=426743
You may try setting DRI off, but most probably the performance will be very low.