PDA

View Full Version : Dual Boot Problem



antiskeptic
14th December 2007, 03:18 AM
Hey all, bear with me, Im only new to linux (sighs i can hear), but very keen to learn. I have just finished installing fedora 8 on my system with xp along side. I have 2 ide hdds one being a 200g which I partioned in 2. C: has my / dir my /home and my /boot. d: partition has winxp on a ntfs file sys.
My second hdd has nothing bar my /swap dir, some reason fedora kept telling me there was no room on my c: drive when there was plenty but oh well.

Grub runs real nice and fedora even better my prob is when i go to boot windoze xp i get the following error

rootnoverify (hd0,4)
chain loader +1

any suggestions on how i can fix this and get winxp booting would be greatly appreciated

I have looked around on the net but since everyone has different distros and machines its been hard to find an answer

Cheers

Bryan

Dies
14th December 2007, 04:14 AM
Your partitioning scheme sounds a little strange, can you post the output of

su -
fdisk -l

antiskeptic
14th December 2007, 05:14 AM
Disk /dev/sda: 199.9 GB, 199913329664 bytes
255 heads, 63 sectors/track, 24304 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0cd70cd6

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 104391 83 Linux
/dev/sda2 12749 24303 92815537+ f W95 Ext'd (LBA)
/dev/sda3 14 1288 10241437+ 83 Linux
/dev/sda4 1289 12748 92052450 83 Linux
/dev/sda5 12749 24303 92815506 7 HPFS/NTFS

Partition table entries are not in disk order

Disk /dev/sdb: 80.0 GB, 80025280000 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x94919491

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 128 1028128+ 82 Linux swap / Solaris

ptb
14th December 2007, 05:58 AM
I just helped a friend install Fedora not too long ago and ran into similar problems. This (http://forum.fedoraforum.org/forum/showthread.php?t=172454) might be insightful. The problem might be that you have windows on an extended partition and windows doesn't like to boot from an extended partition.

brr872002
14th December 2007, 12:23 PM
Option I
Boot with XP CD in recovery mode
Edit C:\boot.ini
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(5)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(5)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
OR
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(4)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
If it fails
Try Option II
Keep Xp Install CD ready make partitions fresh for FC8
dev/sda1 5 GB fat32 >>> This helps for HDD installs from DVD.iso without writing to disc

/dev/sda2 12749 24303 92815537+ f W95 Ext'd (LBA)
/dev/sda3 /home
/dev/sda4 /
/dev/sda5 12749 24303 92815506 7 HPFS/NTFS

No need for /boot

Now boot with XP CD in rescue mode
fixmbr
fixboot

Reinstall fedora
Grub optin mbr /dev/sda1

antiskeptic
14th December 2007, 11:33 PM
Thanks for the advice.
When I put in my Windows XP Disk it does the norm and say "inspecting system hardware blah blah" then always seems to freeze, screen goes blank dvd rom does nothing and hdd light stays permantley on. It dont like it.
If I have made a huge mess here I dont mind re installing both os's another way, but which way to make them both like each other. My only on concern is I wish to keep my sdb hdd 80.0g on say fat32 or ntfs if fc8 has no prob reading writing to this for certain files I wish to share between the two os's.

Thanks guys and girls if your reading :)

Dies
14th December 2007, 11:56 PM
See this thread for the Windows install hanging.

http://forums.fedoraforum.org/forum/showthread.php?t=167302&highlight=balks

You can read and write to NTFS just fine from Linux.

If you feel up to it nuke the drive, then use the first disk for Windows and the second for Fedora, leaving the Windows bootloader untouched an installing grub to the Fedora disk, this is the best way to go IMHO.

http://www.jplawrence.us/mywiki/DualBootLinux

jaygeefed
15th December 2007, 12:22 AM
Thanks for the advice.
When I put in my Windows XP Disk it does the norm and say "inspecting system hardware blah blah" then always seems to freeze, screen goes blank dvd rom does nothing and hdd light stays permantley on. It dont like it.
If I have made a huge mess here I dont mind re installing both os's another way, but which way to make them both like each other. My only on concern is I wish to keep my sdb hdd 80.0g on say fat32 or ntfs if fc8 has no prob reading writing to this for certain files I wish to share between the two os's.

Thanks guys and girls if your reading :)

I recently recovered from a similar problem (I've got a Dell desktop with 2 hard drives. WinXP Pro SP2 on the master HD and Fedora8 on the slave HD).

First I used the Win XP Recovery Console to sort out the C:\ disk MBR with the FIXMBR command which then let me boot into Win XP.

Next I installed Acronis DiskDirector 10.0 and the integral OS Selector software allowed(allows) me to choose to boot into either system thereafter.

May not be the most politically correct solution as it uses commercial software but it works out of the box.

HTH

John

stoat
15th December 2007, 01:29 AM
Hello antiskeptic,

The only possible partition in your fdisk that can be an XP partition is the NTFS /dev/sda5 which is a logical partition. Even though XP can be installed in a logical partition. it must still have a compatible (FAT32, NTFS) active primary partition for its boot loader files (ntldr, ntdetect.com, boot.ini). You have no such partition. You very likely allowed Fedora to destroy it during its installation. It's happened before. In fact, it's the thread that ptb linked to above. I am very familiar with that case. It ended with the victim re-installing everything after several days of trying to recovery from it. While it is theoretically possible to repair such a situation (I did it), it is very difficult to learn via forum posts. I hope you backed up your important files because you are very likely going to be re-installing both XP and Fedora.

If you do decide to re-install XP, I recommend that you re-install XP before re-installing Fedora. This time, Install XP in a primary partition at the very beginning of the drive that is first in the BIOS boot order. Then behind that, you can install Fedora in any kind of partition on any drive and everything will be okay.

P.S.: You may find that you have to remove your Linux partitions (or at least sda1, maybe) before your XP CD will boot to allow you to re-install XP.

antiskeptic
17th December 2007, 11:24 AM
Ok guys, i decided to kill the two os's and start from sratch now i have another dual boot problem...

my hdds are set up like this now...

Disk /dev/sda: 199.9 GB, 199913329664 bytes
255 heads, 63 sectors/track, 24304 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0cd70cd6

Device Boot Start End Blocks Id System
/dev/sda1 * 1 12748 102398278+ 7 HPFS/NTFS
/dev/sda2 12749 24303 92815537+ f W95 Ext'd (LBA)
/dev/sda5 12749 24303 92815506 e W95 FAT16 (LBA)

Disk /dev/sdb: 80.0 GB, 80025280000 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x94919491

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 25 200781 83 Linux
/dev/sdb2 26 9729 77947380 8e Linux LVM

Disk /dev/dm-0: 77.6 GB, 77678510080 bytes
255 heads, 63 sectors/track, 9443 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 2080 MB, 2080374784 bytes
255 heads, 63 sectors/track, 252 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x30307800

Disk /dev/dm-1 doesn't contain a valid partition table

windows on hda and linux on hdb
now i followed the link above and did the following to the dot...

This should be really simple. Of course I found out the hard way after installing twice in 3 days. A lot of folks will tell you to install grub into the MBR of the XP hard drive so you can boot Linux and Windows. Well I tried and tried and tried. No dice! So I remembered what I did a few years ago ( since my last install) was to disconnect my Windows hard drive change the Linux hard drive to be the primary hard drive in the BIOS (not on the Motherboard) and install Linux. Sounds good huh? Well if you leave it this way, during the install Linux will NOT find your windows install. Make a note to install grub into your MBR of your LINUX drive and your current drive mapping is that your Windows hard drive is the primary and the Linux drive is slave.

To clear things up, the Windows hard drive is connected to the Primary IDE cable. The Linux Hard Drive is connected to the Secondary IDE cable.

To me thats great; no need for that anyhow. (no Windows) But my wife likes to play games and such and I must admit I need to print every once in a while. printing is another sore subject for me having to do with Lexmark BS printers. But thats another story. So after spending a few grueling hours installing and updating and getting everything nice nice the way I like it, I went in and edited my grub.conf file with the following

title Windows XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

This tells grub to pass the ball to the NT boot loader on the other hard drive. So to make this work you need to make sure you have these settings

* Your 2 drives are mapped so that Windows is attached to the primary (IDE cable) and Linux is Slave.
* Your primary boot hard drive in the BIOS is set to Linux Drive.
* You remove the power from the Windows drive prior to booting the Linux CD.
* You install as normal
* Install Grub into the MBR of the Linux Drive (usually /dev/hdb )
* You edit your grub.conf file so that you have the above code allowing you to boot into Windows.

Shut down, plug in the power to the Windows Drive and boot up. you should get your grub boot screen. Hit enter and you'll see the choices you have to boot maybe a few kernels and that Windows hard drive. Go ahead and choose windows no one will blame you for doing so. You should be able to boot it up no problems. So go ahead and reboot and this time choose your Linux kernel that you want and it will boot up as well.

what have I learned here? That Linux can have its own boot loader installed into the MBR of its own hard drive. Windows can boot thinking its the only OS out there. And finally there is NO need to install grub into the MBR of your Windows hard Drive ever again.

now i get this error instead....

Booting Windoze XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1
error 11: unrecognized device string

any help again appreciated

Cheers
Bryan

stoat
17th December 2007, 07:13 PM
now i get this error instead....

Booting Windoze XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1
error 11: unrecognized device stringI think you should take a moment to post your grub.conf here.

antiskeptic
18th December 2007, 04:40 AM
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.23.8-63.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.23.8-63.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.23.8-63.fc8.img
title Fedora (2.6.23.1-42.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.23.1-42.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.23.1-42.fc8.img
title Windoze XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1, 0)
chainloader +1

stoat
18th December 2007, 04:59 AM
title Windoze XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1, 0)
chainloader +1Get rid of the space after the comma in the rootnoverify line and try again.

antiskeptic
18th December 2007, 06:17 AM
cheers stoat, that little space made the difference.... your the man! :)