PDA

View Full Version : Graphics questions - ATI



Deore
13th December 2007, 11:35 PM
Hi,

after some time using f8 there are still some graphics issues that I would like to have solved.

1. Video playback problems with Compiz: In order to avoid flashing video in xine I use the xshm driver. However this is slow. In fullscreen I have some lagging despite 2,2 GHz. I know there is a patch for mplayer, but this would mean compiling it from source. I don't want to mess up my system by doing that. I like yum :). Has anybody solved this somehow? My workaround is to go back to metacity while playing a vid.

2. xine-plugin shows a corrupted picture - not usable. Which plugin are you using for firefox? I suppose this has something to do with issue 1, but I don't even know how to set settings for the plugin in order to experiment with it.

3. RandR - the fglrx driver is supposed to support RandR. My Xorg log says that the RandR extension is enabled upon booting. But still when using xrandr -q it shows my laptop screen alright but no other port - no VGA nor DVI. I can't switch to external monitor with it. In the guides I read, xrandr showed even the laptop LCD with an ID like LVDS, with me its only "Screen 0". Do you know why?

4. I am not able to find an rpm with the radeonhd driver. I wanted to give it a try, but I don't want to compile it and install it myself.

Ah, my graphics card is ati mobility radeon hd2400, using fglrx 8.43-3.7.11 on a 2.6.23.8-63.fc8 kernel. X is from f7 - 1.3.0.0-9.fc7.
I will appreciate it if you shared your opinion on these issues!

leigh123linux
14th December 2007, 12:42 AM
1. try xvmc instead
2. should be better using xvmc
3. dont know
4. http://koji.fedoraproject.org/koji/buildinfo?buildID=27906

Deore
14th December 2007, 03:53 PM
Thanks Leigh!

xvmc (like xv) has the same effect as leaving xine to auto choose the driver.
This applies to both 1 and 2.

The radeonhd is cool, I just need to invest some time in testing what it can - the first time I ran it I got a all-white screen, but I suppose I should have switched compiz-fusion off ;)
I am particularly interested to see if the radeonhd can change the brightness of my LCD as with fglrx this fails. But it may even not be a driver issue...

Deore
15th December 2007, 06:58 PM
Well the brightness issue is a problem for radeonhd too, but the behavior is different - when I press the Fn + Brightness keys, there is absolutely no effect. With fglrx the screen flickers for a part of a second as if it would really change brightness, but instead it remains all up. From this I suppose that with fglrx it is a bug and with radeonhd it is not implemented.

And the randr issue seems to be related to ATI too. With radeonhd I get all the ports listed (except hdmi, but it is not yet supported) - lvds and vga-1. Also on a laptop with intel graphics the randr thing works great too.

Deore
18th February 2008, 04:15 PM
Issue 1 has been solved (it really helps to read the X log once in a while):

In the Device section in the xorg.conf the Option "TexturedVideo" should be set to "true". After doing this the "xshm" driver for xine works perfect (no lagging) and "xv" driver for vlc is also ok.
Maybe this solves issue 2 (forgot to test).