PDA

View Full Version : small web fonts



pcandpc
9th December 2007, 03:36 AM
Hi,

I am using FC 8. I find the web fonts on firefox are darn samll;
I almost always have to squint my eyes. It's very uncomfortable.

I have tried increasing font sizes within firefox but didn't help.

Will installing Windows True Type Fonts help? If so, how can I install them?
And, where can I find them?

Thanks.

Wayne
9th December 2007, 03:39 AM
http://www.mjmwired.net/resources/mjm-fedora-f8.html#ttf

Edit: I use (for want of a better word) a custom set of fonts, which includes the original msttcorefonts, arial unicode, MS Mincho and MS Gothic (for Japanese pages) and Vista fonts that sits in my ~/.fonts directory (So I don't need to reinstall it every time a new Fedora version comes out) If you want it let me know and I'll give you a link to it.

Wayne

JN4OldSchool
9th December 2007, 03:43 AM
back in Firefox preferences, did you try adjusting the "minimum font size" box? This should force it to use bigger font.

pcandpc
9th December 2007, 10:27 PM
Hi,

Thanks for the tip. Yes, I have tried setting the minimum font size bigger
but didn't help that much.

Just to share with you how small my web screen fonts look, I am attaching
a sample screen shot.

PeTzZz
9th December 2007, 11:22 PM
Have you updated to the latest Firefox with the Software Updater? Fedora 8 came with Firefox 2.0.0.8 and I had the same problem with it and saw others having it too. Firefox 2.0.0.9 fixed it.

pcandpc
11th December 2007, 10:57 PM
Hi,

Actually, my firefox is already at v 2.0.0.10.

Now the browsing fonts look better with JN4OldSchool's method.

However, the firefox menu fonts and its pop-up window fonts are
still very small. How can I increase them?

For other applications, their fonts look normal (at least bigger than
firefox's).

Take a look at the screen shot.

leigh123linux
11th December 2007, 11:02 PM
Hi,

Actually, my firefox is already at v 2.0.0.10.

Now the browsing fonts look better with JN4OldSchool's method.

However, the firefox menu fonts and its pop-up window fonts are
still very small. How can I increase them?

For other applications, their fonts look normal (at least bigger than
firefox's).

Take a look at the screen shot.


If you adjust the application fonts that should sort it out



gnome-appearance-properties

Seve
11th December 2007, 11:04 PM
Hello:
Hello:
If you find that you have small fonts, or smaller than you would like in the top line and cannot adjust them with Preferences, then you can add an entry to your
/home/username/.mozilla/firefox/xxxx.default/chrome/userChrome.css


#specifiy the font size for the top menu
menubar, menubutton, menulist, menu, menuitem, textbox, toolbar, tab,
tree, tooltip
{
font-family: verdana, helvetica !important;
font-size: 18px !important;
}

Just play with the 18px [i.e. 14 .. 15 .. 16 etc.] and adjust the font-family to what you are using .

When you are editing the file, make sure that firefox is not running, save your changes and restart firefox.

Edit:
You may not have a userChrome.css file as there is only a sample one installed by default. In which case, just create one {pay attention to CaSe}
More info here : http://www.mozilla.org/support/firefox/edit#css

Seve

bob
11th December 2007, 11:39 PM
Thanks, Seve. That answered my problem with fonts. The file to edit is userChrome-example.css which you then save as userChrome.css

Seve
11th December 2007, 11:59 PM
Hello:
Holy cow ....... Bob :)
This is probably the first time I have ever suggested a working solution for you. :cool:

Seve

bob
12th December 2007, 12:01 AM
Nah, it's just the first time I admitted it. :D

leigh123linux
12th December 2007, 12:19 AM
Hello:
Hello:
If you find that you have small fonts, or smaller than you would like in the top line and cannot adjust them with Preferences, then you can add an entry to your
/home/username/.mozilla/firefox/xxxx.default/chrome/userChrome.css


#specifiy the font size for the top menu
menubar, menubutton, menulist, menu, menuitem, textbox, toolbar, tab,
tree, tooltip
{
font-family: verdana, helvetica !important;
font-size: 18px !important;
}

Just play with the 18px [i.e. 14 .. 15 .. 16 etc.] and adjust the font-family to what you are using .

When you are editing the file, make sure that firefox is not running, save your changes and restart firefox.

Edit:
You may not have a userChrome.css file as there is only a sample one installed by default. In which case, just create one {pay attention to CaSe}
More info here : http://www.mozilla.org/support/firefox/edit#css

Seve


I normally type


about:config


Then filter for dpi and set the value to 96

pcandpc
15th December 2007, 05:17 AM
Hi,

After manipulating the chrome file per leigh123's suggestion,
the menu now appears better. But, the pop-up windows' fonts
are still small.

Here is what I have done in the chrome file:

#specifiy the font size for the top menu

menubar, menubutton, menulist, menu, menuitem, textbox, toolbar, tab,
tree, tooltip, menupopup

{
font-size: 12pt !important
}

And, this is my sample screenshot: