View Full Version : networking woes in FC2T3

7th May 2004, 10:31 AM

I have two network cards in my machine. One with a direct connection to an internet router, one for the internal home network. Both cards are configured fine, as far as I can tell. The card pointing at the router has the default gateway (IP of router), the other card's default gateway is empty.

PROBLEM: I can ping the router and IPs on my internal network. But I can not get past the router. Doing a traceroute on an IP on the internet gives me * * * at the first hop, so it is not even sent to the router. Even though the default gateway is set and it is shown in the routing table (netstat -rn and route).

During installation I was asked whether I want a firewall, I answered no to this.

I tried restarting the network interfaces, I also tried with only the internet card enabled. No change.

Any ideas? Righ now I can not access the internet at all. Oh btw: the router does work, I am using it right now from a windows workstation.


7th May 2004, 12:40 PM
I am assuming DHCP is off...

You need to add a DNS name server to the machines
i.e. something like

7th May 2004, 12:58 PM

yes, DHCP is off and I do have DNS servers. It's not a DNS problem, it's a routing problem I guess. For some reason, packets destined for the internet are not being sent to the router.

Doing traceroutes to IP addresses (not DNS names) on the internet are not even passing to the router, they stop at hop #1.

I can only talk to the local network.


7th May 2004, 08:28 PM
anyone? I am really stuck here....


15th May 2004, 07:24 AM
I had some troubles behind a netgear router.

ping and things like that would work. browser/wget/ssh and things like that would not.

found some posting indicating to turn off ECN
echo 0 > /proc/ sys/net/ipv4/tcp_ecn

this did the trick for me.