PDA

View Full Version : Annoying yum error



rilo
27th November 2007, 11:36 PM
Yum keeps locking up when running and fills my logs with this error:

yum-updatesd-helper: error getting update info: 'module' object has no attribute 'GroupError'

It seems its trying to import the python class GroupError from yum.Errors, but that doesn't exist - 'GroupsError' does however. Changing it from GroupsError to Error seems to do the trick for the time being.....

Anyone else noticed this?

RHamel
28th November 2007, 12:42 AM
Yes, you have a conflict with yum-updatesd. I solved this by disabling the service, since it's no problem for me to occasionally run yum from a terminal. I believe others have solved this with a plugin.

rilo
28th November 2007, 12:47 AM
changing the python library seems to fix it up fine (yum/Errors.py line:65 GroupsError to GroupError), it just seems like a typo in the source code to me. what exactly is conflicting? and what does the plugin do?

RHamel
28th November 2007, 01:30 AM
http://forums.fedoraforum.org/forum/showthread.php?t=171785

RHamel
28th November 2007, 01:46 AM
I think you are right. There is an error in the routine/s that is malfunctioning, which is causing a lot churning with the daemon. That then conflicts with running yum from a terminal. I'm not experiencing the same problems if F7. In F8 I noticed a lot of TCP/IP traffic, which led me to turn off yum-updatesd.