PDA

View Full Version : updated FC7, all sound died



ordinary
27th November 2007, 11:29 PM
I just updated my FC7 box this morning (via yumex), and since then I cannot get sound to work. Sound was working yesterday, but not since the update. I couldn't swear that the update caused the problem, but I changed nothing else between the sound working and not working. (Having said that, the problem will eventually reveal itself as being caused by some other fat-fingering on my part.)

I know little to nothing about diagnosing sound problems. /var/log/messages contains no clue. Neither does /var/log/anything_else. So I could use some help diagnosing this. I must admit that I use sound without thinking much about it.

I tried system-config-soundcard, but achieved nothing practical. The "Sound test" failed to produce sound. It detected the sound HW as vendor: nVidia Corporation, Model: MCP55 Hgh Definition Audio, Module: snd-hda-intel. That module seems suspicious. Why intel, if it is nVidia? I thought it was RealTek or some such. I just don't know much about audio HW.




[root@frederic log]# lspci
<snip>
00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
<snip>
[root@frederic log]#


[root@frederic log]# uname -a
Linux frederic 2.6.22.9-91.fc7 #1 SMP Thu Sep 27 20:47:39 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
[root@frederic log]#

I have searched these forums to no avail. It isn't that I get no returns for my search, but the search terms I used produce a great many results or a few useless results.

Thanks,
Phil

RHamel
28th November 2007, 12:50 AM
What does /var/log/yum.log look like? Can you post it?

ordinary
28th November 2007, 12:52 AM
Okay, this is odd.

I've got sound now.

Before I started this thread, I screwed around with the problem for about an hour and an half. I logged out and back in, I tried different users, I even rebooted the machine. No success, no sound. I even tried a bunch of different audio sources: no joy.

In the meantime, I socialized with the wifelet. Now I come back and, what the heck, try it again. And the sound works.

I don't like problems that fix themselves. I guess I should consider myself lucky, but what's the solution next time? I still don't know how to diagnose sound problems, and I'd still like to. Does flirting with one's spouse really help?

Thanks anyway,
Phil

ordinary
28th November 2007, 12:53 AM
What does /var/log/yum.log look like? Can you post it?

Thanks for the interest, RHamel.


[root@frederic log]# cat yum.log
Nov 27 12:52:16 Installed: totem-plparser.x86_64 2.18.3-1.fc7
Nov 27 12:52:17 Updated: info.x86_64 4.11-2.fc7
Nov 27 12:52:56 Updated: compat-wxGTK26.x86_64 2.6.4-0.7
Nov 27 12:52:58 Updated: libzzub.x86_64 0.2.3-10.fc7
Nov 27 12:53:06 Updated: samba-common.x86_64 3.0.27a-0.fc7
Nov 27 12:53:08 Updated: texinfo.x86_64 4.11-2.fc7
Nov 27 12:53:09 Updated: procps.x86_64 3.2.7-16.1.fc7
Nov 27 12:53:10 Updated: libsane-hpaio.x86_64 1.7.4a-6.fc7
Nov 27 12:53:10 Updated: texinfo-tex.x86_64 4.11-2.fc7
Nov 27 12:53:14 Updated: samba-client.x86_64 3.0.27a-0.fc7
Nov 27 12:53:27 Updated: audacity.x86_64 1.3.2-14.fc7.1
Nov 27 12:53:44 Updated: ddd.x86_64 3.3.11-17.fc7
Nov 27 12:53:45 Updated: libsmbclient.x86_64 3.0.27a-0.fc7
Nov 27 12:53:45 Updated: hdparm.x86_64 7.7-1.fc7
Nov 27 12:53:46 Updated: hal-cups-utils.x86_64 0.6.13-2.fc7
Nov 27 12:53:51 Updated: selinux-policy.noarch 2.6.4-57.fc7
Nov 27 12:54:04 Updated: selinux-policy-targeted.noarch 2.6.4-57.fc7
Nov 27 12:54:05 Updated: wine-docs.noarch 0.9.49-1.fc7
Nov 27 12:54:16 Updated: wine-core.i386 0.9.49-1.fc7
Nov 27 12:54:17 Installed: totem-plparser.i386 2.18.3-1.fc7
Nov 27 12:54:22 Updated: pilot-link.i386 2:0.12.2-6.fc7
Nov 27 12:54:25 Updated: pilot-link.x86_64 2:0.12.2-6.fc7
Nov 27 12:54:26 Updated: wine-esd.i386 0.9.49-1.fc7
Nov 27 12:54:27 Updated: wine-tools.i386 0.9.49-1.fc7
Nov 27 12:54:28 Updated: wine-ldap.i386 0.9.49-1.fc7
Nov 27 12:54:28 Updated: wine-capi.i386 0.9.49-1.fc7
Nov 27 12:54:29 Updated: wine-nas.i386 0.9.49-1.fc7
Nov 27 12:54:30 Updated: wine-cms.i386 0.9.49-1.fc7
Nov 27 12:54:32 Updated: wine-twain.i386 0.9.49-1.fc7
Nov 27 12:54:33 Updated: wine-jack.i386 0.9.49-1.fc7
Nov 27 12:54:50 Updated: totem-xine.x86_64 2.18.3-1.lvn7
Nov 27 12:55:04 Updated: totem-xine.i386 2.18.3-1.lvn7
Nov 27 12:55:13 Updated: wine-devel.i386 0.9.49-1.fc7
Nov 27 12:55:14 Updated: libsmbclient.i386 3.0.27a-0.fc7
Nov 27 12:55:14 Updated: wine.i386 0.9.49-1.fc7
Nov 27 12:55:15 Updated: pilot-link-devel.x86_64 2:0.12.2-6.fc7
Nov 27 12:55:36 Updated: python.x86_64 2.5-15.fc7
Nov 27 12:55:37 Updated: python-libs.x86_64 2.5-15.fc7
Nov 27 12:55:38 Updated: python-libs.i386 2.5-15.fc7
Nov 27 12:55:46 Updated: rhythmbox.x86_64 0.10.1-5.fc7
Nov 27 12:55:48 Updated: smolt.noarch 1.0-2.fc7
Nov 27 12:55:48 Updated: smolt-firstboot.noarch 1.0-2.fc7
Nov 27 12:55:55 Updated: python-devel.i386 2.5-15.fc7
Nov 27 12:56:00 Updated: python-devel.x86_64 2.5-15.fc7
Nov 27 12:56:01 Updated: livna-config-display.noarch 0.0.19-2.lvn7
Nov 27 12:56:02 Updated: pyzzub.x86_64 0.2.3-10.fc7
Nov 27 12:56:03 Updated: yumex.noarch 2.0.3-2.fc7
Nov 27 12:56:10 Updated: rhythmbox.i386 0.10.1-5.fc7
Nov 27 12:56:17 Erased: totem-xine-plparser
Nov 27 12:56:22 Erased: totem-xine-plparser
Nov 27 12:58:12 Updated: hplip.x86_64 1.7.4a-6.fc7
Nov 27 12:58:17 Updated: hplip-gui.x86_64 1.7.4a-6.fc7
Nov 27 13:00:11 Updated: hpijs.x86_64 1:1.7.4a-6.fc7
Nov 27 16:45:12 Installed: alsamixergui.x86_64 0.9.0-0.3.rc1.fc6
[root@frederic log]#



Thanks,
Phil

RHamel
28th November 2007, 01:39 AM
Could be just pulse-audio acting up. It seemed flaky to me.

ordinary
28th November 2007, 04:14 AM
RHamel: Could be just pulse-audio acting up. It seemed flaky to me.

I'll look into that. Thanks for the input. It truely is annoying for any system to fix itself. You just know that it will occur again at an inconvenient time.

I still know no more about diagnosing sound problems. I'll spend some time online trying to fix that.



landonmkelsey: I NEVER had a successful Fedora (or the old Red Hat free Linux) update.

Surely you misunderstand. I don't mean upgrading from some previous Fedora version, I just mean updating the installed packages.

Thanks,
Phil

ordinary
28th November 2007, 06:22 AM
what sound card do you have?

I have built in sound on the motherboard!

search bugzilla or.....do a total install...save data first on a CD/DVD or flash drive

Reinstall? The question is about how to diagnose sound problems. Even if I were willing to reinstall the OS to fix a minor problem on a nice, stable, running system, how will that help me diagnose the problem?

ordinary
28th November 2007, 04:50 PM
as I said: I have never gotten an update to work 100%

Do you mean you install every week or so, or do you just ignore the updates?

I have never had a package update fail in any meaningful way. I mean, a time or two I have had a dependency mismatch or something like that, but even then I just wait a couple of days for the repository maintainers to do their thing and try again. That has simply never failed for me.

If I had as much problem with the repos as you suggest, I would surely find another distribution, another OS, or another profession.

Good luck,
Phil

dan sawyer
28th November 2007, 11:52 PM
I had the same issue. I upgraded from the DVD and there were two items preventing moving to the upgrade, sound and xorg.conf 'virtual'. Sound is not working. Only one issue remaining preventing cutting over. - Dan