PDA

View Full Version : Blender wont start [Segmentation fault]



moljac024
27th November 2007, 06:55 PM
I can't start blender.
I tried reinstalling it, still the same


[bojan@Lappy ~]$ blender
Compiled with Python version 2.5.1.
Checking for installed Python... got it!
/usr/bin/blender: line 46: 7637 Segmentation fault /usr/bin/blender.bin $@

Please help :)

Running fedora 8 on an MSI laptop with an intel gma 950...

Seve
27th November 2007, 07:23 PM
Hello:
It looks like someone else had a similar problem, you may also want to follow up here : https://bugzilla.redhat.com/show_bug.cgi?id=375611


Seve

arqlinux
28th November 2007, 04:54 PM
same problem... nothing solved yet... :(

FriedChips
28th November 2007, 04:57 PM
I assume you are installing with yum and not compiling from source?

moljac024
28th November 2007, 11:00 PM
I went to blender official site, all I could see were pre-compiled packages...didn't find a link to a source tarball....

FriedChips
28th November 2007, 11:06 PM
don't download it from official site, install from yum with:

yum install blender

it is right in the fedora repositories

[Stephen@localhost ~]$ yum list blender
Loading "presto" plugin
Loading "fastestmirror" plugin
Loading "skip-broken" plugin
Setting up and reading Presto delta metadata
Loading mirror speeds from cached hostfile
Available Packages
blender.x86_64 2.45-4.fc8 fedora

arqlinux
29th November 2007, 03:18 PM
have it installed from yum... same message.... :( really dont know what to do... and i really need it... i use it for work!...

moljac024
29th November 2007, 07:14 PM
I installed it from yum in the first place but thought that maybe if I compiled it myself it would work....

quazart
29th November 2007, 07:48 PM
I think it is not blender's fault. I have the same problem in both i810 and intel video drivers but blender works ok using vesa video driver. Anyway this is not a solution because vesa is generic and has some limitations.

arqlinux
30th November 2007, 12:00 AM
maybe this can show us some light...... http://www.mail-archive.com/debian-x@lists.debian.org/msg70898.html

arqlinux
30th November 2007, 12:29 AM
another reference..........http://www.blender.org/forum/viewtopic.php?t=12423&highlight=segmentation+fault

FriedChips
30th November 2007, 12:39 AM
another reference..........http://www.blender.org/forum/viewtopic.php?t=12423&highlight=segmentation+fault

that suggests that building the newest version from svn may solve the problem.

arqlinux
30th November 2007, 03:17 PM
so is this mesa problem or blender problem???

DoctorVesuvius
20th December 2007, 07:33 PM
Am seeing this same thing on an ATI Mobility. Here's an accidental find: If I root login to KDE, then start new sessions to use my non-root login to KDE, the non-root KDE works. And if I reverse the login order, then start new session the root login works. Almost as if only the second session logged in KDE account gets it.
-doc

moljac024
22nd December 2007, 02:19 AM
Yes, i can confirm this....if you start a new session blender will work in the second session. Really strange...

arqlinux
27th December 2007, 05:09 PM
its because in the second session theres no direct rendering... only in the first session... thats why blender works... you can confirm this by doing glxinfo on the 2 sessions...

arqlinux
8th January 2008, 04:18 PM
From bugzilla:

sudo yum upgrade mesa-libGL --enablerepo=updates-testing

That fixes the issue. The new mesa hasn't been pushed yet. Please test this
out and then go to https://admin.fedoraproject.org/updates/F8/FEDORA-2008-0094
to add karma to the package so it can be released. Please note this bug in your
comments when adding karma.

moljac024
14th January 2008, 10:44 PM
I have just done a system update and the bug is fixed. Blender will now start with no problems. Great!