PDA

View Full Version : Wake from Suspend/Hibernate problem - F8 - Thinkpad T61p - Nvidia Quadro FX 570M



pklingem
27th November 2007, 04:57 PM
When I wake from suspend there is usually a blank screen with a pointer and occasionally a few small glitches on an otherwise blank screen. Sometimes I can type my password and hit enter and gnome will display correctly. Sometimes I can hit Ctrl-Alt-Backspace and the XServer will restart, and sometimes I have to reboot entirely.

When I wake from Hibernate it goes through the normal boot process and after udev I get a blank screen with a cursor and it hangs.

Has anyone else encountered these problems?

jrummy27
2nd December 2007, 07:39 PM
I have similar problem with an nVidia GeForce Go 7900 GS. It will suspend fine but when it comes back the screen is blank. Sometimes there is the mouse pointer and the keyboard is responsive (caps lock, num lock lights work). Other times it is locked up. I have never been able to kill X so a reboot is always required.

Digging around google and this forum looks like a lot of people have had this problem with livna drivers, yet I can't find any solution. It worked fine for me in F7 without configuration, so I am lost.

jrummy27
2nd December 2007, 08:15 PM
pklingem, are you using compiz-fusion? After some digging I tried without compiz enabled and suspend worked fine. That lead me to investigate it and I came across the sync to vblank setting for compiz. Disabling it has allowed me to suspend and resume normally (for the most part).

If you have fusion-icon, right click it and go to Settings Manager->General Settings->Display Settings->Sync to vblank = unchecked. Suspend works pretty well now, except for a few tries where the keyboard wasnt responsive, the or the mouse didnt work. Hope this helps.

pklingem
5th January 2008, 08:09 PM
Thanks for the response jrummy, I'll try it next time I use my thinkpad, that sounds like it will probably work!