PDA

View Full Version : error page printing



yonnieboy
26th November 2007, 10:22 AM
this printer keeps printing an error report every five minutes. How do I turn this off? I sent a test page print job from CUPS and instead of printing the test page the printer is printing this error report. Even after telling CUPS to cancel the print job, this printer is still wasting paper and ink.

Top of page says :
GET /favicon.ico HTTP/1.1
Host: 192-168.0.5:9100
....several more lines
Keep-Alive: 300
Connection: keep-alive

The printer keeps saying "printing", keeps loading another sheet, keeps printing the same error message

I installed a network printer in CUPS as:
http://192.168.0.5:9100
and used an hplip driver for the printer model hp officejet pro L7700.

twn250
26th November 2007, 04:13 PM
Hello!

Not a expert at this, but have you tried restarting CUPS, and if that did not help restart your computer and printer.

yonnieboy
26th November 2007, 08:54 PM
restarting the computer seemed to resolve the problem last nite. restarting the computer this morning did not resolve problem. I had to get into cups and cancel print jobs and go to printer and do same several times, plus restart computer again. Still can't get a test page to print, just an error page. something with the configuration I think. The hp device manager says there are no hp devices installed. If I run cups and wade through the configuration it says printer installed, I click on print test page and it says printing not allowed.

Looking through the instruction pages it says hp usually wants to use port 9100, on the cups pages it seems to want port 631. I've tried both. I've also tried "ipp://192.168.0.5:9100" and "ipp://192.168.0.5/ipp/9100 and the http: variations of same data. Nothing seems to work, now I'm not even getting the error page.

What really weird is my other system (debian) won't print anymore. It was set up with the basic driver hpijs using sockets. It didn't access the scanner/fax stuff, but did do a nice job of printing. Windows xp on other computers still works with the printer. printer is a network printer using a wireless connection to a router.

yonnieboy
7th December 2007, 06:29 AM
Okay, I've got CUPS version 1.2.12. (it's whatever came with FC6) I've downloaded and ran hplip.2.7.10. My original mistake was being in root mode at the time. (there was a reason, don't remember what now)

anyway, I couldn't get HP Device Manager to run. So I finally tried it as root, it came up part way, but still wouldn't install the printer. So I trashed it all and started over as a user.

Now I have a slightly different problem. I can get the HP device manager to start up in user mode but then I get a message about "Unable to find an appropriate su/sudo utility to run HP setup".

I suspect the darn program is wanting su privileges but I'll be damned if I can figure out how to do that. I've tried logging out and back in as root, still same problem.

I'm also stuck at trying to install a newer version of CUPS, rpmbuild won't work and the package manager refuses to find the file.

Can somebody who knows a little more about this give me a hand?