PDA

View Full Version : Install Mplayer (missing libx264.so.55) on Fedora 8?



sddmack
26th November 2007, 05:29 AM
I upgrade from 7 to 8 and had to do so without Mplayer. Now when I try to install I get:


[root@localhost sdering]# yum install mplayer mplayer-gui mplayer-skins mplayer-fonts mplayerplug-in mencoder
Loading "protectbase" plugin
Excluding Packages from Livna for Fedora Core 8 - i386 - Base
Finished
70 packages excluded due to repository protections
Setting up Install Process
Parsing package install arguments
No package mplayer-gui available.
Resolving Dependencies
--> Running transaction check
---> Package mplayerplug-in.i386 0:3.40-1.fc7 set to be updated
---> Package mencoder.i386 0:1.0-0.36.rc1try2.fc8 set to be updated
--> Processing Dependency: libmad.so.0 for package: mencoder
--> Processing Dependency: libx264.so.55 for package: mencoder
---> Package mplayer-fonts.noarch 0:1.1-3.fc set to be updated
---> Package mplayer-skins.noarch 0:1.8-1 set to be updated
---> Package mplayer.i386 0:1.0-0.36.rc1try2.fc8 set to be updated
--> Processing Dependency: libx264.so.55 for package: mplayer
--> Running transaction check
---> Package libmad.i386 0:0.15.1b-5.lvn8 set to be updated
---> Package mplayer.i386 0:1.0-0.36.rc1try2.fc8 set to be updated
--> Processing Dependency: libx264.so.55 for package: mplayer
---> Package mencoder.i386 0:1.0-0.36.rc1try2.fc8 set to be updated
--> Processing Dependency: libx264.so.55 for package: mencoder
--> Finished Dependency Resolution
Error: Missing Dependency: libx264.so.55 is needed by package mplayer
Error: Missing Dependency: libx264.so.55 is needed by package mencoder
[root@localhost sdering]#

Thanks

scottro
26th November 2007, 06:27 AM
Most of the mplayer stuff is from the livna repos. I assume you have a good reason to exclude them--is it possible to include them for this update?
Or, if not, and mplayer is working for you, just do something like yum update --exclude mplayer.

sddmack
26th November 2007, 08:58 AM
I was able to get the rpm for libx264.so.55 here (http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/libx264.so.55) and installed it. After that, Mplayer installed just fine.

Thanks