PDA

View Full Version : Compiz with nvidia



sharique
25th November 2007, 08:16 PM
I have Athalon x2 4000+, Asus A2N MX SE M/B.
I have installed driver from official nvidia site, and when try to enable Compiz, It says unable to enable desktop effect.
Whats' wrong, driver is working perfectly.

Crito
25th November 2007, 08:27 PM
Had same problem here. The driver from Livna works with Compiz, however. Unfortunately the Livna driver gets borked if you've already compiled the one from nvidia... long story short, that's why I reinstalled F8 the first time -- second time was because of SELinux (which has caused me more trouble in two months than hackers have in two years).

drobbins
27th November 2007, 12:06 AM
Hello All

64 bit newbie here
what's the deal with software from repos like livna?
do you just pull the packages the same as for 32 bit Fedora?
what does it do, some kind of emulation?
just got 64 bit F8 installed and looking to get video working

Dave

Fedoreuser
27th November 2007, 12:28 AM
su
yum instal kmod-nvidia
then enable desktop effects, buy u can't configure they, only 2 options
go there if u need more effects
http://forums.fedoraforum.org/forum/showthread.php?t=173317&highlight=compiz

Seve
27th November 2007, 12:36 AM
I have Athalon x2 4000+, Asus A2N MX SE M/B.
I have installed driver from official nvidia site, and when try to enable Compiz, It says unable to enable desktop effect.
Whats' wrong, driver is working perfectly.
Hello:
If you installed the drivers from nVidia's site then you need to add a couple of entries to your /etc/X11/xorg.conf
to enable the ability to use compiz correctly


Section "Extensions"
Option "Composite" "Enable"
EndSection
and to the

Section "Screen"
Option "AddARGBGLXVisuals" "True"

See here for more details : HOWTO: Compiz with NVIDIA Graphics Drivers (http://www.nvnews.net/vbulletin/showthread.php?t=77030)

If you use the rpm pakcages from Livna, then these amendments to your /etc/X11/xorg.conf file are taken care of during the isntallation.

Seve

Thetargos
27th November 2007, 01:30 AM
Had same problem here. The driver from Livna works with Compiz, however. Unfortunately the Livna driver gets borked if you've already compiled the one from nvidia... long story short, that's why I reinstalled F8 the first time -- second time was because of SELinux (which has caused me more trouble in two months than hackers have in two years).

You don't need to reinstall the whole system, only ONE package. After you uninstall the nvidia driver running nvidia-installer --uninstall, you will need to re-install (forcing the installation) the Xserver package, as some critical libs (libglx.so, and libdri.so IIRC) are overwritten by the nvidia package, once you do that (download the package, then re-install with rpm -Uvh --force) you can re-install the livna package. You will need (if you want a GUI to do this) to use the vesa or nv drivers to be able to launch X.