View Full Version : NVidia driver install causing boot "Starting udev" hang

25th November 2007, 04:52 PM
* Toshiba Satellite M35-S456 laptop
* F8 stock install from DVD
* NVidia GeForce FX Go5200 32M/64M card
- stock install installs "nv" driver

To try to get configuration options to be able to adjust lcd brightness on my laptop, I installed kmod-nvidia from livna, and now my laptop f8 boot hangs on "Starting udev". From googling, I've tried
* disabling selinux - didn't work
* rescue mode - tried putting the old "nv" /etc/X11/xorg.conf back in place - didn't work

I'm now stuck - can't boot into f8 at all - always hangs at "Starting udev".

Any help is appreciated.


25th November 2007, 05:20 PM
This doesn't seem like a kmod-nvidia problem, it does seem like a kernel problem. What other updates did you do along with adding kmod-nvidia? Can you boot into an older kernel?
If you don't get a grub screen when you boot, boot the cd in rescue mode and chroot into /mnt/sysimage/ and edit your grub.conf with nano, add a # infront of the line hiddenmenu, save and reboot selecting an older kernel and see how far you get.

25th November 2007, 05:29 PM
Thanks jbkt23 for replying! I *did* do 'yum update' in the same session where I installed kmod-nvidia - not sure what was installed then, but I should be able to find out - I'll post it here. Also I'll try booting into older kernel and see what happens.

25th November 2007, 09:01 PM
The most recent kernel ( is the one that now hangs booting on "Starting udev" - I screwed it up by doing 'yum update' and also in the same session did 'yum install kmod-nvidia xorg-x11-drv-nvidia'.

I booted into the next older kernel ( - booted fine, then did
yum install kmod-nvidia-
nvidia-config-display enable
service nvidia restart

and everything is working in that older kernel.

Does that mean that there's a problem with the kernel?

25th November 2007, 11:06 PM
I have had the experience that some kernel updates have corrupt initrd images. Do the following as root in the /boot directory:
cp initrd2.6.23.1-49.fc8.img initrd2.6.23.1-49.fc8.img.old
mkinitrd initrd2.6.23.1-49.fc8.img
then reboot and see if it worked. Other than that I don't know what else to suggest.

26th November 2007, 01:42 AM
I used rescue mode from the fc8 DVD, chroot'd to /mnt/sysimage, cd /boot and found *nothing* at all in /boot - so the mkinitrd failed. My /lib/modules shows both and, but /boot has nothing. Not sure what this indicates...

26th November 2007, 02:58 AM
I'm confused, so what is in boot? Why did you need to use the rescue disk when you can boot into the prior kernel?

26th November 2007, 01:09 PM
Sorry, stupid of me. Ok, I booted the older kernel, moved the newer out of the way, and did the mkinitrd - been a LONG time since I've created an image so I didn't remember how long it takes. After waiting a 1/2 hour I finally wanted to go to bed so I killed it. This is on a 3 year old Toshiba 1.6 ghz processor - any idea how long the mkinitrd might take - an hour? I'll do it again tonight when I can let it go for a while ;-)

26th November 2007, 03:37 PM
Do you use ndiswrapper as the driver for your wireless card on the laptop? The kernel caused my laptop to hang on udev due to ndiswrapper - recompiling the kernel without the 4k stacks module fixed the problem.

26th November 2007, 05:51 PM
No I don't use ndiswrapper - I use ipw2200. But thanks.

27th November 2007, 02:11 AM
No joy - I created the -49 image, but trying to boot that now gives a different error. I'm wondering if my killing the first mkinitrd screwed something up. I can't devote any more time to this now that I have a working kernel (-42). I'm going to wait for the next kernel update before trying again.

27th November 2007, 04:47 AM
Sorry, I was in NY all day so couldn't respond, not that I have a solution. The mkinitrd command should take less then 30 seconds to run on you chip. So if it is hanging then you are going to have the same problem with successive kernel updates. I think we need more info about your system. The way the initrd image is made on the initial install is different than how it is made in updates. There are threads on this subject here on the forum that you can search for and also on bugzilla.
What yum repos do you use? Do you have software installed that did not originate from fedora repos?