PDA

View Full Version : Grip mp3 path



crainey69
25th November 2007, 04:06 PM
I could probably spend a day trying to figure this out but, hopefully, someone can give me an answer quickly.

I set up grip to rip a CD as mp3's and it appeared to work successfully but never found a way to set the path of where to put the files. I thought I would just find them after it was done. Can't

Can anyone help me set the path for the rip?

Thanks in advance

Cory

SuperNu
25th November 2007, 04:48 PM
There are two places you could setup for grip to rip and encode files. The first is where grip places the files after it rips them from the cd and before it encodes them. You need to click on the Config tab, then click on the Rip tab, then click on the Ripper tab. There should be a line called "Rip file format". This is where you can tell grip to place the ripped files. My line says "/mp3/%A/%d/%t - %n.wav" without the quotes. What this does is places the .wav files in the mp3 directory with an artist directory then disc name directory beneath that. The files are named "track number - track name.wav" without the quotes. If you click on the Config tab and then the Encode tab, under the Encoder tab there is a line called "Encode file format". This is where you tell grip to place the encoded files. My line says "/mp3/%A/%d/%t - %n.mp3" again without the quotes and the directory structure is the same. Hope this helps.

Edit:
Also, be sure to check out section 4.8 of the help document for information on the different Configuration (%) switches grip uses. I get there by clicking on the Help tab and then on the Configuring Grip button.

--SN

crainey69
25th November 2007, 05:03 PM
Can anyone help me with setting the defaults? By default, it doesn't save to the directory I want or use id3 tags on the files.


Thanks again

Cory

SuperNu
25th November 2007, 06:38 PM
In order to add id3 tags into your files, you need to click on the Config tab then the ID3 tab. I have checked all three option boxes, "Add ID3 tags to encoded files", "Add ID3v2 tags to encoded files" and "Only tag files ending in '.mp3'". The "ID3 comment field" text box is empty, the "ID3v1 Character set encoding" text box is set to "UTF-8" and "ID3v2 Character set encoding" text box is set to "LATIN1".

What directory are you trying to get your ripped files into? What is listed under the Rip and Encode tabs under the Config tab?

You might need to restart grip in order for these changes to take effect.

--SN

crainey69
25th November 2007, 06:45 PM
rip dir was /mnt/..../music.

I just exited and reopened Grip and now it seems to work fine. Thanks!