PDA

View Full Version : No sound on youtube; also not receiving updates



moljac024
24th November 2007, 08:58 PM
Hi,i have no sound when i play videos at youtube.com

I think that this could be related to the java version, because i noticed (while installing some software) that a new java was downloaded (kind of confusing since it was iced tea 1.7.0 java - thought that was already installed). How could i troubleshoot this without installing sun's java ?

My other problem is that everytime i try 'yum update' i get 'no packages obsolete' message. I'm just not buying the fact that there have been no package updates for fedora in the last few days. :D

Any help will be appreciated, thanks!

fozner
25th November 2007, 03:21 PM
Youtube is flash, not java. Flash plays through the sound system like normal. If you'reusing Fedora 8, the system is pulseaudio.

If you're not using Fedora 8...ignore this!

I think the settings for kde are in kde-settings-pulseaudio.noarch

As for gnome, I just load pulseaudio -D into my user's session (System->Preferences->Personal->Sessions).

Quite frequently, pulseaudio will refuse to start after a reboot, power failure or whenever it feels like. You need to remove /tmp/pulse*/pid and try again. So your actual startup script might look like mine (looks like a hack. somebody correct me!)

pulseaudio -k
rm /tmp/pulse*/pid
pulseaudio -D

As for the other thing, it looks like there are indeed no updates available. This sometimes happens around the holidays.


Try typing this in the terminal:

pulseaudio -D

If that works, add it to your window manager's startup or hunt around for the rpm package that does it, pulseaudio-kde or pulseaudio-gnome, I think, since I don't have it either!

These are the default packages, since this is a fresh Fedora 8 install:

$ alias rq='rpm -qa --nodigest --nosignature| grep -i'
$ rq pulse
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8.i386
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8.i386
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8.i386
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8.i386
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8.i386
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8.i386
pulseaudio-0.9.7-0.17.svn20071017.fc8.i386
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8.i386
alsa-plugins-pulseaudio-1.0.14-5.fc8.i386
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8.i386

moljac024
25th November 2007, 10:30 PM
I now that it is flash but that same day i tried opening youtube on a computer at college and it wouldn't play stating that i either didn't have flash or java enabled. So i thought it could be SOMEHOW related to java....nevermind, thought it was pulseaudio (since it wasn't in the default install ,i used fedora8 live cd with KDE, and i added it later via yum), will try to configure that...
Although i do get sound everywhere else, it's just youtube that is silent but if it won't work i'll just remove pulseaudio alltogether....

Thanks!

Strange about the updates though... :)

CD-RW
25th November 2007, 11:10 PM
Try running X and KDE as root, and see if you get any sound then with FlashPlayer and Firefox? If so, this may be a permissions problem on the audio device files.

http://forums.fedoraforum.org/showthread.php?t=173519

Netbeans has some nice flash downloads I like to use for testing:

http://www.netbeans.org/kb/55/flash.html

moljac024
25th November 2007, 11:54 PM
i installed the package "libflashsupport" and that solved the sound issue for flash!