PDA

View Full Version : linux newbie: problem with xorg.conf with VIA technologies VT8378 s3 unichrome



Cedar
24th November 2007, 07:15 PM
hello, i am new to linux, just put fedora 8 i386 on my system and determined to stick to it, removed windows completely and done with it.

when i first installed fedora 8, i noticed desktop effects was not enabling. so i downloaded all the packages regarding compiz -fusion and emerald theme manager, desktop effects was still not enabling i did some research on my integrated graphics card, and found that compiz-fusion will not work with my card, i was a little dissapointed as i was very fascinated by the 3d effects. i got over the fact that it wont work but i realized a bigger problem, emerald theme manager does nothing on my system, when i click on a theme to enable it, nothing happens, and when i try "emerald --replace" nothing happens either. however when i type "compiz --replace" it brings my back to my fedora login gui. above that my general GUI "level 5" runs slow, windows lag when moved around and things are not as smooth as they were on xp. i read up on it and played around with my xorg.conf file. the driver was set on "via", i changed that to "vesa" and my x-server stopped working, at that point i removed xorg.conf (i was told that by removing it, fedora will revive the original xorg.conf file), and i am guessing it did because im able to run level 5 again, however when i look for the file i cannot find it, it is missing "gedit /etc/X11/xorg.conf" gives me a blank document, and when i look for the file in my file system it doesnt exist.

at that point downloaded and installed "openchrome" and nothing happened either.

my question is how can i revive my xorg.conf, and what can i do to make my fedora 8 run smoothly and be able to run emerald theme manager and if possible compi-fusion.

here is my /sbin/lspci:

[root@localhost ~]# /sbin/lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0a.0 Communication controller: Agere Systems V.92 56K WinModem (rev 03)
00:0b.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video (rev 01)


can someone please help me out i am really willing to put alot of effort into this.

cheers!

Cedar
24th November 2007, 09:39 PM
update:

here is my glxinfo (direct rendering says enabled):

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: VIA Technology
OpenGL renderer string: Mesa DRI UniChrome (KM400) 20060710 x86/MMX+/3DNow!+/SSE
OpenGL version string: 1.2 Mesa 7.0.2
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, GL_ARB_window_pos,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_compiled_vertex_array, GL_EXT_convolution, GL_EXT_copy_texture,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_histogram,
GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_polygon_offset,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
GL_APPLE_packed_pixels, GL_IBM_rasterpos_clip,
GL_IBM_texture_mirrored_repeat, GL_MESA_window_pos, GL_NV_blend_square,
GL_NV_light_max_exponent, GL_NV_texgen_reflection, GL_OES_read_format,
GL_SGI_color_matrix, GL_SGI_color_table, GL_SGIS_texture_edge_clamp,
GL_SGIS_texture_lod

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x22 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x23 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x24 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 0 0 0 0 0 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 0 0 0 0 0 0 None
0x26 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x27 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 None
0x28 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x2a 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 Slow
0x2b 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 Slow
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 Slow
0x47 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 Ncon


and here is partial glxgears output: (when glxgears window maximized, low fps, when minimized high fps):

2291 frames in 5.0 seconds = 458.111 FPS
2353 frames in 5.0 seconds = 470.428 FPS
2357 frames in 5.0 seconds = 471.312 FPS
2387 frames in 5.0 seconds = 477.362 FPS
2361 frames in 5.0 seconds = 472.048 FPS
2387 frames in 5.0 seconds = 477.322 FPS
2360 frames in 5.0 seconds = 471.996 FPS
2387 frames in 5.0 seconds = 477.390 FPS
11482 frames in 5.0 seconds = 2296.294 FPS
17038 frames in 5.0 seconds = 3407.500 FPS
14580 frames in 5.0 seconds = 2915.139 FPS
13403 frames in 5.0 seconds = 2680.597 FPS
16540 frames in 5.0 seconds = 3307.939 FPS
16877 frames in 5.0 seconds = 3375.262 FPS
17572 frames in 5.0 seconds = 3514.243 FPS
17967 frames in 5.0 seconds = 3593.268 FPS
17657 frames in 5.0 seconds = 3531.342 FPS
17966 frames in 5.0 seconds = 3593.061 FPS
17657 frames in 5.0 seconds = 3531.248 FPS
17687 frames in 5.0 seconds = 3537.234 FPS
17928 frames in 5.0 seconds = 3585.532 FPS
16831 frames in 5.0 seconds = 3366.200 FPS
14868 frames in 5.0 seconds = 2973.515 FPS
16496 frames in 5.0 seconds = 3299.168 FPS
16764 frames in 5.0 seconds = 3352.732 FPS
12162 frames in 5.0 seconds = 2432.348 FPS
3365 frames in 5.0 seconds = 672.966 FPS
2483 frames in 5.0 seconds = 496.449 FPS
3607 frames in 5.0 seconds = 721.383 FPS
10420 frames in 5.0 seconds = 2083.944 FPS
10218 frames in 5.0 seconds = 2043.462 FPS
12729 frames in 5.0 seconds = 2545.766 FPS
17629 frames in 5.0 seconds = 3525.712 FPS
16756 frames in 5.0 seconds = 3351.145 FPS
16959 frames in 5.0 seconds = 3391.797 FPS
16683 frames in 5.0 seconds = 3336.569 FPS
16755 frames in 5.0 seconds = 3350.892 FPS
15164 frames in 5.0 seconds = 3032.748 FPS

hope any of this helps!

Cedar
25th November 2007, 07:53 PM
all that i have said so far has been over a gnome session, i just ran KDE environment and for some reason its running alot smoother..? so i tried compiz --replace in terminal and it gave me the following fatal error, aftar that i tried emerald --replace and the windows jammed, still waiting a reply i hope someone has an idea of what i can do because i am feeling kind of hopeless right now...here is my output:

[Majd@localhost ~]$ compiz --replace
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
[Majd@localhost ~]$ emerald --replace
Reloading...
Reloading...
Reloading...
Reloading...

Cedar
26th November 2007, 06:51 AM
also...:

[root@localhost ~]# Xorg -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

CrystalCowboy
26th November 2007, 10:30 PM
I'm attaching an xorg.conf from a system that is using the "openchrome" driver. Nothing fancy, but it appears stable with a 1280x1024 LCD monitor.

Cedar
2nd December 2007, 01:22 AM
Crystal thanks for the reply i appreciate it...so i didnt know how to copy the file into my X11 folder but i created a blank one and copied the text from your file into it. After that i rebooted the computer and it seems like nothing happened at all, the windows still lag when moved around and the system is just running slow in general. I was thinking maybe its just my hardware in general but i figured cmon it cant be that bad...windows xp was running fine on it. do u suggest anything i can do? here are my system specs aswell:

Motherboard Part / Feature Specification / Support
Motherboard Description Mb manufacturer name: ASUS A7V8X-LA

HP/Compaq name: Kelut-GL6E
CPU Socket A

AMD Athlon XP

Core frequency up to Athlon XP 3200+
Chipset VIA KM400A

VIA VT8237
Front Side Bus (FSB) 400 / 333 / 266 MHz
Memory 2 x 184-pin DDR DIMM sockets

Support up to maximum 2 GB memory (PC manufacturer's maximum memory may differ)

Supports unbuffered PC2700/2100 non-ECC DDR SDRAM memory
Expansion Slots Three PCI slots

One AGP 8x/4x (1.5V)
Storage Two UltraDMA 100 IDE connectors

Two Serial ATA connectors
Integrated Graphics VIA UniChrome graphics
Audio Realtek AL658 six-channel AUDIO CODEC

Digital audio via an S/PDIF out interface
LAN Southbridge integrated 10/100 Mbps

VT6103 LAN PHY
Hardware Monitoring Super I/O integrated monitoring of: CPU/chassis fan, MB/CPU temperature
Rear Panel I/O Ports One Parallel

One Serial

One PS/2 Keyboard

One PS/2 Mouse

One RJ45 port

One Audio I/O

One VGA

One IEEE 1394

Four USB 2.0/1.1 (Two connectors)
Internal I/O Two USB connectors support additional four USB 2.0 ports

One IEEE 1394 connector for an additional IEEE 1394 port

CPU/chassis fan connectors

20-pin ATX power connector

Front panel connector

CD/AUX connectors

Front panel audio connector
BIOS Features 4Mb Flash ROM

Award BIOS

Enhanced ACPI

DMI 2.0

Green features

PnP features
Industry Standard PCI 2.2

USB 2.0/1.1
Manageability WOL

WOR

Wake on PS/2 mouse
Support CD Contents Device drivers

ASUS PC Probe

ASUS Screensaver

Award BIOS Flash Utility

Adobe Acrobat Reader

Trend Micro PC-cillin 2002
Form Factor Micro-ATX form factor: 9.6 inches x 9.6 inches (24.38 cm x 24.38 cm)