PDA

View Full Version : Trying to install Nvidia Driver



coup_detat
24th November 2007, 06:11 PM
Following the instructions on Nvidia's site to install the video driver I get the following message:

ERROR: You appear to be running an X server; please exit X before installing.
For further details, please see the section INSTALLING THE NVIDIA DRIVER
in the README available on the Linux driver download page at
www.nvidia.com.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.\

I run the following command:

./NVIDIA-Linux-x86-100.14.19-pkg1.run and get this:

NVIDIA Accelerated Graphics Driver for Linux-x86 (100.14.19)





ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at www.nvidia.com.

OK










NVIDIA Software Installer for Unix/Linux www.nvidia.com




I also get this from the setroubleshooter:

Summary
SELinux is preventing /usr/bin/Xorg (xdm_xserver_t) "write" to /var/log
/nvidia-installer.log (var_log_t).

Detailed Description
SELinux is preventing /usr/bin/Xorg (xdm_xserver_t) "write" to /var/log
/nvidia-installer.log (var_log_t). The SELinux type var_log_t, is a generic
type for all files in the directory and very few processes (SELinux Domains)
are allowed to write to this SELinux type. This type of denial usual
indicates a mislabeled file. By default a file created in a directory has
the gets the context of the parent directory, but SELinux policy has rules
about the creation of directories, that say if a process running in one
SELinux Domain (D1) creates a file in a directory with a particular SELinux
File Context (F1) the file gets a different File Context (F2). The policy
usually allows the SELinux Domain (D1) the ability to write or append on
(F2). But if for some reason a file (/var/log/nvidia-installer.log) was
created with the wrong context, this domain will be denied. The usual
solution to this problem is to reset the file context on the target file,
restorecon -v /var/log/nvidia-installer.log. If the file context does not
change from var_log_t, then this is probably a bug in policy. Please file a
http://bugzilla.redhat.com/bugzilla/enter_bug.cgi against the selinux-policy
package. If it does change, you can try your application again to see if it
works. The file context could have been mislabeled by editing the file or
moving the file from a different directory, if the file keeps getting
mislabeled, check the init scripts to see if they are doing something to
mislabel the file.

Allowing Access
You can attempt to fix file context by executing restorecon -v /var/log
/nvidia-installer.log

The following command will allow this access:
restorecon /var/log/nvidia-installer.log

Additional Information

Source Context unconfined_u:system_r:xdm_xserver_t:s0
Target Context unconfined_u:object_r:var_log_t:s0
Target Objects /var/log/nvidia-installer.log [ file ]
Affected RPM Packages xorg-x11-server-Xorg-1.3.0.0-33.fc8 [application]
Policy RPM selinux-policy-3.0.8-44.fc8
Selinux Enabled True
Policy Type targeted
MLS Enabled True
Enforcing Mode Permissive
Plugin Name plugins.mislabeled_file
Host Name localhost.localdomain
Platform Linux localhost.localdomain 2.6.23.1-42.fc8 #1 SMP
Tue Oct 30 13:55:12 EDT 2007 i686 athlon
Alert Count 3
First Seen Sat 24 Nov 2007 01:58:43 AM EST
Last Seen Sat 24 Nov 2007 11:48:54 AM EST
Local ID 48624064-3d66-4dd4-b802-cc2de4fb4fe9
Line Numbers

Raw Audit Messages

avc: denied { write } for comm=X dev=dm-0 egid=0 euid=0 exe=/usr/bin/Xorg exit=0
fsgid=0 fsuid=0 gid=0 items=0 path=/var/log/nvidia-installer.log pid=22185
scontext=unconfined_u:system_r:xdm_xserver_t:s0 sgid=0
subj=unconfined_u:system_r:xdm_xserver_t:s0 suid=0 tclass=file
tcontext=unconfined_u:object_r:var_log_t:s0 tty=pts1 uid=0

Seve
24th November 2007, 07:13 PM
Hello:
Follow this guide for setting up your Fedora 7 or 8 installation (including the nVidia drivers) and you should be good to go.
http://www.freewebs.com/dnmouse/index.htm

Seve

iamzen
25th November 2007, 01:59 AM
You are trying to do it the hard way and I can tell you that from experience with my nvidia cards. First, make sure to add the Livna (http://rpm.livna.org/rlowiki/) repository. Go to the terminal and do:
su -
yum -y install kmod-nvidia

When you reboot(best thing to do) or restart your x-server(ctrl+alt+backspace), you will be running the updated newest driver from nvidia plus you will have it in your system to be updated with the kernel, etc.

As a safety, you might want to add Option "HWCursor" "off" to your /etc/X11/xorg.conf file in case you have one of them that has the cursor turning invisible problem. Here is where I made the change in mine:
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "HWCursor" "off"

coup_detat
25th November 2007, 03:35 AM
You are trying to do it the hard way and I can tell you that from experience with my nvidia cards. First, make sure to add the Livna (http://rpm.livna.org/rlowiki/) repository. Go to the terminal and do:
su -
yum -y install kmod-nvidia

When you reboot(best thing to do) or restart your x-server(ctrl+alt+backspace), you will be running the updated newest driver from nvidia plus you will have it in your system to be updated with the kernel, etc.

As a safety, you might want to add Option "HWCursor" "off" to your /etc/X11/xorg.conf file in case you have one of them that has the cursor turning invisible problem. Here is where I made the change in mine:
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "HWCursor" "off"
I tried what you said and this is what I got:

[whumphrey@localhost ~]$ su
Password:
[root@localhost whumphrey]# yum -y install kmod-nvidia
Setting up Install Process
Parsing package install arguments
No package kmod-nvidia available.
Nothing to do
[root@localhost whumphrey]#

coup_detat
25th November 2007, 03:46 AM
Hello:
Follow this guide for setting up your Fedora 7 or 8 installation (including the nVidia drivers) and you should be good to go.
http://www.freewebs.com/dnmouse/index.htm

Seve

This is what wound up working for me, figured I'd include what I saw in case anyone else uses this advice:

[root@localhost whumphrey]# rpm -ivh http://rpm.livna.org/livna-release-8.rpm
Retrieving http://rpm.livna.org/livna-release-8.rpm
warning: /var/tmp/rpm-xfer.yZ6JFh: Header V3 DSA signature: NOKEY, key ID a109b1ec
Preparing... ########################################### [100%]
1:livna-release ########################################### [100%]
[root@localhost whumphrey]# yum -y install kmod-nvidia xorg-x11-drv-nvidia-libs-32bit
fedora 100% |=========================| 2.1 kB 00:00
livna 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 129 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
Setting up Install Process
Parsing package install arguments
No package xorg-x11-drv-nvidia-libs-32bit available.
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.i686 0:100.14.19-18.lvn8 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.23.1-49.fc8 for package: kmod-nvidia
--> Running transaction check
---> Package kmod-nvidia-2.6.23.1-49.fc8.i686 0:100.14.19-18.lvn8 set to be updated
--> Processing Dependency: nvidia-kmod-common >= 100.14.19 for package: kmod-nvidia-2.6.23.1-49.fc8
--> Running transaction check
---> Package xorg-x11-drv-nvidia.i386 0:100.14.19-4.lvn8 set to be updated
--> Processing Dependency: livna-config-display for package: xorg-x11-drv-nvidia
--> Processing Dependency: livna-config-display for package: xorg-x11-drv-nvidia
--> Running transaction check
---> Package livna-config-display.noarch 0:0.0.19-2.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
kmod-nvidia i686 100.14.19-18.lvn8 livna 21 k
Installing for dependencies:
kmod-nvidia-2.6.23.1-49.fc8 i686 100.14.19-18.lvn8 livna 2.1 M
livna-config-display noarch 0.0.19-2.fc8 livna 64 k
xorg-x11-drv-nvidia i386 100.14.19-4.lvn8 livna 4.9 M

Transaction Summary
================================================== ===========================
Install 4 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 7.0 M
Downloading Packages:
(1/4): livna-config-displ 100% |=========================| 64 kB 00:00
(2/4): kmod-nvidia-2.6.23 100% |=========================| 2.1 MB 00:05
(3/4): xorg-x11-drv-nvidi 100% |=========================| 4.9 MB 00:12
(4/4): kmod-nvidia-100.14 100% |=========================| 21 kB 00:00
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID a109b1ec
Importing GPG key 0xA109B1EC "Livna.org rpms <rpm-key@livna.org>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-livna
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: livna-config-display ######################### [1/4]
Installing: kmod-nvidia-2.6.23.1-49.fc8 ######################### [2/4]
Installing: kmod-nvidia ######################### [3/4]
Installing: xorg-x11-drv-nvidia ######################### [4/4]

Installed: kmod-nvidia.i686 0:100.14.19-18.lvn8
Dependency Installed: kmod-nvidia-2.6.23.1-49.fc8.i686 0:100.14.19-18.lvn8 livna-config-display.noarch 0:0.0.19-2.fc8 xorg-x11-drv-nvidia.i386 0:100.14.19-4.lvn8
Complete!

There were 2 more steps in the walkthrough at the link provided in the quote I provided that did not need done and were actually unrecognized commands. I restarted X window system (Ctrl-Alt-Backspace) and the display was working perfectly!

Thanks again everyone!