PDA

View Full Version : Root Problem



avimish
24th November 2007, 04:15 PM
whenever i try to run an "rpm" file or anything that requires entering my "root" PASSWORD
nothing shows up except the demand for password and afterwords nothing... what should i do?

bob
24th November 2007, 04:45 PM
Try changing it first: "passwd" (as root).

avimish
24th November 2007, 10:36 PM
sorry i'm new can you explain alittle more....thank's/

bob
24th November 2007, 10:45 PM
Perhaps there's a problem with the password that you typed; that it's somehow not recognized. What I was suggesting is to change the password. If you open a terminal and type in "su -" and give that password, you should see your designation change from your username to 'root'. If you want to change the root password, then the command is "passwd", which tells you to type in a new password.

In any case, give us a few more details of your problem before doing anything. Can you open a terminal and type "su -", followed by your password and then "yum update"? What's the response?

avimish
25th November 2007, 07:02 AM
o.k i'll try and tell you what happend... thank
by theway wha is gcc installer?

forkbomb
25th November 2007, 07:11 AM
by theway wha is gcc installer?

http://en.wikipedia.org/wiki/GNU_Compiler_Collection

avimish
25th November 2007, 10:12 AM
http://en.wikipedia.org/wiki/GNU_Compiler_Collection
i ran "yum update" and it did o.k updated the yum(what is yum?) . and changed the password and everything is the same/

please help ,,,,,thank's.

forkbomb
25th November 2007, 11:12 AM
i ran "yum update" and it did o.k updated the yum(what is yum?)
http://en.wikipedia.org/wiki/Yellow_dog_Updater%2C_Modified

Seriously... some of these questions can be answered with a modicum of searching.

If you managed to update yum, you were logged in as root. You have to be root to use yum (unless you setup sudo but that's a different matter entirely). So I'm wondering what the problem is here... :confused:

You said the original problem was with trying to install from an .rpm. Please try doing it again and post back your terminal output.

EDIT:
Standard procedure for installing from an .rpm file (e.g. one you got from a third-party site) is:


su -
cd /directory/where/rpm/is
rpm -ivh name-of-the-rpm.rpm

Of course, give your admin/root passward after su, substitute in what directory your rpm is in (e.g. /home/username/Download), and the proper name of the rpm.

avimish
25th November 2007, 08:06 PM
the .rpm file worked u think the problem us the software installer
because every which suppose to run there doesn't work such as new updates
and add/remove program ....waiting for your re;ly thank's for your paition