PDA

View Full Version : Problems with VMware Workstation 6.0.2 on FC8



hokousha
24th November 2007, 01:47 PM
This is specific enough that I thought I'd start another topic. My machine is running FC8 (2.6.23.1-49.fc8) and I've just downloaded VM Workstation 6.0.2. Installing via the RPM and running vmware-config.pl was, for the first time. completely smooth. No more patching, which is a big step forward.

However... some runtime problems. First, the vmware binary says it is unable to find its shared-object libraries. The installer puts these under individual directories (!?) in /usr/lib/vmware/lib, so they're not found by default, but adding each subdirectory to a conf file in /etc/ld.so.conf.d/ does the trick. Nevertheless, when I start up the program I then get the simple, unhelpful message:


No protocol specified


Has anyone found a way to remedy this? It seems strange that they'd work out all the other kinks but still leave it unworkable. I guess they didn't want to make it too easy...

tonyrodgers
12th February 2008, 01:57 PM
This is specific enough that I thought I'd start another topic. My machine is running FC8 (2.6.23.1-49.fc8) and I've just downloaded VM Workstation 6.0.2. Installing via the RPM and running vmware-config.pl was, for the first time. completely smooth. No more patching, which is a big step forward.

However... some runtime problems. First, the vmware binary says it is unable to find its shared-object libraries. The installer puts these under individual directories (!?) in /usr/lib/vmware/lib, so they're not found by default, but adding each subdirectory to a conf file in /etc/ld.so.conf.d/ does the trick. Nevertheless, when I start up the program I then get the simple, unhelpful message:


No protocol specified


Has anyone found a way to remedy this? It seems strange that they'd work out all the other kinks but still leave it unworkable. I guess they didn't want to make it too easy...
I have a similar problem on Fedora 8 (I had vmware workstation running fine on Fedora 7). I am using the latest build VMware-workstation-6.0.2-59824

After installation I was unable to configure vmware with the config script "/usr/bin/vmware-config.pl" (complained that it couldn't compile the module, etc)...

So I downloaded Petr Vandrovec's vmware-any-any-update115 and proceeded again with the vmware-config script. This time it completed OK. But when I run vmware (/usr/bin/vmware) I get this totally useless error message "No protocol specified" and nothing else...