PDA

View Full Version : something went kablooie



drobbins
23rd November 2007, 10:50 PM
I've been running F8 about a week now and everything was running great
I did an update an all hell broke loose :rolleyes:
I usually use KDE but all of a sudden when I boot the original login screen I see is different
it just has a square in the center with my account and a guest account in it
I don't even think there is a guest account (maybe there is)
there's no option to choose the session (kde vs gnome)
when I login I get Gnome and I'm lost
what controls that login screen? (which login manager runs)
I want my PC back :)

Dave

leigh123linux
23rd November 2007, 11:05 PM
Try


su
yum install gdm

drobbins
23rd November 2007, 11:14 PM
Yikes!! this thing went nuts :)
here's my grub.conf
it looks like it loaded a F9 kernel
when I load the F8 kernel X won't run
man, life is great on the bleeding edge :D



# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sdb
default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.24-0.41.rc3.git1.fc9)
root (hd0,0)
kernel /vmlinuz-2.6.24-0.41.rc3.git1.fc9 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.24-0.41.rc3.git1.fc9.img
title Fedora (2.6.23.1-49.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.23.1-49.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.23.1-49.fc8.img
title XP Professional
root (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1

drobbins
23rd November 2007, 11:18 PM
interesting



[root@C2 ~]# yum install gdm
http://rpm.livna.org/fedora/8.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://livna.cat.pdx.edu/fedora/8.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/8.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/8.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://mirror.atrpms.net/livna/fedora/8.90/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/8.90/i386/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] 550 Failed to change directory.
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: livna. Please verify its path and try again
[root@C2 ~]#

leigh123linux
23rd November 2007, 11:27 PM
Yikes!! this thing went nuts :)
here's my grub.conf
it looks like it loaded a F9 kernel
when I load the F8 kernel X won't run
man, life is great on the bleeding edge :D



# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sdb
default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.24-0.41.rc3.git1.fc9)
root (hd0,0)
kernel /vmlinuz-2.6.24-0.41.rc3.git1.fc9 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.24-0.41.rc3.git1.fc9.img
title Fedora (2.6.23.1-49.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.23.1-49.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.23.1-49.fc8.img
title XP Professional
root (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1



Life is tough when you are running F9 Rawhide ( fedora development )

you will need to re-install F8 to fix this :(

drobbins
23rd November 2007, 11:44 PM
Leigh

as usual, thanks for all the help
I don't much mind reinstalling, this box is a new toy I'm still breaking in, but from a technical standpoint, what the heck do you think went wrong?
you walked me through compiling cinelerra the other day, that worked great
then I think I installed k3b-extras-nonfree
then when pirut tried to do an update it gaged on libdvdread
somehow I got the idea to tell it not to update libdvdnav and it went ahead with the update
then I ended up with this :rolleyes:
heck, maybe I'll just go play with the 64 bit version a bit, I'd just like to know what went wrong
thanks for all the help, your past posts will get me back to where I was

DAve

leigh123linux
23rd November 2007, 11:52 PM
Some how you must have enabled the development repo ( did you play with the repo manager in pirut ?)

To prevent this happening again next time you could delete the development repo altogether !!

su
rm /etc/yum.repos.d/fedora-development.repo

drobbins
24th November 2007, 12:35 AM
well, I'm back up and running
install, upgrade, install, upgrade :)
I'll take your advice on the devel repos
it'll work if I just add an extension to them, right?
like fedora-devel-don't-use?

Dave

leigh123linux
24th November 2007, 12:47 AM
well, I'm back up and running
install, upgrade, install, upgrade :)
I'll take your advice on the devel repos
it'll work if I just add an extension to the, right?
like fedora-devel-don't-use?

Dave

That will work as well ( as long as it doesn't end with .repo )

drobbins
24th November 2007, 01:25 AM
well, as I put things back together, it appears to me that my problem had something to do with libdvdread from livna
it seems to have been installed with k3b-extras-nonfree
my problems occured after I installed that package
I can't say for sure but I don't think I'll reinstall it :)

Dave