PDA

View Full Version : F8 Sun/java nightmare; Uninstallation HELP;



mircobeaker
23rd November 2007, 08:12 AM
I followed the instructions i found in the fedoraguide site on how to install sun java on fedora 8.
All went well and I selected the new installed java as number 2 in the list. The other version I have installed is the icedtea versio
I then downloaded Vuze/Azureus onto my home folder and as I usually do I run the sh from there and it all just works. This time the app opended and I followed the setup wizard.
Once the Vuze completed the setup wizard the program stayed open for a couple of seconds and then crashed disappearing away.
i tried removing the .azureus folder that it created and re running the sh script for it but it warned that Azureus did not close down tidily and a couple of seconds after It crashed again disappearing away.
I removed the Vuze folder from my home folder and then installed the azureus version via yum. it installed but if I try and tun it won't open.
how can I uninstall completely the verions of Java I installed along with the default one?

Thanks

Mirco

LLS
23rd November 2007, 08:34 AM
The sun java should work if you apply the fix from here-
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jdk1.6.0_03/jre/lib/i386/xawt/libmawt.so
and maybe
sudo yum install compat-libstdc++*

To uninstall Yum remove java for the native stuff and
and alternatives --remove "your java" for the sun stuff

Imiro
13th January 2008, 05:23 PM
I'd also be instrested if theres an easy way to completely demolish all non-sun java features?

I've done this by removing stuff from path and deleting entries from the "handy" java switcher app and finally deleting what directories i could find.

Very annoying to uncheck all java and gnome etc. packages during installation and having them faithfully appear back. I suppose if dependencies were needed, there would have been a notification :confused: