PDA

View Full Version : k9copy crashes



slade17
23rd November 2007, 06:38 AM
[colin@dhcp-169-196 ~]$ k9copy
kbuildsycoca running...
DCOP Cleaning up dead connections.

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:547 ***
*** for vtsi_mat->vtsm_vobs == 0 || (vtsi_mat->vtsm_vobs > vtsi_mat->vtsi_last_sector && vtsi_mat->vtsm_vobs < vtsi_mat->vts_last_sector) ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:550 ***
*** for vtsi_mat->vtstt_vobs == 0 || (vtsi_mat->vtstt_vobs > vtsi_mat->vtsi_last_sector && vtsi_mat->vtstt_vobs < vtsi_mat->vts_last_sector) ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:1568 ***
*** for c_adt->cell_adr_table[i].vob_id <= c_adt->nr_of_vobs ***

*** buffer overflow detected ***: k9copy terminated
======= Backtrace: =========
/lib64/libc.so.6(__fortify_fail+0x32)[0x364f6ea362]
/lib64/libc.so.6[0x364f6e8a90]
/lib64/libc.so.6[0x364f6e7ef9]
/lib64/libc.so.6(_IO_vfprintf+0x457e)[0x364f64733e]
/lib64/libc.so.6(__vsprintf_chk+0x9d)[0x364f6e7f9d]
/lib64/libc.so.6(__sprintf_chk+0x80)[0x364f6e7ee0]
k9copy[0x472e28]
k9copy[0x42c792]
k9copy[0x45783d]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectio nListP8QUObject+0x149)[0x394a563a59]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEi+0xb0)[0x394a564730]
/usr/lib64/libkdeui.so.4(_ZN7KAction9qt_invokeEiP8QUObject+0x 211)[0x394bed67d1]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectio nListP8QUObject+0x149)[0x394a563a59]
/usr/lib64/libkdeui.so.4(_ZN14KToolBarButton13buttonClickedEi N2Qt11ButtonStateE+0xcb)[0x394bdfddfb]
/usr/lib64/libkdeui.so.4(_ZN14KToolBarButton17mouseReleaseEve ntEP11QMouseEvent+0xab)[0x394bdfe0ab]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN7QWidget5eventEP6QEvent+0x3e9)[0x394a59aa79]
/usr/lib64/libkdeui.so.4(_ZN14KToolBarButton5eventEP6QEvent+0 x16)[0x394be68f26]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN12QApplication14internalNotifyEP7QObjec tP6QEvent+0x85)[0x394a5029a5]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN12QApplication6notifyEP7QObjectP6QEvent +0x250)[0x394a503e50]
/usr/lib64/libkdecore.so.4(_ZN12KApplication6notifyEP7QObject P6QEvent+0x198)[0x394b7c3678]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN9QETWidget19translateMouseEventEPK7_XEv ent+0x4ba)[0x394a4a1b5a]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN12QApplication15x11ProcessEventEP7_XEve nt+0xd49)[0x394a4a0f49]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN10QEventLoop13processEventsEj+0x484)[0x394a4b0ea4]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN10QEventLoop9enterLoopEv+0x31)[0x394a51a151]
/usr/lib64/qt-3.3/lib/libqt-mt.so.3(_ZN10QEventLoop4execEv+0x22)[0x394a51a032]
k9copy[0x44360f]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x364f61e074]
k9copy(_ZN11KMdiMainFrm19switchToTabPageModeEv+0xa 1)[0x41f7a9]
======= Memory map: ========
00400000-004fb000 r-xp 00000000 08:07 1400965 /usr/bin/k9copy
006fa000-00709000 rw-p 000fa000 08:07 1400965 /usr/bin/k9copy
00709000-0112b000 rw-p 00709000 00:00 0 [heap]
3000e00000-3000e0a000 r-xp 00000000 08:07 1395689 /usr/lib64/libhal-storage.so.1.0.0
3000e0a000-3001009000 ---p 0000a000 08:07 1395689 /usr/lib64/libhal-storage.so.1.0.0
3001009000-300100a000 rw-p 00009000 08:07 1395689 /usr/lib64/libhal-storage.so.1.0.0
364e400000-364e41b000 r-xp 00000000 08:07 1321267 /lib64/ld-2.7.so
364e61a000-364e61b000 r--p 0001a000 08:07 1321267 /lib64/ld-2.7.so
364e61b000-364e61c000 rw-p 0001b000 08:07 1321267 /lib64/ld-2.7.so
364ec00000-364ec01000 r-xp 00000000 08:07 1396909 /usr/lib64/libutempter.so.1.1.4
364ec01000-364ee01000 ---p 00001000 08:07 1396909 /usr/lib64/libutempter.so.1.1.4
364ee01000-364ee02000 rw-p 00001000 08:07 1396909 /usr/lib64/libutempter.so.1.1.4
364f000000-364f031000 r-xp 00000000 08:07 1401681 /usr/lib64/liblcms.so.1.0.16
364f031000-364f231000 ---p 00031000 08:07 1401681 /usr/lib64/liblcms.so.1.0.16
364f231000-364f233000 rw-p 00031000 08:07 1401681 /usr/lib64/liblcms.so.1.0.16
364f233000-364f235000 rw-p 364f233000 00:00 0
364f600000-364f74d000 r-xp 00000000 08:07 1321269 /lib64/libc-2.7.so
364f74d000-364f94d000 ---p 0014d000 08:07 1321269 /lib64/libc-2.7.so
364f94d000-364f951000 r--p 0014d000 08:07 1321269 /lib64/libc-2.7.so
364f951000-364f952000 rw-p 00151000 08:07 1321269 /lib64/libc-2.7.so
364f952000-364f957000 rw-p 364f952000 00:00 0
364fa00000-364fa82000 r-xp 00000000 08:07 1321497 /lib64/libm-2.7.so
364fa82000-364fc81000 ---p 00082000 08:07 1321497 /lib64/libm-2.7.so
364fc81000-364fc82000 r--p 00081000 08:07 1321497 /lib64/libm-2.7.so
364fc82000-364fc83000 rw-p 00082000 08:07 1321497 /lib64/libm-2.7.so
364fe00000-364fe02000 r-xp 00000000 08:07 1321498 /lib64/libdl-2.7.so
364fe02000-3650002000 ---p 00002000 08:07 1321498 /lib64/libdl-2.7.so
3650002000-3650003000 r--p 00002000 08:07 1321498 /lib64/libdl-2.7.so
3650003000-3650004000 rw-p 00003000 08:07 1321498 /lib64/libdl-2.7.so
3650200000-3650216000 r-xp 00000000 08:07 1321501 /lib64/libpthread-2.7.so
3650216000-3650415000 ---p 00016000 08:07 1321501 /lib64/libpthread-2.KCrash: Application 'k9copy' crashing...
Could not find 'drkonqi' executable.
KCrash cannot reach kdeinit, launching directly.
[colin@dhcp-169-196 ~]$


any idea what the problem is? :confused: all I can see is something wrong with libdvdread and a buffer overflow.

Seve
23rd November 2007, 06:42 AM
Hello:
I believe this is an issue with the livna package ?

See http://bugzilla.livna.org/show_bug.cgi?id=1684

Looks like it should be fixed up shortly.

Seve

slade17
23rd November 2007, 07:21 AM
thanks, i'll wait for the update.

thewils
26th November 2007, 12:08 AM
Maybe this will be of some help. Fedora 8 32bit (on a 64bit cpu) with selinux enabled in Permissive mode (if that makes a difference). More info in the attachment.

Here's the backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208789296 (LWP 14421)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0x00110402 in __kernel_vsyscall ()
#7 0x00bb9690 in raise () from /lib/libc.so.6
#8 0x00bbaf91 in abort () from /lib/libc.so.6
#9 0x00bf19eb in __libc_message () from /lib/libc.so.6
#10 0x00c79b58 in __fortify_fail () from /lib/libc.so.6
#11 0x00c78200 in __chk_fail () from /lib/libc.so.6
#12 0x00c77918 in _IO_str_chk_overflow () from /lib/libc.so.6
#13 0x00bf6793 in __overflow () from /lib/libc.so.6
#14 0x00bd0673 in vfprintf () from /lib/libc.so.6
#15 0x00c779cd in __vsprintf_chk () from /lib/libc.so.6
#16 0x00c77900 in __sprintf_chk () from /lib/libc.so.6
#17 0x080f1be2 in ?? ()
#18 0x08073fc7 in ?? ()
#19 0x080a8023 in ?? ()
#20 0x06ab7b8a in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x06ab857d in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x05abfca9 in KAction::activated () from /usr/lib/libkdeui.so.4
#23 0x05afdb22 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#24 0x05bfb6ad in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#25 0x05bfb971 in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#26 0x06ab7b8a in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x06e4532e in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x06ad6137 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x06bd81a5 in QPopupMenu::mouseReleaseEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x05ac956f in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#31 0x06af4205 in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x06a4e38b in QApplication::internalNotify ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x06a4fb39 in QApplication::notify ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x05873022 in KApplication::notify () from /usr/lib/libkdecore.so.4
#35 0x069e5c30 in QETWidget::translateMouseEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#36 0x069e4036 in QApplication::x11ProcessEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#37 0x069f5cbb in QEventLoop::processEvents ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x06a67c60 in QEventLoop::enterLoop ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#39 0x06a67b16 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#40 0x06a4dfcf in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x0808e268 in ?? ()
#42 0x00ba6390 in __libc_start_main () from /lib/libc.so.6
#43 0x08065911 in QWidget::setUpdatesEnabled ()

Seve
26th November 2007, 12:15 AM
Hello:
You should file a bug report with Livna, including your backtrace content.
http://bugzilla.livna.org/

Seve

thewils
26th November 2007, 12:26 AM
Livna account created...waiting for password to be emailed to hotmail account...must maintain attention....feeling sleepy...

leigh123linux
26th November 2007, 01:50 AM
K9copy works great here ( but I had to make it myself )

For the fixed rpm's ( see links )



x86_64

http://www.4shared.com/file/30373147/2bebe56/k9copy-120-1fc8x86_64.html



i386

http://www.4shared.com/file/30444490/e8cde582/k9copy-120-1fc8i386.html





srpm

http://www.4shared.com/file/30373239/a801bbcf/k9copy-120-1fc8src.html

The srpm is not easy to build so I recommend that you use the precompiled rpm 's

leigh123linux
26th November 2007, 08:25 PM
Added a fixed i386 rpm to my last post

FriedChips
26th November 2007, 08:32 PM
K9copy works great here ( but I had to make it myself )

For the fixed rpm's ( see links )



x86_64

http://www.4shared.com/file/30373147/2bebe56/k9copy-120-1fc8x86_64.html



i386

http://www.4shared.com/file/30444490/e8cde582/k9copy-120-1fc8i386.html





srpm

http://www.4shared.com/file/30373239/a801bbcf/k9copy-120-1fc8src.html

Once again... Thanks Leigh :cool:

clavan
23rd December 2007, 08:21 PM
Maybe this will be of some help. Fedora 8 32bit (on a 64bit cpu) with selinux enabled in Permissive mode (if that makes a difference). More info in the attachment.

Here's the backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208789296 (LWP 14421)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0x00110402 in __kernel_vsyscall ()
#7 0x00bb9690 in raise () from /lib/libc.so.6
#8 0x00bbaf91 in abort () from /lib/libc.so.6
#9 0x00bf19eb in __libc_message () from /lib/libc.so.6
#10 0x00c79b58 in __fortify_fail () from /lib/libc.so.6
#11 0x00c78200 in __chk_fail () from /lib/libc.so.6
#12 0x00c77918 in _IO_str_chk_overflow () from /lib/libc.so.6
#13 0x00bf6793 in __overflow () from /lib/libc.so.6
#14 0x00bd0673 in vfprintf () from /lib/libc.so.6
#15 0x00c779cd in __vsprintf_chk () from /lib/libc.so.6
#16 0x00c77900 in __sprintf_chk () from /lib/libc.so.6
#17 0x080f1be2 in ?? ()
#18 0x08073fc7 in ?? ()
#19 0x080a8023 in ?? ()
#20 0x06ab7b8a in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x06ab857d in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x05abfca9 in KAction::activated () from /usr/lib/libkdeui.so.4
#23 0x05afdb22 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#24 0x05bfb6ad in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#25 0x05bfb971 in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#26 0x06ab7b8a in QObject::activate_signal ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x06e4532e in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x06ad6137 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#29 0x06bd81a5 in QPopupMenu::mouseReleaseEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x05ac956f in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#31 0x06af4205 in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x06a4e38b in QApplication::internalNotify ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x06a4fb39 in QApplication::notify ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x05873022 in KApplication::notify () from /usr/lib/libkdecore.so.4
#35 0x069e5c30 in QETWidget::translateMouseEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#36 0x069e4036 in QApplication::x11ProcessEvent ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#37 0x069f5cbb in QEventLoop::processEvents ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x06a67c60 in QEventLoop::enterLoop ()
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#39 0x06a67b16 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#40 0x06a4dfcf in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x0808e268 in ?? ()
#42 0x00ba6390 in __libc_start_main () from /lib/libc.so.6
#43 0x08065911 in QWidget::setUpdatesEnabled ()


I have exact the same backtrace overhere.
k9copy crashed ... How can I solve this,.... anyone a tip ?

Thanks

leigh123linux
23rd December 2007, 08:57 PM
I have exact the same backtrace overhere.
k9copy crashed ... How can I solve this,.... anyone a tip ?

Thanks

Install the fixed packages from post #7 :rolleyes: :rolleyes: :rolleyes:

clavan
24th December 2007, 09:56 AM
Install the fixed packages from post #7 :rolleyes: :rolleyes: :rolleyes:

Oke, I give it a try and let you know
Thanks anyway
regards
clavan

clavan
24th December 2007, 10:12 AM
Install the fixed packages from post #7 :rolleyes: :rolleyes: :rolleyes:

Yes, it works thanks a lot.

After installing the rpm you said from post #7 it works

Thanks for the tip

greetz
clavan

szandor
1st January 2008, 11:00 AM
K9copy works great here ( but I had to make it myself )

For the fixed rpm's ( see links )



x86_64

http://www.4shared.com/file/30373147/2bebe56/k9copy-120-1fc8x86_64.html



i386

http://www.4shared.com/file/30444490/e8cde582/k9copy-120-1fc8i386.html





srpm

http://www.4shared.com/file/30373239/a801bbcf/k9copy-120-1fc8src.html

The srpm is not easy to build so I recommend that you use the precompiled rpm 's

hell yeah! it took me over an hour to stumble on this. much appreciative of the working package. thanks!

dwhitney67
3rd January 2008, 05:54 AM
K9copy works great here ( but I had to make it myself )

For the fixed rpm's ( see links )



x86_64

http://www.4shared.com/file/30373147/2bebe56/k9copy-120-1fc8x86_64.html



i386

http://www.4shared.com/file/30444490/e8cde582/k9copy-120-1fc8i386.html





srpm

http://www.4shared.com/file/30373239/a801bbcf/k9copy-120-1fc8src.html

The srpm is not easy to build so I recommend that you use the precompiled rpm 's
I downloaded and tried to install the i386 version of the RPM. My F8 package manager states that the RPM (or contents of) is already installed on my system. Yet when I attempt to "open" a DVD using k9copy, I obtain the identical stack trace as posted before (by 'thewils').

I just ran a 'yum update' on my system, and everything is up to date. Any ideas on what else I can do?

slade17
3rd January 2008, 07:40 AM
I downloaded and tried to install the i386 version of the RPM. My F8 package manager states that the RPM (or contents of) is already installed on my system. Yet when I attempt to "open" a DVD using k9copy, I obtain the identical stack trace as posted before (by 'thewils').

I just ran a 'yum update' on my system, and everything is up to date. Any ideas on what else I can do?
try removing k9copy first (yum remove k9copy), then install the downloaded rpm.

FriedChips
3rd January 2008, 03:11 PM
or install with

rpm -Uvh k9copy-whatever-version.rpm

dwhitney67
3rd January 2008, 03:19 PM
try removing k9copy first (yum remove k9copy), then install the downloaded rpm.
Thanks, your suggestion worked.

allan_r
4th January 2008, 05:27 PM
I maybe having the same problem, but the above fixes DID NOT seem to work for me. K9copy seem to be crashing after ripping and shrinking org. dvd, It never get to the point of request a blank dvd.

dwhitney67
4th January 2008, 05:37 PM
It's not the same problem. The problem I, and I believe the others were having, occurred when an attempt to "open" a DVD was made.

I am now able to rip DVDs, compressing them to approx 4.4GB. I uses Gnome's tool to burn to DVD, not k9copy. Perhaps you should try that too.

Jasbo
5th January 2008, 02:21 AM
I removed k9copy then removed the libdvdread package ignoring the dependencies and compiled libdvdread from source. Reinstalled the k9copy after that and it works now...hope this helps someone

Maxim9
5th January 2008, 04:39 PM
Exactly what I was looking for. Awesome your RPMs worked!

szandor
6th January 2008, 02:14 AM
I maybe having the same problem, but the above fixes DID NOT seem to work for me. K9copy seem to be crashing after ripping and shrinking org. dvd, It never get to the point of request a blank dvd.

sounds like a different issue. you may want to check the error log and do a search on the last comprehensible repeating error. that's how i eventually got to this thread. depending on how k9copy is set up, for me, i just get a 'click ok' window to click on and i'm done. i just eject the dvd, put in blank dvd, and burn the iso with k3b or i can play the iso in mplayer if i never plan on moving the file. did k9copy ever create an iso or vob files? if so, can you play any of the them in say, mplayer?

leigh123linux
13th January 2008, 02:45 PM
I just updated and livna have released a new version available though yum and it works :eek:

FriedChips
14th January 2008, 05:13 AM
I just updated and livna have released a new version available though yum and it works :eek:

Confirmed :D