PDA

View Full Version : build grub



AllanPen
21st November 2007, 08:58 PM
I have checked around but, still puzzled as to a solution here

I installed LinuxMint on sda7 and during install the option to install grub on root wasn't there; at least I couldn't see it. So in Mint I have the boot folder of course but, no grub folder or menu.lst. Anyone know the solution. I'm looking at a modification of # grub-install /dev/hd0 but, am a bit afraid of screwing everything up.




Disk identifier: 0x0000752c



Device Boot Start End Blocks Id System

/dev/sda1 * 1 11473 92156841 7 HPFS/NTFS

/dev/sda2 11474 11664 1534207+ 82 Linux swap / Solaris

/dev/sda3 11665 14214 20482875 83 Linux

/dev/sda4 14215 30401 130022077+ 5 Extended

/dev/sda5 14215 16126 15358108+ 83 Linux
(Fedora 8)
/dev/sda6 16127 17401 10241406 83 Linux (Ubuntu)

/dev/sda7 17402 18676 10241406 83 Linux
(LinuxMint)
/dev/sda8 18677 19951 10241406 83 Linux

/dev/sda9 19952 20588 5116671 b W95 FAT32

/dev/sda10 20589 30401 78822891 7 HPFS/NTFS



Disk /dev/sdb: 250.0 GB, 250059350016 bytes

255 heads, 63 sectors/track, 30401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x00068165



Device Boot Start End Blocks Id System

/dev/sdb1 * 1 3824 30716248+ 83 Linux

/dev/sdb2 3825 8286 35841015 83 Linux

/dev/sdb3 8287 30401 177638737+ 7 HPFS/NTFS

bob
21st November 2007, 09:21 PM
Try Stevea's (post7) instructions: http://forums.fedoraforum.org/forum/showthread.php?t=169046 - make sure they're modified for your config, of course.

BTW, Mint sure does have grub; I'm using it to boot my distros. It's in there; worst case, reinstall and look around during the process for it. I think it's a part of the custom partitioning section.

AllanPen
21st November 2007, 09:30 PM
Actually you are the reason I'm trying it; I read one of your posts where you mentioned Mint favourably and thought I'd give it a try. I have a friend who is almost ready to give LInux a try and I want to be able to suggest an easy out of the box everything works distro. I have Ubuntu controlling the MBR. On the Mint install when it came to the bootloader part I couldn't seem to get past having Mint take over MBR. I wanted to put the loader on root of partition. I guess I must have missed something. I'll try again loading it.

bob
21st November 2007, 09:51 PM
Well, Mint is an Ubuntu variant and Ubuntus love to control grub. Frankly, I'd let it happen since Debian distros have excellent recognition of other distros.

AllanPen
21st November 2007, 09:59 PM
Yes I thought of that it's just that I was considering Mint to be a temporary install and may put another distro over it in the future; was trying to avoid future messing with MBR control. Thanks Bob.

bob
21st November 2007, 10:04 PM
Just one more tip; when you've got your menu.lst set up, print it off and keep it handy in case the next grub doesn't do as well recognizing your distros.

AllanPen
21st November 2007, 10:10 PM
Good advice Bob. Will do; or keep copies on my USB backups.

AllanPen
22nd November 2007, 06:26 PM
Hi Bob
I reloaded Mint as you suggested and there was no option to to put bootloader on Mint root. I really wanted to leave Ubuntu controlling MBR so I had a brain wave (don't have too many at this stage). I use Acronis True Image a lot and forgot that it backsup MBR so I just went to an older image and recovered the Ubuntu MBR then just put Mint's menu entry into Ubuntu's menu. Yeehaw. Bob's your uncle!!