PDA

View Full Version : PulseAudio not Working



CNLiberal
19th November 2007, 03:24 AM
I just love that title. It explains everything doesn't it? OK, here's the scoop. New up to date F8 install on an Asus A7N8X-DLX rev 2.0 board using COAX digital out. The analog out does not work on this board, but coax out has always worked in Winblowz. This is the first time I've had Linux on this hardware. Pulseaudio is currently not working. Here are the symptoms. I was able to get xine and mplayer to output only DVD movie audio through the coax. That is now not working because I followed some steps that told me to go to:

System > Preferences > Hardware > Sound

These instructions told me to choose PulseAudio Sound Server for Sound Events, Music and Movies, and Audio Conferencing. Now when I try and start up PulseAudio Volume Meter, I receive a connection error. I open PulseAudio Manager and under Server Information, all I see are n/a. OK, this makes me think that the daemon isn't running. So I go to a command prompt and type this in:


pulseaudio &


I receive this error:



[joltman@galifrey ~]$ pulseaudio &
[2] 3806
[1] Exit 1 pulseaudio
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:1,0: No such device
E: module.c: Failed to load module "module-alsa-sink" (argument: "device=hw:1,0"): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.

Here is my /etc/pulse/default.pa


#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

.nofail

### Load something into the sample cache
#load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-access /usr/share/sounds/generic.wav

.fail

### Load audio drivers statically (it's probably better to not load
### these drivers manually, but instead use module-hal-detect --
### see below -- for doing this automatically)
load-module module-alsa-sink device=hw:1,0
load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists /usr/lib/pulse-0.9/modules//module-hal-detect.so
load-module module-hal-detect
.else
### Alternatively use the static hardware detection module (for systems that
### lack HAL support)
load-module module-detect
.endif

### Load several protocols
load-module module-esound-protocol-unix
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP reciever module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 description="RTP Multicast Sink"
#load-module module-rtp-send source=rtp.monitor

### Automatically restore the volume of playback streams
load-module module-volume-restore

### Automatically restore the default sink/source when changed by the user during runtime
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### Load X11 bell module
#load-module module-x11-bell sample=x11-bell

### Publish connection data in the X11 root window
.ifexists /usr/lib/pulse-0.9/modules//module-x11-publish.so
load-module module-x11-publish
.endif

### Register ourselves in the X11 session manager
# Deactivated by default, to avoid deadlock when PA is started as esd from gnome-session
# Instead we load this via /etc/xdg/autostart/ and "pactl load-module" now
# load-module module-x11-xsmp

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists /usr/lib/pulse-0.9/modules//module-gconf.so
load-module module-gconf
.endif

### Make some devices default
#set-default-sink output
#set-default-source input

I have tried uninstalling the pulseaudio-alsa lib but that had no affect. ConsoleKit and avahi-daemon are both running and set to start at boot.

Before, when I had my sound settings using ALSA, I was seeing the PulseAudio Volume Meter jumping around when I was playing an MP3 through Amarok. However, I wasn't hearing anything. When I was able to play a DVD through xine and hear it, I tried dropping an xvid or mp3 in, and could hear nothing. PulseAudio Volume Meter wasn't showing anything either. I read through the 6 pages of the Pulse thread, but wasn't able to piece together anything that worked. Is this just a bug that I have to live with? What can I do? Thanks for your help!

Jim

space_cadet
10th December 2007, 01:05 PM
I had same problem with pulseaudio daemon!
Try this:
change owership of /tmp/pulse-<username> directory and all the files in it from root to <username>:
#cd /tmp
#chown -R <username>:<username> pulse-<username>/

This fixed all my sound problems (well not all, totem-xine has some sound delay but that is something completely different)