PDA

View Full Version : Green Screen with Quicktime



Jbanicar
13th November 2007, 11:26 PM
Hey, I apologize for another similar topic out there, but recently I had been going through steps in another thread, trying to edit my xorg.conf inorder to get compiz-fusion to work. But the problem all along was that I didn't have Move Windows plugin enabled, and the Desktop one enable to prevent the windows from opening too high where I couldn't reach.

Prior to that thread, I had gotten quicktime playability working perfectly & youtube working perfectly, however, now I think as a result of those changes to my xorg.conf, whenever I go to play a Quicktime trailer, or view a webcam video while using Skype, I get sometimes a screen with green lines or maybe yellow, something of that nature. It does the same thing if I ask it to open with vlc.

YouTube videos work fine.

I've tried different combinations to see if it was the compiz window manager, by selecting the Metacity and also trying the GTK window decoder to see if it was Emerald/compiz, but I get the same result with the quicktime trailers. BUT I can hear the sound. Again, QUicktime trailers were playing fine prior to maybe editing something I shouldn't have in my xorg.conf.

But installing compiz-fusion didn't mess it up, because it still worked then; I only went to go watch a quicktime trailer this afternoon, and I saw the same green lines as I saw in skype this morning with the video (which is why I think it's a xorg.conf issue).

Anyway, here's my xorg.conf, is there anything that could mess it up? I have bolded what was added when I was working with some other helps to, when I thought the reason why my compiz-fusioin wasn't working, was the result of a driver issue (which it wasn't really).

Thanks


Jbanicar@localhost ~]$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Sep 12 14:29:35 PDT 2007

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Wed Sep 12 14:30:30 PDT 2007
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "extmod"
Load "glx"
Load "dri"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
Option "LeftEdge" "120"
Option "RightEdge" "830"
Option "TopEdge" "120"
Option "BottomEdge" "650"
Option "FingerLow" "14"
Option "FingerHigh" "15"
Option "MaxTapMove" "110"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "20"
Option "MinSpeed" "0.3"
Option "MaxSpeed" "0.75"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "ViewSonic N2060w-1M"
HorizSync 31.0 - 65.0
VertRefresh 47.0 - 63.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Gateway FPD2185W"
HorizSync 31.0 - 81.0
VertRefresh 56.0 - 76.0
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce Go 6800 Ultra"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce Go 6800 Ultra"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: 1680x1050 +0+0; DFP: 1600x1024 +0+0; DFP: 1440x900 +0+0; DFP: 1400x1050 +0+0; DFP: 1360x768 +0+0; DFP: 1280x1024 +0+0; DFP: 1280x960 +0+0; DFP: 1280x800 +0+0; DFP: 1280x768 +0+0; DFP: 1280x720 +0+0; DFP: 1152x864 +0+0; DFP: 1024x768 +0+0; DFP: 800x600 +0+0; DFP: 640x480 +0+0; DFP: 640x400 +0+0"
# Removed Option "TwinView" "1"
# Removed Option "metamodes" "CRT: nvidia-auto-select +1680+0, DFP: 1680x1050 +0+0; DFP: 1600x1024 +0+0; DFP: 1440x900 +0+0; DFP: 1400x1050 +0+0; DFP: 1360x768 +0+0; DFP: 1280x1024 +0+0; DFP: 1280x960 +0+0; DFP: 1280x800 +0+0; DFP: 1280x768 +0+0; DFP: 1280x720 +0+0; DFP: 1152x864 +0+0; DFP: 1024x768 +0+0; DFP: 800x600 +0+0; DFP: 640x480 +0+0; DFP: 640x400 +0+0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT: 1680x1050 +0+0; CRT: nvidia-auto-select +0+0"
Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"
Option "AllowGLXWithComposite" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT: nvidia-auto-select +0+0"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

[Jbanicar@localhost ~]$

Also, these commands were entered during the course of trying to fix my window issue:


su -
nvidia-xconfig --render-accel -d 24
nvidia-xconfig --add-argb-glx-visuals -d 24
nvidia-xconfig --allow-glx-with-composite -d 24

Jbanicar
14th November 2007, 12:00 AM
Nevermind... rebooting fix it. Sorry for taking up space!