PDA

View Full Version : Fedora 8 install problem



stikboy73
12th November 2007, 01:32 AM
So I have installed Fedora 8 three times now and all three times I run into the same problem. After the install and reboot I get to the Greetings screen and my mouse doesn't work and my keyboard freezes. Can't turn on or off numlock anymore. If I reboot from there it starts up and instead of a greetings screen, I get just a light blue screen, my mouse works but my keyboard is frozen again. I'm stumped on this. I have been using Fedora since Fedora Core 5 and have never had a problem.
Any suggestions would be greatly appreciated.

Thanx
SB

krusher
12th November 2007, 04:34 AM
I have the EXACT same problem that you do in the beginning, although I get firstboot to come up every time after it freezes. I also tried installing Fedora 7 figuring that I could do an upgrade once I get past firstboot, but the same thing happens.

I'm installing to two identical SCSI drives if that makes any difference. (The install uses them both as one logical volume; completely default installation options.)

I did both installs off of an NFS share--a network installation works really well.

Thanks.

krusher
12th November 2007, 05:56 AM
Well, I'm going to give it up tonight but I did find an older posting for FC6 where someone had the same problem as us. It did get me past the welcome (firstboot) screen, but my computer just became unresponsive on the login screen. The cursor kept flashing even though the keyboard and mouse were being ignored...

1. Boot with the rescue CD
2. chroot /mnt/sysimage
3. chkconfig --levels 2345 firstboot off
4. Exit

See what that does; maybe it will work for you.

krusher
12th November 2007, 06:10 AM
Ok, last one for tonight! If that one above doesn't work for you, I remember vaguely seeing a post that you should turn of Hyperthreading. I thought "ya, right" but guess what...it worked.

I have a 3.4 GHz Prescott with Hyperthreading. This is probably a bug of some sort but I'm not sure how to report it. After I get everything installed and updated tomorrow I will try turning HT back on again to see if it becomes unresponsive again.

Good Luck.

krusher
13th November 2007, 06:59 AM
Yep, it's hyperthreading that is causing the problem for me. It runs fine with it turned off so I'll keep it that way for now.

stikboy73
13th November 2007, 01:40 PM
I have a Pentium D, which if I recall does not have hyperthreading. I tried turning it ff anyway and it made it worse. Before I would get to the welcome screen, now I get a black screen. I'm about to go back to Fedora 7....

krusher
14th November 2007, 04:29 AM
Ok, so Fedora 7 did work for you? Have you tried installing 7, and then use 8 to do an upgrade from 7? I have the same problem with 7 as I do with 8. But if yours works differently, it might be worth a shot then.

almu
15th November 2007, 10:11 AM
Hello,
I have the similar problems to those described above with both Fedora 7 and Fedora 8. When rebooting after the instalation, the PC was hanging when 'starting sendmail'. It sometimes got to the login window, but the keyword and mouse only works intermittently and I never could start a session.
I have tried rebooting changing kernel options:
- deleting 'quiet'
- adding: usbcore.autosuspend=-1 pnpacpi = off reboot= b, w i 8042.nomux

The hanging during rebooting does not accur anymore, but I still have trouble with the keyboard and the mouse. If I wait for ages, until I am lucky and the keyboard works while I am typing at the login screen after rebooting, then I was able to log in, but the mouse is dead and there nothing I can do...It looks dead or extremely slow...
My knowledge on all this stuff is very very limited, so any help would be really welcome! I'm getting desperate!
Thanks!

SaGS
15th November 2007, 04:29 PM
... w i 8042.nomux ...
If I wait for ages, until I am lucky and the keyboard works while I am typing at the login screen after rebooting, then I was able to log in, but the mouse is dead and there nothing I can do...Dontít know what the 8042.nomux is, but some keyboard/ mouse stuck problems are solved by the option i8042.noloop.

almu
15th November 2007, 06:12 PM
Hello SaGS, thanks for your reply. I won't be able to try i8042.noloop until next monday. I'll test it the and let you know.

stikboy73
16th November 2007, 04:46 PM
Thank you everyone for all your help. I did get my problem fixed. It turns out it was as simple as using the acpi=off switch.
Thanx again
SB