PDA

View Full Version : F8 Boot/swap problems



Tylerious
11th November 2007, 10:01 PM
Another thread had a similar problem, but got merged with a different thread, so it's really difficult to understand now.

I'm trying to set up a tri-boot system (PC-BSD 1.4 and Ubuntu 7.10 already installed). Those two are installed on the first two partitions and I installed Fedora 8 to the third partition (from the DVD). The fourth partition is swap space used by Ubuntu (and theoretically now Fedora). However, when I try to boot to Fedora, it hangs after printing "Trying to resume from LABEL=SWAP=sda4".

First off, I have a PATA hd, not SATA, so shouldn't that be hda4?
Second, I never use the hibernate/resume features in Ubuntu. Not planning on it for Fedora.

My fstab:
LABEL=/1 / ext3 defaults 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
LABEL=SWAP-sda4 swap swap defaults 0 0

My grub.conf
#boot=/dev/sda
default=1
timeout=5
#splashimage=(hd0,2)/boot/grub/splash.xpm.gz
#hiddenmenu
title PC-BSD 1.4
root (hd0,0,a)
kernel /boot/loader
title Ubuntu 7.10
root (hd0,1)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=afec557b-796c-49a5-b50f-4112f954ae7a ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet
title Fedora 8
root (hd0,2)
kernel /boot/vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.23.1-42.fc8.img

How do I fix this? I really want to boot Fedora!

rudeboyskunk
12th November 2007, 01:01 AM
I am having the exact same problem, as are many others. It is addressed in this thread here, but we still have no solution: http://forums.fedoraforum.org/showthread.php?t=171223

marko
12th November 2007, 01:33 AM
Another thread had a similar problem, but got merged with a different thread, so it's really difficult to understand now.

I'm trying to set up a tri-boot system (PC-BSD 1.4 and Ubuntu 7.10 already installed). Those two are installed on the first two partitions and I installed Fedora 8 to the third partition (from the DVD). The fourth partition is swap space used by Ubuntu (and theoretically now Fedora). However, when I try to boot to Fedora, it hangs after printing "Trying to resume from LABEL=SWAP=sda4".

First off, I have a PATA hd, not SATA, so shouldn't that be hda4?
Second, I never use the hibernate/resume features in Ubuntu. Not planning on it for Fedora.
......

I don't have an answer for the other points, but now all HD's in linux
will appear as scsi, even if they are IDE/PATA.

REF:

http://lwn.net/Articles/194866/

Mark

Seve
12th November 2007, 01:54 AM
Another thread had a similar problem, but got merged with a different thread, so it's really difficult to understand now.

I'm trying to set up a tri-boot system (PC-BSD 1.4 and Ubuntu 7.10 already installed). Those two are installed on the first two partitions and I installed Fedora 8 to the third partition (from the DVD). The fourth partition is swap space used by Ubuntu (and theoretically now Fedora). However, when I try to boot to Fedora, it hangs after printing "Trying to resume from LABEL=SWAP=sda4".

First off, I have a PATA hd, not SATA, so shouldn't that be hda4?
Second, I never use the hibernate/resume features in Ubuntu. Not planning on it for Fedora.

My fstab:
LABEL=/1 / ext3 defaults 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
LABEL=SWAP-sda4 swap swap defaults 0 0

My grub.conf
#boot=/dev/sda
default=1
timeout=5
#splashimage=(hd0,2)/boot/grub/splash.xpm.gz
#hiddenmenu
title PC-BSD 1.4
root (hd0,0,a)
kernel /boot/loader
title Ubuntu 7.10
root (hd0,1)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=afec557b-796c-49a5-b50f-4112f954ae7a ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet
title Fedora 8
root (hd0,2)
kernel /boot/vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.23.1-42.fc8.img

How do I fix this? I really want to boot Fedora!
Hello:
From Fedora, can you post the output of
su -

fdisk -l

If you now cannot boot fedora, then just comment out the swap entry in your /etc/fstab
and reboot

Seve

Tylerious
12th November 2007, 04:14 AM
I cannot execute 'fdisk -l' from Fedora since I cannot boot to Fedora. However, here are the results from Ubuntu:

Disk /dev/hda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8f800100

Device Boot Start End Blocks Id System
/dev/hda1 1 9959 79995352+ a5 FreeBSD
Partition 1 does not end on cylinder boundary.
/dev/hda2 * 9960 19918 79995667+ 83 Linux
/dev/hda3 19919 29877 79995667+ 83 Linux
/dev/hda4 29878 30401 4209030 82 Linux swap / Solaris

I tried removing the swap line from my /etc/fstab and the same problem occurred. Thanks for replying! Also, thanks Marko for clarifying the *ATA thing.

marko
12th November 2007, 04:25 AM
I cannot execute 'fdisk -l' from Fedora since I cannot boot to Fedora. However, here are the results from Ubuntu:

You could by booting the F8 install disk, hitting the Esc key
and typing at the "boot:" prompt

boot: linux rescue

and then running fdisk -l from the command line when it
finally gets to it (it will ask what keyboard you want before
then). But using ubuntu's fine too. I just want to get across
that the rescue mode is kind of useful.

Mark

Seve
12th November 2007, 04:30 AM
Hello:
Not sure what you have or have not done ?
Boot from your linux install disc and enter linux rescue
[don't edit Fedora from the other Os's]
chroot /mnt/sysimage
then
vi /etc/fstab
and place a ##
in front of the swap entry
use your cursor to move around, type i [for insert], when finished hit the esc key and then, SHIFT ZZ to save an write the changes.
Then type exit to reboot.

If it does not reboot cleanly, then post the complete error that you get.

Seve

Edit:
Sorry marko, didn't mean to post over you :)

stoat
12th November 2007, 04:55 PM
Consider trying what was done here. (http://forum.fedoraforum.org/showthread.php?t=171897) It may work for you. I doubt that it will worsen anything.

vnpenguin
12th November 2007, 05:04 PM
Consider trying what was done here. (http://forum.fedoraforum.org/showthread.php?t=171897) It may work for you. I doubt that it will worsen anything.
No, it does not solved because it's not LABEL problem. I tried to change partition label to /dev/sd* in fstab, but the same error, as always :(

Tylerious
12th November 2007, 05:12 PM
I tried everything through "rescue linux", with the same results. 'fdisk -l' gives same results. Booting still stops at "Trying to resume from LABEL=SWAP-sda4" with swap line commented out (or even absent).

Not sure I see why I can't just mount /dev/hda3 in Ubuntu to make changes to /etc/fstab, but that's kinda irrelevant. I'll try what that thread suggested (from Fedora ;)) and post the results.

---
'mkswap -L SWAP-sda4 /dev/sda4' returns:
"Setting up swapspace version 1, size = 4310040 kB
LABEL=SWAP-sda4, UUID=b542542f-9f54-4a1c-8c1a-7bc3004d7f61

I then tried booting with my swap line both commented and uncommented. Same problem, but now I don't have any swap in Ubuntu! Is this because Ubuntu specifies the UUID in its /etc/fstab? If the UUID was changed, will Ubuntu not be able to find its swap? Should I change Ubuntu's /etc/fstab to /dev/hda4 instead of the UUID? Would doing so require a new initrd image or something?

vnpenguin
12th November 2007, 07:22 PM
From Fedora Core 1 to Fedora 7, I use always the same swap partition for ALL Linux distro on my box (Fedora, SuSE, Ubuntu,...). For each installation, the swap partition will be selected automatically (without format of course), and it works without any problem.

And now, Fedora 8 can not boot. It's so bad and so sad !!!

:( :( :(

rexbinary
12th November 2007, 07:33 PM
I've filed a bug for this, feel free to add to it.

https://bugzilla.redhat.com/show_bug.cgi?id=375591

Tylerious
13th November 2007, 11:43 PM
I've contributed my share to the bug - never thought it had anything to do with my type 165 partition!

rexbinary
14th November 2007, 12:35 AM
Yeah it's a weird issue for sure. Let FreeBSD or PC-BSD format the partition, Fedora won't boot. Format it ext2, FAT32, or NTFS, and Fedora will boot. And apparently it doesn't matter if it's on the same physical drive or not as I first thought it did.

Thanks for contributing. I need to try some of the suggestions in the bug thread as soon as I get a chance, although I'm sure I'll have the same results as the others that have tried already.