PDA

View Full Version : Unable to receive mail after upgrading to Fedora 8



dpavlovich
11th November 2007, 08:45 PM
Hello,

My primary system has been Redhat/Fedora for many years now. I just upgraded to Fedora 8 and now am unable to retrieve my email. Here are the details:

- I use evolution.
- I have a custom partitioning configuration.
- During install, I reformated the "boot", "/" and "swap" partitions but NOT the "/home" partition.
- After installing, on the root account, I configured evoluton as I used to do in the past, entering the particulars for my pop email account hosted by google.
- When I attempted to retrieve mail, it didn't ask for my password, it just sat there at "waiting...". Then it gave me an error message:

"Error while Fetching Mail.
Could not connect to mail.pupshine.com: Connection timed out."

- I read of other people having problems with SELinux not "relabeling" the /home partition if you don't reformat it, so I opened the SELinux config and set it to "permisssive" and rebooted.
- It warned me that it would take some time to relabel stuff ... I let it complete.
- I attempted to get mail again with the same results as before.

I am really frustrated here. I tried installing Fedora multiple times now, reformatting each time (everything except "/home"). I tried the regular Fedora 8 DVD (test 3) download, I tried downloading the Fedora 8 iso, burned the DVD but the resulting DVD (although accesible/readable) would not act as a boot device. I then tried the Fedora 8 Gnome spin (what I currently have installed now) and at least that booted and installed. The steps I mentioned above I did after this latests installation.

Any help you can provide would be greatly appreciated!

Also, any idea why the Fedora 8 DVD iso resulted in a non-bootable DVD? This worked fine with Fedora 8 (test 3). I've created 2 different DVDs from this iso (downloaded from bittorrent) and neither are bootable.

Finally, can someone provide a link to where I can download the CD images of the full install so I can try installling from that instead of the Gnome spin?

Thanks again everyone!

marko
11th November 2007, 11:29 PM
what happens if you disable selinux then try the mail?

dpavlovich
12th November 2007, 12:45 AM
I actually did try that, but definitely thank you for the suggestion. As I said, I'm somewhat desperate for a solution for this. I've not been able to retrieve my mail for a week or so now. I was hoping that this would get fixed when the final version of Fedora 8 was released. Unfortunately, as I mentioned before, that did not fix it either.

Any other ideas folks? This has to be some sort of configuration problem or firewall/SELinux thing. That is the only thing that makes sense to me. But perhaps I'm just missing something.

Help !!!!

marko
12th November 2007, 02:32 AM
When I run host against mail.pupshine.com it seems to suggest you're
talking about gmail:

$> host mail.pupshine.com
mail.pupshine.com is an alias for ghs.GOOGLE.com.
ghs.GOOGLE.com is an alias for ghs.l.GOOGLE.com.


Are you sure the pop3 server for gmail is mail.pupserve.com ??

When I run a google search on the address I get no hits at all.
It seems unlikely to me that a correct pop3 address for gmail would
have no hits when searched on google.

I then found instructions for getting gmail via pop3 and they say to use
pop.gmail.com

http://email.about.com/od/gmailtips/qt/et010605.htm

maybe you have evolution trying to get mail from the wrong address?

Mark

dpavlovich
12th November 2007, 03:37 AM
Thank you Mark for the idea. Although I was successfully receiving mail when configured as mail.pupshine.com before I upgraded/reinstalled to Fedora 8, I followed your suggestion (and the instructions at the link you provided). Unfortunately, I got the same results again. Grrrr...

But I really do appreciate your help thus far. Any other thoughts?

marko
12th November 2007, 04:17 AM
Did you try other pop3 apps besides Evolution? I use kmail all the time
(not for Gmail though, I don't have gmail) for pop3 mail. kmail is in
your Fedora 8 install.

As a test, you have tried simply turning off the iptables firewall and
then trying to get your mail? That would only expose your system
for a short time then turn the iptables back on.

You said you tried turning off selinux in post #3, but in post 1 you said
you tried setting it to permissive. I mean *totally* turn it off (disabled mode), reboot and
try to get mail. If you did that but left it out of your post 1 then nevermind.

I doubt this is an selinux issue because the problem is not
being able to even get to the pop server, I was under the impression
that selinux is for policing interuser/interprocess permissions,
access controls to filesystems, etc and not stuff like networking
out of the machine. I personally don't see the use of it for a
home user with one account.

Mark

ccacioppo
12th November 2007, 05:33 PM
I am using Evolution on F8 for Gmail.

The server I am pointed to is IMAP so its: imap.gmail.com.

all works ok there. I think its SSL also.

ccacioppo

spinstate
13th November 2007, 03:33 PM
Are you able to telnet to your mail server?

telnet mail.pupshine.com 110

I just tried the command above, and didn't get a response...

nick.stumpos
13th November 2007, 03:52 PM
you sure thats your pop3 server
nick:~# nmap -sS -sV -O mail.pupshine.com

Starting Nmap 4.20 ( http://insecure.org ) at 2007-11-13 09:52 EST
Interesting ports on eh-in-f121.google.com (72.14.207.121):
Not shown: 1693 filtered ports
PORT STATE SERVICE VERSION
80/tcp open http Google httpd 1.3 (GFE)
113/tcp closed auth
179/tcp closed bgp
443/tcp closed https
Device type: broadband router|hub|general purpose|print server|printer
Running (JUST GUESSING) : 3Com embedded (88%), Cisco embedded (88%), IBM embedded (88%), D-Link embedded (87%), Be BeOS 4.X (87%), Novell NetWare 3.X|4.X|5.X (87%), Brother embedded (86%)
Aggressive OS guesses: 3Com OfficeConnect Remote 812 aDSL Router (88%), Cisco 760 Series ISDN router (non IOS) or IBM Stackable Hub (88%), D-Link 2630 Broadband router (87%), BeOS 4 - 4.5 (87%), D-Link Print Server (87%), Novell NetWare 3.12 - 5.00 (87%), 3Com OfficeConnect 812 aDSL router (86%), Brother HL-1230 Printer (86%), Print server: Zero One Tech 3000, Hawking PN7117, or EUSSO UPS1211-B (86%), Sony AIBO ERS-7 running AIBO Mind 2 (86%)
No exact OS matches for host (test conditions non-ideal).
Service Info: OS: Linux

OS and Service detection performed. Please report any incorrect results at http://insecure.org/nmap/submit/ .
Nmap finished: 1 IP address (1 host up) scanned in 46.672 seconds

zilch321
13th November 2007, 04:24 PM
Agree with what is posted above. Did a little diging

;; ANSWER SECTION:

mail.pupshine.com. 3600 IN CNAME ghs.GOOGLE.com.

ghs.GOOGLE.com. 604800 IN CNAME ghs.l.GOOGLE.com.

ghs.l.GOOGLE.com. 300 IN A 64.233.179.121

I tried several different ports, imap, pop, ssh nothing answers at mail.pupshine.com other than a ping. Something is wrong but I dont think its your fedora system.