PDA

View Full Version : HD with fedora 8



nemesis963
11th November 2007, 08:04 PM
Hello,

I'm trying to play some HD files (mkvs) with mplayer on fedora 8. The problem is that they are rendered really slow. On fedora 7 I had no problems.
I used xv rendering with the radeon driver and the fglrx 8.42.3 driver, but none of them worked.

My system is Amilo M1437G, Centrino 1.86GHz, 2GB RAM, Mobility Radeon X700.

Thanks

leadgolem
11th November 2007, 08:32 PM
Do you have desktop effects software active? That sometimes kills the performance.

This sounds strange, but open a terminal then call nautilus, then navigate to a folder with videos in it. Post any errors you receive here. Example:
nautilus ./When the system tries to create the previews you may get some useful info in the terminal. Also, try your player from the terminal. Post any of errors you get there also.

spike28
11th November 2007, 08:55 PM
I have the same problem. I've also tried to use xine for that kind of movies, but it doesn't work better :(

nemesis963
11th November 2007, 09:02 PM
Do you have desktop effects software active? That sometimes kills the performance.

No, I don't use compiz or beryl.


This sounds strange, but open a terminal then call nautilus, then navigate to a folder with videos in it.

I've tried this but nautilus doesn't seem to give any feedback in the terminal. I've seen that when nautilus tries to preview those files it takes about 10 seconds to process a single file and then it doesn't show any preview.


Post any errors you receive here. Example:
nautilus ./When the system tries to create the previews you may get some useful info in the terminal. Also, try your player from the terminal. Post any of errors you get there also.

Here's the output from mplayer:


MPlayer 1.0rc2-4.1.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) M processor 1.86GHz (Family: 6, Model: 13, Stepping: 8)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing movie.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
================================================== ========================
================================================== ========================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 1280x720 => 1280x720 Planar YV12
A: 367.8 V: 367.4 A-V: 0.406 ct: -0.074 92/ 92 114% 12% 2.8% 14 0
Exiting... (Quit)

nemesis963
11th November 2007, 09:04 PM
I have the same problem. I've also tried to use xine for that kind of movies, but it doesn't work better :(

I also tried xine with no luck. For me, at least, it seems that xine is even slower.

leadgolem
12th November 2007, 10:38 AM
Where did you get the h.264 video codec from?

nemesis963
12th November 2007, 10:44 AM
Where did you get the h.264 video codec from?
mplayer and ffmpeg-libs are both from livna. I know that the problem is with ffh264 codec, but I don't know how to fix it.

leadgolem
12th November 2007, 04:24 PM
Have you tried a basic yum remove/ yum install? You could have just gotten corrupted files. Happened to me a couple of times.

nemesis963
12th November 2007, 06:39 PM
Have you tried a basic yum remove/ yum install? You could have just gotten corrupted files. Happened to me a couple of times.
It still doesn't work.

multescugeorge@
13th November 2007, 06:54 PM
i think you need to enable TexturedVideos or something for xv with fglrx, i don't remember where i read it and i don't know if it's correct, use google and see if it turns up something.

nemesis963
13th November 2007, 07:18 PM
i think you need to enable TexturedVideos or something for xv with fglrx, i don't remember where i read it and i don't know if it's correct, use google and see if it turns up something.

I have TexturedVideo="true". Here's my xorg.conf:


# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
VendorName "Videocard vendor"
BoardName "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Option "TexturedVideo" "true"
Option "RenderAccel" "True"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

multescugeorge@
13th November 2007, 07:28 PM
at the start of the file i don't see:


Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "GLcore"
EndSection

and at the end:


Section "DRI"
Group 0
Mode 666
EndSection


see http://paste.lisp.org/display/48069 for a example xorg, perhaps not all the option in the paste.lisp file apply to you, first try to add the sections i put up, see if you get into trouble.
BIG FAT WARNING, be sure to save your current xorg.conf file before making any changes to it, if you have trouble starting X, then press ctrl-alt-f2 and restore xorg.

example back-up comand:


cp /etc/X11/xorg.conf /etc/X11/xorg.conf.good

example restore comand:


cp /etc/x11/xorg.conf.good /etc/X11/xorg.conf
press y when prompted to overwrite

nemesis963
13th November 2007, 07:52 PM
at the start of the file i don't see:


Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "GLcore"
EndSection

and at the end:


Section "DRI"
Group 0
Mode 666
EndSection


I've added the lines you sugested, but it doesn't appear to be any faster.

I've checked my Xorg.0.log log file with my initial xorg.conf configuration and I do have DRI enabled ((II) fglrx(0): DRI initialization successfull!).

multescugeorge@
13th November 2007, 07:58 PM
only thing you can do is to wait for a updated driver from ati, i suspect your troubles come from the fact that fglrx version 8.42.3 doesn't support 2.6.23 kernel (yet), i know there are patches available, but it's better to wait for the official driver support.

nemesis963
13th November 2007, 08:12 PM
only thing you can do is to wait for a updated driver from ati, i suspect your troubles come from the fact that fglrx version 8.42.3 doesn't support 2.6.23 kernel (yet), i know there are patches available, but it's better to wait for the official driver support.
I don't think the fglrx driver is the problem, because the same thing happens if I use the radeon open source driver.
I suspect that there's something wrong with ffh264 codec from ffmpeg, because I have other HD files (same resolution, but avi format) which are played really great. The difference is that they use another codec (ffodivx from ffmpeg).

nemesis963
19th November 2007, 09:12 PM
I've installed fedora 8 with
acpi=off and this was the problem. I removed
acpi=off from grub.conf and it works now.

Orland
1st July 2008, 11:32 AM
Have same problem with Fedora 9. My HD videos coded by ffh264 are terrible slow. But other videos runs perfect. I saw that i should remove acpi=off from grub.conf, but there is no such line. Could anyone help me ?

leadgolem
2nd July 2008, 03:08 AM
What are you playing the videos with?

Orland
2nd July 2008, 07:45 AM
What are you playing the videos with?
I 'm using smplayer.

leadgolem
2nd July 2008, 11:05 PM
Hmm, that should actually work... I would give vlc a try.