PDA

View Full Version : java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.



peterlauri
11th November 2007, 07:48 PM
I get this error when I try to install Zend Studio on my Fedora Core 8 installation. Last week all went well on a Fedora Core 7 installation.

I assume this has to do with some jre or similar, but I don't know where to start :( Any ideas? Here is the prompt when I install:

[peterlauri@dhcppc13 ~]$ ./ZendStudio-5_5_0.bin
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted

toxicshock
11th November 2007, 08:10 PM
Greetings,

I had the same problem with the BOINC manager application (#./boincmgr). I ended up launching the app itself (#./boinc). HtH.

m4rgin4l
11th November 2007, 08:53 PM
Here's a description of the problem

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

I used the "sed" workaround and it worked for me:

For sun-java5-bin:
sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-1.5.0-sun-1.5.0.11/jre/lib/i386/xawt/libmawt.so

For sun-java6-bin:
sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.00/jre/lib/i386/xawt/libmawt.so

I hope this gets fixed soon.

peterlauri
11th November 2007, 08:59 PM
The "sed" workaround didn't do it for me. I am getting lost. I am thinking to move back to FC7 as it worked very well there.

rajihammer
11th November 2007, 09:03 PM
I ditto m4rgin4l , I've been struggling with Java too. For me it's almost a deal breaker if java cannot be made to work. Cannot make icetea work on Seamonkey my browser of choice, funny(as in irritating)it works with Firefox, icetea that is.

m4rgin4l
11th November 2007, 09:23 PM
That's weird. I've used the workaround on three different computers and it worked on all of them. Are you supplying the correct path for libmawt.so? On my PCs java is not installed on the path that is mentioned in the workaround (I'm using the official JDK rpms).

peterlauri
11th November 2007, 09:30 PM
Hi. I did a find -name 'libmawt.so' in the /usr/lib and then I made the sed. And it didn't work :(

Cloty
13th November 2007, 11:04 AM
At first,you should run Zend installer in a slint mode
#./ZendStudio-5_5_0.bin -i silent

after installation run
# cd /usr/local/Zend/ZendStudio-5.5.0/jre/lib/i386/xawt
# cp libmawt.so libmawt.so.bak && sed -i s/XINERAMA/FAKEEXTN/g libmawt.so

Cloty
13th November 2007, 11:09 AM
Can any one help me to setup netbeans 6.0?

I hope if I haven't setup Fedora 8.
Now,I know stable version is important.

walovaton
13th November 2007, 05:30 PM
Peter, I had the same exact problem as you and I could find a solution. Now Zend Studio works fine for me. =)

Let's see, the problem happens for many Java versions on a recent linux distribution, in this case Fedora 8. The workarounds posted here worked fine, the really difficult part is applying the workaround to the right installation of the JVM. In this case it's very tricky because the binary installer uncompress a different JVM in /tmp/install.dir.XXXX (where XXXX are different random numbers) every time you try to execute the binary installer.

So, what I did was to make a temporary copy of the JVM bundled with the Zend installer somewhere else (eg: /root - you can delete it later on) with the following command:
# cp -R /tmp/install.dir.XXXX/Linux/resource/jre/ /root/java

Remember to replace XXXX with the exact numbers. Then apply the fix on that Java installation in the root home:
# cd /root/java/lib/i386/xawt
# sed -i 's/XINERAMA/FAKEEXTN/g' libmawt.so

That's all, now execute the Zend installer this way:
# ./ZendStudio-5_1_0.bin LAX_VM /root/java/bin/java

note that I am using Zend Studio 5.1.0 and you are using a newer one (5.5.0) so I had to previously apply the fix explained here [ http://www.zend.com/support/knowledgebase.php?kbid=226&view_only=1 ] to make it work. It's an old problem and it's needed to install Zend Studio even on Fedora 7. So you might need to apply this, may be not. But I guess you probably know this already.

Now, follow the regular steps during the installation and then apply the same fix to the definitive Java installation for Zend Studio:
# cd /usr/local/Zend/ZendStudioClient-5.1.0/jre/lib/i386/xawt (your install dir may vary)
# sed -i 's/XINERAMA/FAKEEXTN/g' libmawt.so

That's it my friend... run Zend Studio the regular way as a normal user:
$ /usr/local/Zend/ZendStudioClient-5.1.0/bin/ZDE (again, your install dir may vary)

Cheers,

--
William Lovaton

red_dungeon
13th November 2007, 06:00 PM
The problem is the replaced XLib in F8.
XLib in F8 is replaced by http://xcb.freedesktop.org/.

XCB (especially the 1.0) is not nice regarding locks.
I've upgraded libxcb to version 1.1 (upstream) and got some problems solved (Citrix Client in my case).

IMHO the Fedora-Devels should A.S.A.P. repackage xcb and replace 1.0 with 1.1.

hf

epharaoh
13th November 2007, 08:04 PM
I tried using libxcb version 1.1 by "yum --enablerepo=development install libxcb.x86_64"

It didn't solve the problem. I then tried the 'sed' workaround and it worked like a charm!

I was trying to run ArgoUML, btw.



The problem is the replaced XLib in F8.
XLib in F8 is replaced by http://xcb.freedesktop.org/.

XCB (especially the 1.0) is not nice regarding locks.
I've upgraded libxcb to version 1.1 (upstream) and got some problems solved (Citrix Client in my case).

IMHO the Fedora-Devels should A.S.A.P. repackage xcb and replace 1.0 with 1.1.

hf

walovaton
13th November 2007, 08:48 PM
I tried using libxcb version 1.1 by "yum --enablerepo=development install libxcb.x86_64"

It didn't solve the problem. I then tried the 'sed' workaround and it worked like a charm!

I was trying to run ArgoUML, btw.
Mmmm.... maybe in your case updating libxcb to rawhide wasn't necessary.

peterlauri
13th November 2007, 10:33 PM
http://blogit.claymountain.com/sf/index.php?/archives/104-Installing-Zend-Studio-Neon-Beta-on-FC-8.html solved it for me...

dmobrien2001
14th November 2007, 03:40 AM
The sed work around works great. F8, FF 2.0.0.9, jdk1.6.0_03. I NEED java applet to access my work Juniper SSL VPN. Thanks for the info!

lvanek
14th November 2007, 04:04 AM
just to add my 2 cents on this topic.

The sadest thing for me is that x-plane flight simulator cannot be reinstalled because of this bug. Both IceTea & the Sun java jre "sed fix" produce no joy when using their DVD installer.

The Sun java jre does work in the browser, however.

I am guessing its an issue with the version of java on their (x-plane) DVD. Cant fix that one. Wouldnt be an issue if it were open source.

FlightGear here I come.

I will remember this one for Fedora 8. Each of the Fedora's had some particular "brain fart" for which they can be remembered. All in all I still remain addicted to it :)

Vikswd
17th November 2007, 01:13 AM
At first,you should run Zend installer in a slint mode
#./ZendStudio-5_5_0.bin -i silent

after installation run
# cd /usr/local/Zend/ZendStudio-5.5.0/jre/lib/i386/xawt
# cp libmawt.so libmawt.so.bak && sed -i s/XINERAMA/FAKEEXTN/g libmawt.so

This worked for me, thanx!!! :)

mistergoodbytes
19th November 2007, 02:10 PM
At first,you should run Zend installer in a slint mode
#./ZendStudio-5_5_0.bin -i silent

after installation run
# cd /usr/local/Zend/ZendStudio-5.5.0/jre/lib/i386/xawt
# cp libmawt.so libmawt.so.bak && sed -i s/XINERAMA/FAKEEXTN/g libmawt.so

OK, what IS this Zend installer? Is this a package I'll never use but which contains the one tiny file which is flawed in FC8? The reason I ask is that I only have 40 GIG on my Linux partition, and so far every tiny app I want is accompanied by a massive bloat of stuff I can't remove to keep the tiny applet. So, can I get this Zend package, extract the flawed file and NOT put another huge package on my system?

Calrefawena
19th November 2007, 10:03 PM
I just wanted to point out that this works for Borland Together and Maple 9.5 as well.

For Maple, though, the file you have to change instead of lib/i386/xawt/libmawt.so is lib/i386/libawt.so.

Thanks for the fix, I can do my Maths assignments now :)

Mammouth
26th November 2007, 10:04 PM
I have the same problem with Matlab (which use its own java). Using the sed workaround made matlab starting (it was'nt before), but the same problem arise if, for example, I start the help or any part using java.
Well, i'm using octave now...

Calrefawena
26th November 2007, 10:15 PM
I have the same problem with Matlab (which use its own java). Using the sed workaround made matlab starting (it was'nt before), but the same problem arise if, for example, I start the help or any part using java.
Well, i'm using octave now...

A fix I read elsewhere is if you put


export LIBXCB_ALLOW_SLOPPY_LOCK=1

into /etc/profile.d/[whatever].sh. Then when you next log in, the errors still occur (and if you start the program from a console you'll be spammed with xcb_lock problems), but at least they don't halt the program. Which is what eventually got Maple working with open/save dialogs etc; I was a little optimistic in my other post. ;)

Hope it works for you and anyone else still having this problem.

CrystalCowboy
26th November 2007, 11:01 PM
Can any one help me to setup netbeans 6.0?

I hope if I haven't setup Fedora 8.
Now,I know stable version is important.

To fix: download and install jdk 1.6u3 and Netbeans 5.5.1 separately:
netbeans-5_5_1-linux.bin*
jdk-6u3-linux-i586.bin*

Move jdk to /opt directory, fix bug in libmawt.so:
mv jdk1.6.0_03 /opt/
cd /opt/jdk1.6.0_03/jre/lib/i386/xawt/
sed -i 's/XINERAMA/FAKEEXTN/g' libmawt.so
cd ..
ln -s xawt/libmawt.so

Then install Netbeans, it should work. During installation, you will be prompted for location of a JRE.

morrist
27th November 2007, 06:11 AM
I am a new convert to Fedora and loving it.... although it is a learning experience. I have been having the same issue with my Java install (however, I am using the JDK for college). I got the part about the lock fixed using the sed command, but this brings me to the next issue:

Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/java/jdk1.6.0_03/jre/lib/i386/libdeploy.so: libstdc++.so.5: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java :1647)
at java.lang.Runtime.load0(Runtime.java:770)
at java.lang.System.load(System.java:1005)
at com.sun.deploy.config.UnixConfig.loadLibDeploy(Uni xConfig.java:38)
at com.sun.deploy.config.UnixConfig.<clinit>(UnixConfig.java:26)
at com.sun.deploy.config.ConfigFactory.newInstance(Co nfigFactory.java:11)
at com.sun.deploy.config.Config.getInstance(Config.ja va:662)
at com.sun.deploy.config.Config.<clinit>(Config.java:678)
at com.sun.deploy.util.DeployUIManager.setLookAndFeel (DeployUIManager.java:102)
at com.sun.deploy.panel.ControlPanel.<clinit>(ControlPanel.java:33)

BTW, I can get all (as far as I can see) java-based applications such as Azureus to work. My problem is Java inside of FireFox. Note sure if it is Java or Firefox problem, but the error messages are from me trying to run the Java control panel.

red_dungeon
27th November 2007, 09:27 AM
A fix I read elsewhere is if you put


export LIBXCB_ALLOW_SLOPPY_LOCK=1

into /etc/profile.d/[whatever].sh. Then when you next log in, the errors still occur (and if you start the program from a console you'll be spammed with xcb_lock problems), but at least they don't halt the program. Which is what eventually got Maple working with open/save dialogs etc; I was a little optimistic in my other post. ;)

Hope it works for you and anyone else still having this problem.

Doesn't work OutOfTheBox for Fedora8.
Reason: F8 has libxcb1.0... the LIBXCB_ALLOW_SLOPPY_LOCK feature is only in libxcb1.1 included.

So...
you have to get libxcb from rawhide or compile yourself (see other posts about that problem).

red_dungeon
27th November 2007, 09:30 AM
I am a new convert to Fedora and loving it.... although it is a learning experience. I have been having the same issue with my Java install (however, I am using the JDK for college). I got the part about the lock fixed using the sed command, but this brings me to the next issue:

[B]Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/java/jdk1.6.0_03/jre/lib/i386/libdeploy.so: libstdc++.so.5: cannot open shared object file: No such file or directory



yum install compat-libstdc++-33


btw... open a new topic for such cases in the next time :)

franciturci
29th November 2007, 10:45 AM
I tried to install Java Runtime Environment (JRE) 6 Update 3 from Sun following the roadmap of http://www.mjmwired.net/resources/mjm-fedora-f8.html#java but it didn't manage. Quite desperate about it! When I type
java-version

it turns out

java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode,
sharing)

Is it ok?

Jongi
2nd December 2007, 12:48 AM
this xcb issue seems a bit of an issue

wolland12
4th December 2007, 10:38 AM
this xcb issue seems a bit of an issue

I must say a bit of an issue is quite an understatement. I have been using Red Hat/Fedora for 4 years now and have so far recommended it to a lot of people. Mainly because there are a lot of packages for it and also because it is comparatively easy to work with.... however this latest issue with libxc has made me re-consider my choice of distribution.

In brief I think that fedora developers have let down their users. I have been trying for 2 days to install Oracle 9i on Fedora 8 and since it ships its own jre (and copies it to a time stamped folder) I have been unable to hack it with the ugly replacement suggested. I have also installed the aptly named packages ( http://ajax.fedorapeople.org/libxcb/ ), but they dont work for some reason either...

The bottom line is .. I have lost 2 days of work trying to solve a simple problem ,which has already been addressed in OpenSuse and Ubuntu ( https://bugs.launchpad.net/ubuntu/+source/sun-java5/+bug/86103 ), which fedora developers refuse to address, since it will make debugging X application much harder?

I know the problem is within the JDKs but this does not solve anything. THere are up to 5 major JDK vendors and many of the JDKs that enterprise applications used cannot be changed. They all worked on 7 . Some Sun developer acknowledged at a conference the problem is within their JDK ... great ... how does this help the people that need to get their work done though.

I must say this is a very narrow minded approach to the user's interest. If you cannot run the core applications , such as Zend studio and in my case Oracle ( then it is pretty much useless to debug anything) .

I will post again from the Kubuntu install just to let you know whether this is an option for people that need linux not for purely philosophical but also practical uses.

Bye and Thanks for the Hat

red_dungeon
4th December 2007, 12:11 PM
@wolland12

i can understand you.
it's a pity how the fed-developers are handling this MAJOR issue.

They say:
It's a bug in the JDK's

I Say:
Yes it is... but the fact is, that the user has non-running programs (a lot of them). And in other distros it works (using the SLOPPY workaround)

I think the problem is that we have some hardliners (icedtea) in the Fedora team :mad:

Here: https://bugzilla.redhat.com/show_bug.cgi?id=301691#c4

Q here: https://bugzilla.redhat.com/show_bug.cgi?id=301691#c16
A here: https://bugzilla.redhat.com/show_bug.cgi?id=301691#c17



>>> Please remove the assertions at least temporarily.

No.The asserts are there for a reason. They prevent race conditions that
would otherwise be maddening to debug. I'm not going to sacrifice guaranteed
correctness for heisenbugs.



humm... :eek:
Why not upgrading to 1.1 and let the user decide whether they wanna use the sloppy lock thing or not ?

Adam Jackson ?

mistergoodbytes
4th December 2007, 03:04 PM
A fix I read elsewhere is if you put


export LIBXCB_ALLOW_SLOPPY_LOCK=1

into /etc/profile.d/[whatever].sh. Then when you next log in, the errors still occur (and if you start the program from a console you'll be spammed with xcb_lock problems), but at least they don't halt the program. Which is what eventually got Maple working with open/save dialogs etc; I was a little optimistic in my other post. ;)

Hope it works for you and anyone else still having this problem.

I got the messages that libxcb was locked and could not be unlocked; libxcb was unlocked and could not be locked; doublethink fullwise plusgood. The good news is that with the above code BOINC will now start, BUT I have no idea what this does to security.

lvanek
4th December 2007, 08:49 PM
It will be interesting to see what happens if this problem remains unresolved & some version of F8 eventually morphs into RedHat's enterprise desktop client. Issues with installing 3rd party software will not fly in a business environment.

fedcor8
5th December 2007, 07:20 AM
cannot install J2EEsdk-1_4_03-linux.bin . I get this error message :
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Deleting temporary files...

Please help.

Thanks
Fedcor8

Gooddy
5th December 2007, 08:43 AM
It is time Red Hat to take measures on correction of a situation!

lyonsban
5th December 2007, 11:05 PM
11G on Fedora 8

echo `expr 1024 \* 1024 \* 1024` > /proc/sys/kernel/shmmax

groupadd dba
groupadd oinstall
useradd -c "Oracle Database Owner" -g oinstall -G dba oracle
passwd oracle

mkdir /opt/oracle
mkdir /opt/oracle/product
mkdir /opt/oracle/product/11G
chown -R oracle.oinstall /opt/oracle
mkdir /var/opt/oracle
chown oracle.dba /var/opt/oracle
chmod 755 /var/opt/oracle

vi /home/oracle/.bash_profile
# Oracle Environment
export ORACLE_BASE=/opt/oracle
export ORACLE_HOME=/opt/oracle/product/11G
export ORACLE_SID=MyData
LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
export LD_LIBRARY_PATH

xterm +
su - oracle
unzip linux_11gR1_database.zip
cd database
./runInstaller -jreLoc /usr/lib/jvm/jre

Ignore warnings or fix them if you want. It doesn't seem to matter
Get the Oracle DBA to do the housekeeping if you don't know how (tnsnames.ora, memory allocation, database file location etc etc etc)

Overall this is by far the -easiest- install of Oracle I've done since version 7 on fedora 5

ksmj
7th December 2007, 09:24 AM
when i followed your instruction with oracle 10, i get this error


Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2
Passed


All installer requirements met.

Preparing to launch Oracle Universal Installer from /tmp/OraInstall2007-12-07_04-20-33PM. Please wait ...
Preparing to launch Oracle Universal Installer from /tmp/OraInstall2007-12-07_04-20-33PM. Please wait ...
[oracle@localhost database]$ Exception java.lang.NullPointerException occurred..
java.lang.NullPointerException
at oracle.sysman.oii.oiix.OiixPathOps.concatPath(Oiix PathOps.java:553)
at oracle.sysman.oii.oiic.OiicBaseApp.setAdditionalPr operties(OiicBaseApp.java:369)
at oracle.sysman.oii.oiic.OiicInstaller.processComman dLine(OiicInstaller.java:668)
at oracle.sysman.oii.oiic.OiicInstaller.runInstaller( OiicInstaller.java:887)
at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInst aller.java:866)


Any idea?

uname -a : Linux localhost 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 22:14:09 EST 2007 x86_64 x86_64 x86_64 GNU/Linux


if i just do ./runInstaller, I get



Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-3, SuSE-9, redhat-4, UnitedLinux-1.0, asianux-1 or asianux-2
Passed


All installer requirements met.

Preparing to launch Oracle Universal Installer from /tmp/OraInstall2007-12-07_04-22-37PM. Please wait ...
[oracle@localhost database]$ java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.



Please help

lvanek
8th December 2007, 07:24 AM
I found a work around on the Fedora mail list that works for me:

https://www.redhat.com/archives/fedora-list/2007-December/msg00827.html

The steps are:

[1] enable the development repo

[2] update libxcb to libxcb-1.1-1.fc9.i386

[3] set enviroment variable:

export LIBXCB_ALLOW_SLOPPY_LOCK="1"

This allowed me to install x-plane as I had with Fedora 7.

red_dungeon
8th December 2007, 03:47 PM
As I said in this topic.... libxcb 1.1 HAS TO GO TO F8 A.S.A.P

mikahe
9th December 2007, 02:57 PM
Recent libxcb 1.0-4 update fixes the problem :)

red_dungeon
10th December 2007, 01:58 PM
Great !!!

And without the need of setting the SLOPPY Env Var !

https://bugzilla.redhat.com/show_bug.cgi?id=390261#c10

Sren Sandmann Pedersen, you're the man :D

Gooddy
10th December 2007, 02:39 PM
lvanek

DBSodo

Thanks, has normally passed all!

:)

haydude
19th December 2007, 10:51 PM
It will be interesting to see what happens if this problem remains unresolved & some version of F8 eventually morphs into RedHat's enterprise desktop client. Issues with installing 3rd party software will not fly in a business environment.

Fetore's (that means stink) developers are dumb like the name of the distro:
"regression testing" is alien to them

lyonsban
22nd January 2008, 06:07 PM
All other comments on what libraries should or should not be in core Fedora aside, -this- is a Oracle issue more than a Fedora issue IMHO. I've been installing Oracle on linux since 2000 and prior to than on HP/UX and SUN. It's never been easy to do, ever. Until now.

Upgrade to Oracle 11. The only issue I had when I upgraded was attaching the temp file because temp doesn't attach automatically, but heck that's simple DBA stuff. I didn't even have to recompile functions, procedures or views.

No I don't work for Oracle. I just know a good thing when I see it.

wizard_nitrkl
22nd February 2008, 02:32 PM
Peter, I had the same exact problem as you and I could find a solution. Now Zend Studio works fine for me. =)

Let's see, the problem happens for many Java versions on a recent linux distribution, in this case Fedora 8. The workarounds posted here worked fine, the really difficult part is applying the workaround to the right installation of the JVM. In this case it's very tricky because the binary installer uncompress a different JVM in /tmp/install.dir.XXXX (where XXXX are different random numbers) every time you try to execute the binary installer.

So, what I did was to make a temporary copy of the JVM bundled with the Zend installer somewhere else (eg: /root - you can delete it later on) with the following command:
# cp -R /tmp/install.dir.XXXX/Linux/resource/jre/ /root/java

Remember to replace XXXX with the exact numbers. Then apply the fix on that Java installation in the root home:
# cd /root/java/lib/i386/xawt
# sed -i 's/XINERAMA/FAKEEXTN/g' libmawt.so

That's all, now execute the Zend installer this way:
# ./ZendStudio-5_1_0.bin LAX_VM /root/java/bin/java

note that I am using Zend Studio 5.1.0 and you are using a newer one (5.5.0) so I had to previously apply the fix explained here [ http://www.zend.com/support/knowled...226&view_only=1 ] to make it work. It's an old problem and it's needed to install Zend Studio even on Fedora 7. So you might need to apply this, may be not. But I guess you probably know this already.

Now, follow the regular steps during the installation and then apply the same fix to the definitive Java installation for Zend Studio:
# cd /usr/local/Zend/ZendStudioClient-5.1.0/jre/lib/i386/xawt (your install dir may vary)
# sed -i 's/XINERAMA/FAKEEXTN/g' libmawt.so

That's it my friend... run Zend Studio the regular way as a normal user:
$ /usr/local/Zend/ZendStudioClient-5.1.0/bin/ZDE (again, your install dir may vary)

This worked fine for me.

-Sarvoday Bishnoi

coolsesh
19th November 2009, 09:15 AM
I am using FC8 and I got the same bug and i followed this instructions:

I used the "sed" workaround and it worked for me:

For sun-java5-bin:
sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-1.5.0-sun-1.5.0.11/jre/lib/i386/xawt/libmawt.so

For sun-java6-bin:
sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.00/jre/lib/i386/xawt/libmawt.so

I hope this gets fixed soon.

It worked for me on Java5 environment. Hope for you too.....

RupertPupkin
19th November 2009, 08:10 PM
I hope this gets fixed soon.
It was fixed in F9, i.e. about a year and a half ago. :)