PDA

View Full Version : Fedora 8 install barfs init[1]



Pigpenn
11th November 2007, 09:04 AM
Hi

Fresh install of Fedora8 and it barf during boot with;

init[1]: segfault at 0000000000000010 rip 00002aaaab0f8e84 rsp ..........

Any ideas?

andgeo
28th November 2007, 12:43 PM
+1 another victim of the same bug(?) here . The weird is that i have the same memory faults . I mean 000000...10 rip 00002aaaa.... rsp .... error 4.

I googled for a while but no luck . I found a thread in kernel.org with the same issue but it was for the kernel 2.6.20 rc2 ... a year ago . They claim that they have the bug fixed right now , but i couldnt find any reasonable solution for my problem , except to recompile a new kernel with recovery disk and using the kernel option CONFIG_PROFILE_LIKELY=y: to n . Didnt try it yet . I m wondering if this issue has come up to a peer around . I checked the fedora forums and redhat's bug list . I found similar problems while booting but the error was init[1]: trap device .. or sth. Still no luck with the problem . No solution found .
My system is a X86_64 Intel D with RAID0 enabled dual boot with XP , no BDS etc , and the OSes are installed at a third HD (sdc ) at partitions 1 (XP ) and 3 (FEDORA8) , nothing to do with the RAID .
Thanks in advance for any help !!!!

andgeo
28th November 2007, 03:15 PM
any one???

andgeo
28th November 2007, 09:35 PM
omg still no answer

bob
28th November 2007, 09:48 PM
Rather than keep posting 'bumps' on a thread, which isn't acceptable under the Guidelines, I'd check Bugzilla and the mailing lists to see who else has reported it and what the developers say. No reports? Well, then you know what to do! If you feel this is a bug that needs to be addressed, the only way the developers will find it is if you report it.

andgeo
29th November 2007, 09:09 AM
OK latest news ... Sorry for the off-topic posts . I Had no idea .
Anyway i manage to boot only when i unplugged the raid 0 disks . Everything went Ok . It s ok with my system since all the RAID is in ntfs file system . So there is no problem . As for the advice about the bug ... I dont even know if it s a bug or something else . So how can i submit a ticket to developers when i m not sure what the hell this problem is . Thats why i posted here in order to find any peer with the same problem . I saw Pigpen's post 2 weeks ago .Since then i have been roaming around with UBUNTU 7.10 and Mandriva . The only one that worked without a problem was Madriva 2008 . But due to restrictions with proprietary and commercial software i decided to have my FEDORA 8 fixed .
This is the whole story .
Sorry again .

suicidaleggroll
19th March 2008, 03:19 AM
I ran into this problem recently on a new computer of mine, and I believe that in my case it was a memory problem. Specifically, too low a voltage. DDR2 spec is 1.8v, these dimms run at 2.2v. I had them at 2.16 and would periodically get hangups and X crashes. I tried dropping it to 2.06v and that's when I ran into this init[1] segfault.... problem. I bumped it up to 2.26v and it seems to be running happy as pie.

Fedora 8 x86_64
Intel Core 2 Duo E6750
4GB DDR2 1066 Crucial Ballistix
750g Samsung sata2
GeForce 7600GT
etc