PDA

View Full Version : Fedora Won't Startup



zimecki
10th November 2007, 10:04 PM
I was in the middle of updating my packages, when the entire GNOME interface froze. Impatient, I manually rebooted the computer. Upon starting it up, I was prompted with the following error:

'Checking filesystems /dev/VolGroup00/LogVol00: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY [FAILED]'

I was asked to type in root password for maintenance, which I did, for the error which occurred 'during filesystem check'. Immediately afterwards, the following came up:

(repair filesystem) 1 #:

I don't know what exactly I'm supposed to input, or any steps to fix this problem, so if anyone can help me with this problem, it'd be immensely appreciated.

Thanks in advance.

zimecki
10th November 2007, 10:07 PM
Also, I am instructed to run 'setenforce 1' to reenable.

EDIT: As per the instructions outlined at http://forums.fedoraforum.org/archive/index.php/t-51550.html , I have attempted to try the following:

'OK, I fought my way out of this one. After doing some research I found out that the resize2fs that comes on the stock fedora core 3 rescue disk is hosed. I think it is version 1.35. Version 1.36 addresses some of the problems caused by the broken version. What I wound up doing was burning a fedora core 4 test 3 rescue disk which comes with the correct version of the e2fs tools. I would have prefered to create a fedora core 3 rescue disk with the updated tools but I couldn't figure out how to do that in a timely fashion.

Once I was booted from the fedora core 4 test 2 rescue disk I ran the following commands:

#debugfs -w /dev/VolGroup00/LogVol00 -R "features ^resize_inode"
#e2fsck

e2fsck was able to find the errors and fix them. I was once again able to boot my system.

The project page e2fsprogs at http://sourceforge.net/project/shownotes.php?group_id=2406&release_id=296242a suggested that I run ext2prepare after my file system was fixed in order to reenable online file system resizing (which is what I should have probably done to begin with). I'm a bit hesitant to try this at this point after all the nightmares. Does anybody have experience with this procedure?'

The first command prompted the following: 'no such file or directory while opening filesystem... features: filesystem not open'

To the second, I was only provided a list of commands for e2fsck, but I could not figure out how to execute them.