PDA

View Full Version : Upgrading F7 64bit to F8 64bit errors out with strange error



ajamison
10th November 2007, 08:47 PM
I have tried to upgrade F7 64bit to F8 64bit using the F8 repos everything downloads fine but then when it runs the transaction check before installing the downloaded packages i get the following error



Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package compiz needs libwnck-1.so.18, this is not available.
Package dbus needs libexpat.so.0, this is not available.
Complete!


now I am not sure why rpm_check_debug is on I did not turn Debug on

but i can not get past this point I have tried now 10 times all with fresh downloads of packages.

Seve
10th November 2007, 09:41 PM
Hello:
I've never done an upgrade from one version to the other, so this is just a suggestion.

How about trying to exclude the compiz packages ?

You can always sort that out after you get through with the update.

Seve

ajamison
13th November 2007, 02:34 AM
well that did not work ethier I had to download and upgrade from an ISO

tgmauch
30th December 2007, 09:41 AM
I ran into the same problem. It looks like the x86_64 version of FC7 had both an i386 and x86_64 version of dbus, but FC8 has only the x86_64 version. To get past the error I ran:


yum erase dbus.i386

after updating rpm and yum, but before running


yum upgrade

This removed the complaint about compiz as well, and I was able to proceed with the upgrade.