PDA

View Full Version : Fedora 8 freezes after choosing keyboard type



RKight
10th November 2007, 09:21 AM
When I try to install Fedora 8, the installation makes it as far as the keyboard selection screen. I am able to click on any keyboard type and everything will function like it should...up until I click the next button. I have tried choosing something other than US English, have checked the installation media, and have even tried installing in text mode...but no luck. When I click next in graphical mode, the next button turns dark and the computer will just sit there. I can still move the mouse but cannot click on anything else and nothing happens...it just sits there like that until I do a hard reboot. In text mode, the text box disappears and nothing else ever pops up. This is frustrating. This is happening in the x64 version, by the way.

I may try the 32-bit version...but I'm thinking I tried the 32-bit version of Fedora 7 a while back, with no luck. I currently have Slackware installed on my Linux partition, as it is the only version I was able to get installed. Unfortunately, I don't really like that distro and would much rather have Fedora; I've been a big Redhat fan for a long time...started with Redhat 5.2 and have been running Fedora since the beginning...would be a shame to lose the ability to run Fedora just because I built a new computer.

i0ls
10th November 2007, 09:57 AM
same thing happened to me with the 32 bit live cd install. i made a coaster and another copy and had no problems.

RKight
10th November 2007, 10:23 AM
I may try that...the media checked out okay, but that doesn't necessarily mean anything. I did fire up Rhapsody while burning the DVD and noticed my buffer went way down for a couple of seconds. I'll try to burn it again sometime this weekend and post my results.

RKight
13th November 2007, 09:53 AM
Okay...so I tried burning another copy, this time without running any other programs (not that I really have to worry about messing up a burn...technology has come a long way since the days of solitaire causing a buffer runout error). Anyway, nothing changed. Thankfully, I have another 64-bit computer in the house that I was able to test this on. I fired up the wife's computer with the Fedora 8 disc in the drive...and I was able to get past the keyboard selection screen. In fact, the usual box came up warning me that the sata drive's partition was unreadable. I didn't go past that because she wouldn't be happy with me for installing linux on her computer.

Anyway, this makes me wonder if my RAID controller isn't the problem. I tried disabling it but all my BIOS lets me do is disable RAID...it won't let me entirely disable the SATA controller. :-( I tried disabling RAID anyway but it didn't change anything. I think it is also worth mentioning that I also have the 32 and 64-bit versions of Fedora 7, as well as the Fedora 7 64-bit live CD. I tried all of these to see if the problem was related only to 8 (as I wasn't sure if I had tried the 32-bit version of 7 or not) and both the 32 and 64-bit versions of Fedora 7 stopped in the exact same place...but the live CD worked flawlessly.

Is there a command I can enter at startup that will prevent Fedora from detecting my SATA controller? It loads a driver called "SATA_NV". If it helps, I am listing the hardware in both my computer and my wife's computer.

My computer:
Asus L1N64-WS
2x AMD Athlon FX-74
4Gb Corsair XMS2 PC-6400
4x 80Gb SATA HDDs (3 in RAID0 and 1 by itself)
1x 80Gb IDE HDD (the one I want to install linux on)
1x SATA DVD burner
Hauppauge HVR-1600
2x nVidia GeForce 8800 Ultra

My wife's computer:
Asus SK8N
AMD Opteron 250
2Gb Corsair XMS PC-3200 Registered
2x 74Gb WD Raptor (RAID0)
IDE DVD burner
Sound Blaster Audigy 2 ZS Platinum
nVidia GeForce 7600 GS

I don't know if this will help, or not, but I thought it would be worth mentioning.

Mariusz W
13th November 2007, 12:32 PM
I experienced, and repeatedly at that, exactly the same problem as reported by RKight. Since the integrity of my DVD was beyond doubt: I used the same DVD to make upgrades on two computers; on one of them the upgrade was successful, while on the other of the two it stuck on the already infamous Yum Loop Bug, cf.

http://fedoraproject.org/wiki/Bugs/F8Common#head-7b9bf2dab0e2bdd97d98334c7198cd9cd3eaf9be

I knew the problem was somewhere else. In fact, I discovered that the hang was related to having an external 250GB disk connected via USB, with three partitions on it: ext3, FAT32, and NTFS, each approximately 80GB.

The hang disappeared after I diconnected the disk: on the next install boot Anaconda didn't hesitate for a second after the keyboard selection screen.

It is quite likely that given enough patience, Anaconda would move past the keyboard screen on its own without diconnecting the external drive.

RKight
13th November 2007, 07:35 PM
Your story makes me wish I had an external drive, as I can't think of anything else I can do at this point other than use a command at bootup to make it ignore the sata controller. If anyone knows of any such command, please let me know.

I just did some looking around and ran across a list of boot options...I can't believe I forgot about the "noprobe" switch...I may try that just to see what happens.

maxwedge
13th November 2007, 07:48 PM
I had the exact same problem hanging at the KB type until I disconnected 6 of the 7 HDs in my system and using only the one I want to install on. :D

Hope you get it going.

Apathetik
15th November 2007, 08:15 PM
I recently had same issue with Fedora 7 (both 64bit) I tried the 32 bit with same issue. I eventually unplugged all my hard drives except the one i wanted to install on and that got it going. It worked fine after I re-connected the other drives (I have 4 hdd's) and everything continued to work fine.

Hope that helps!

kafros
16th November 2007, 05:28 PM
i had the same problem on both fedora 7 and 8 and i solved it by typing nodmraid in the beginning of installation

HomeBrew
20th November 2007, 01:10 PM
Exactly the same problem here -- Fedora 8 DVD hangs after selecting keyboard. I was also suspecting RAID as the problem. I have RAID (Promise PDC20276 chip) disabled by motherboard jumper, and none of my three drives are plugged into the RAID IDE connectors (this is an Asus A7V333 MB), but it still hangs.

Will give the nodmraid kernel option a try...

HomeBrew
20th November 2007, 01:22 PM
That seems to have fixed it -- though I haven't time to do the full install right now, I just tried it with the nodmraid option, and it got past the keyboard selection page...

Thank you, kafros.

Curiously, this machine previously had Fedora Core 4 on it, and two of the drives were actually configured as a RAID array (they're not any longer). So, some new distatste for the RAID controller has snuck in between FC4 and Fedora 8, or it doesn't like the fact that there's a RAID chip but the IDE ports it uses are unoccupied. Truthfully, I'm not sure how the anaconda is even detecting the Promise chip when it's disabled at the MB level...

NewFedoraner
2nd December 2007, 04:22 AM
I had EXACTLY the same problem. I tried again (after hours of desperation) using the nodmraid option and it worked immediately. THANK YOU SO MUCH!

RKight
2nd December 2007, 06:29 AM
Wow...I didn't think to check this for replies...I'm going to try that boot option as soon as I get done posting this. I hope it works because I miss linux a lot and I've also been curious to see how well the 64-bit version will perform on my FX-74s. I have never used linux on a multi-cpu system before so I am really looking forward to trying this out.

Edit: I'm also sick of my computer blue-screening every time I shut Vista down. I have traced that issue back to the video card driver (I guess that's what I get for running the latest nVidia card with a crappy under-developed OS) and am waiting for a fix from nVidia. I wouldn't even use Windows except for the fact that I am addicted to Photoshop and gaming. I know linux has Gimp...but it really isn't as good as Photoshop in my opinion. Anyway...off to try this fix...wish me luck!

NewFedoraner
2nd December 2007, 09:49 AM
I just got Fedora 8 to work and am now just struggling with getting Compiz to work...
In my opinion Gimp is an excellent software that gets closer to (or even better than) Photoshop, but that's my very own opinion.

RKight
2nd December 2007, 10:12 PM
Alright...good times. I'm typing this from Fedora 8 64-bit. :D I expected to have a lot of issues with hardware compatibility...but it seems as if a lot of those issues have been taken care of. I used to not be able to install the nVidia driver successfully...but it installed flawlessly this time and everything is working great. Thanks a ton for solving my problem!

blacksheep1
3rd December 2007, 08:53 PM
I have the same prob, too. Have a Gigabyte p35-DS4 Mainboard, with an Intel and a Gigabyte SATA2 Raid controller. Have two 320 GB Hdd's connected to the Gigabyte controller (switched to intel, nothing changed) in Raid0. DVD-Burner @ Intel controller (switched here, switched there, nothing happened). F7 is no prob, just this ****** F8 :( Any ideas with your made experiance?

NewFedoraner
4th December 2007, 01:59 AM
have u tried the nodmraid (boot menu-->[TAB]-->nodmraid) ?

blacksheep1
4th December 2007, 01:17 PM
yep, with nodmraid option he doesnt find any Hard disks...

NewFedoraner
4th December 2007, 03:02 PM
hmmm, never mind.

blacksheep1
7th December 2007, 10:24 AM
help? :rolleyes:

blacksheep1
11th December 2007, 05:04 PM
*pushup* :(

FriedChips
11th December 2007, 06:10 PM
linux i8042.nomux
try booting with that command

Apathetik
4th January 2008, 12:10 AM
I recently reinstalled and had same issue, tried the nodmraid option and it didn't work for me, had to unplug all but the install drive, again.