PDA

View Full Version : Fedora 8 hanging on running /sbin/loader



nincehelser
10th November 2007, 03:15 AM
I've read of some others having this problem, but their fixes don't work for me.

The system is an HP Compaq nx6125 laptop. The processor is an AMD Turion64.

I had no installation problems on this machine with Fedora 7.

I've tried both the 64 and 32 bit versions of Fedora 8. No difference.

The furthest I've ever gotten is entering "nousb" on the boot line. That gets me farther...just past the point where it asks to check the media, but then it just goes nowhere.

fengshaun
10th November 2007, 04:02 AM
in the first menu where you choose to install/rescue etc. go on Install and press tab and add these after vmlinux...etc.

floppy.allowed_drive_mask=0 clocksource=acpi_pm

see if it works. I got this from another topic in this forum and the credit goes to people who discussed it in Bugzilla.

nincehelser
10th November 2007, 04:18 AM
Thanks, but I already tried those. They don't seem to help in my case.

openjaf
10th November 2007, 04:30 AM
I had the same problem with the /sbin/loader, looked like it displayed a grossly formatted memory dump to the menu screen and then nothing forever, You could switch to the other counsels.

Used the boot up parameter fix and it worked fine.

HW: Dell Latitude D630, core2 duo T7500

Thanks,
James.

dcrowder32
14th November 2007, 04:35 AM
Boot parameter worked for me also.

Dell Inspiron 1200 Laptop, Intel Celeron M

evad
18th November 2007, 02:15 AM
in the first menu where you choose to install/rescue etc. go on Install and press tab and add these after vmlinux...etc.

floppy.allowed_drive_mask=0 clocksource=acpi_pm

see if it works. I got this from another topic in this forum and the credit goes to people who discussed it in Bugzilla.

Worked great for me - installing F8 on friend's Dell Latitude D400

bfc
18th November 2007, 02:32 AM
Try one of the liveCD's, for some reason I didn't have the /sbin/loader issue when I used the KDE liveCD.

evad
18th November 2007, 02:43 AM
Try one of the liveCD's, for some reason I didn't have the /sbin/loader issue when I used the KDE liveCD.

LiveCD (with Gnome) actually worked without any problems on the same machine.. :-o

bbfuller
18th November 2007, 01:22 PM
Hello nincehelser

Like you, I'm running an HP Compaq nx6125. I've just managed to get a working installation on this machine and if you haven't succeeded yet you might want to try the following.

From the install menu add:

acpi=off apm=off pci=noacpi

For me, with the DVD install, it got me past the /sbin/loader hang. But after the "Check Install Media" screens I just got some sort of screen dump and yet another hang.

However, it has enabled me to boot from the KDE live CD and then install from that.

acpi=off though is retained in the boot loader and needs to remain there otherwise the installed system won't boot!

Unfortunate because it means the machine won't automatically power off. It's a shame we've gone back to this situation with this particular model of laptop. When it was introduced it was widely noted for a non-standard bios/acpi implementation, but I guess subsequent kernels patched round it as it's been sorted for a long time. It's only the Fedora 8 series that seems to have reintroduced the problem.

If you do get round to trying it, I can't guarantee it working for you as I've only done it the once so far. I'd be interested to hear how you do.

nincehelser
18th November 2007, 08:21 PM
Thanks! That's finally getting me somewhere, but I'm not sure why.

If I boot from the Fedora-8-Live-i686 with the added parameters "acpi=off apm=off", I can boot.

What has me confused is that the AMD Turion isn't an i686 architecture (as far as I know), so why does the i686 image work, but not the x_86-64 (which should be the native architecture for a Turion)? The x_86-64 images just panic when I try to turn off acpi.

???

Anyway, at least it has booted up live. I'll try an install to the hard drive now and give you an update.

Thanks, again!

nincehelser
18th November 2007, 08:39 PM
The install seems to have worked without issue.

The next challenge will be getting the wireless to work....

bbfuller
18th November 2007, 10:14 PM
Hello nincehelser

Glad it worked for you as well.

The wireless works for me using the b43 module and b43-fwcutter method 2 shown here:

http://www.fedoraguide.info/index.php/Fedora8#Broadcom_bcm43xx_.28Method_1.29

Connects OK to WPA-PSK. Connecting with encryption has been a bit of a problem for some fedora 8 installations/setups.

However, it's slow and drops a lot of packets. I'm going to try with ndiswrapper either this evening or tomorrow. I'll compare notes with you.

evad
18th November 2007, 10:33 PM
The wireless works for me using the b43 module and b43-fwcutter method 2 shown here:

http://www.fedoraguide.info/index.php/Fedora8#Broadcom_bcm43xx_.28Method_1.29

Connects OK to WPA-PSK. Connecting with encryption has been a bit of a problem for some fedora 8 installations/setups.

However, it's slow and drops a lot of packets. I'm going to try with ndiswrapper either this evening or tomorrow. I'll compare notes with you.

Unfortunately b43 wireless doesn't work with me - check this thread: http://forums.fedoraforum.org/showthread.php?p=904315

And I did exactly the same thing with b43 firmware, as described abovementioned in method 2.... :(

bbfuller
18th November 2007, 10:45 PM
Hello evad

Wireless at this stage of the Fedora development cycle is a bit of an adventure!

It's very dependent on what version of a wireless card you have and upon what type of encryption you are using on the wireless network.

Have you tried it without any encryption at all? Are you seeing wireless networks in the network manager applet? Have you tried ndiswrapper?

Sorry, I see that you have answered some of those questions in the other thread.

What is the output of:

iwconfig

evad
18th November 2007, 10:47 PM
Hello evad

Wireless at this stage of the Fedora development cycle is a bit of an adventure!

It's very dependent on what version of a wireless card you have and upon what type of encryption you are using on the wireless network.

Have you tried it without any encryption at all? Are you seeing wireless networks in the network manager applet? Have you tried ndiswrapper?

Sorry, I see that you have answered some of those questions in the other thread.

What is the output of:

iwconfig

Thanks for interest in that matter, but problem is now solved and I feel like a fool, as the reason was... disabled wireless adapter by softkey combination Fn-F2. :| But thanks anyway! :)

nincehelser
19th November 2007, 12:26 AM
BINGO!

The b43-fwcutter, method 2 worked!

I'll play with it some and see how reliable the connection is.

I hope they get this get this stuff working "out-of-the-box" next time.

Thanks for your help!

bbfuller
19th November 2007, 12:53 AM
Hello nincehelser

Yes, it works - after a fashion.

The command:

iwconfig

will tell you what speed it is connecting at. Mine begins by connecting at 11Mbs which is not surprising as the open source wireless drivers rarely seem to connect at anything more. If it stayed at that it would be fine. However, after a period of time mine has regularly switched down to 1Mbs, which even at headline rates is half of what my broadband connection is capable.

When I use ndiswrapper under Fedora 7 I regularly get a reported 54Mbs and although it may not be telling the whole truth, file downloads are much quicker.

I'll still be trying ndiswrapper on mine.

As to working out of the box, I doubt it. The ndiswrapper method requires non-free software from your Windows driver and even the firmware extracted by the b43-fwcutter is I believe non-free (as in free to modify and tinker with) so it won't qualify for inclusion in Fedora.

nincehelser
19th November 2007, 02:46 AM
I'm getting a respectable speed. I just downloaded a 523M file in 18 minutes, 30 seconds.

According to wget, it averaged 482.86 KB/s, which should be around 4 Mbps. My broadband connection has a limit of 6 Mbps, so that seems pretty decent.

When I started the download, iwconfig was reporting 1 Mb/s, then jumped to 24 Mb/s shortly into the download.

In any case, I'm finding it nicely functional.

mgabriel
23rd November 2007, 02:30 PM
Tks!

Work Here!

kaos_frack
27th November 2007, 12:18 PM
disregard my previous message i solved that
but i got a new problem
when i choose cd/dvd media it says "the fedora disc was not found in any of your CDROM drivers. Please insert the Fedora disc and press OK to retry"
help

xmas_spirit
2nd December 2007, 03:11 PM
i've succeeded with the fc 8 installation on my nx6125 with following additional parameters:
noapic nolapic rhgb

noapic nolapic solved the hanging /sbin/loader problem
and rhgb solved the "grossly formated memory dump"

MountainMan101
4th December 2007, 05:09 PM
So does that mean nx6125 users are back to having to boot "noapic nolapic" - I thought this bug was fixed in Kernel 2.6.21 (around the time of Fedora 7).

Philip

MEG
4th December 2007, 06:00 PM
Fedora 8 hanging on running /sbin/loader
Same PROPLEM !

kaos_frack
4th December 2007, 06:06 PM
does this work for you MEG:
floppy.allowed_drive_mask=0 clocksource=acpi_pm

it worked for me but i get another error:
the fedora disc was not found in any of your CDROM drivers. Please insert the Fedora disc and press OK to retry

MEG
4th December 2007, 06:37 PM
kaos_frack

the problem is not solved :(

bbfuller
4th December 2007, 07:50 PM
Hello MountainMan101

Like you, I have an nx6125 and as you say, we seem to have stepped back to the old behavior of needing to disable acpi to get a bootable machine. Incidentally, I use the single parameter acpi=off to get mine to work.

I keep hoping that each new kernel will rectify the problem - have you tried the latest 2.6.23.8-63.fc8 yet? I have still to get round to that.

bbfuller
4th December 2007, 08:25 PM
Answered my own question there MountainMan101 as to if the 2.6.23.8-63.fc8 kernel fixes the problem, and I'm afraid the answer is "No".

MountainMan101
5th December 2007, 10:20 AM
2.6.23-21 was working fine in Fedora 7, but 2.6.23 isn't working F8. Surely this should be quite simple to *fix*. Has anyone opened a bug yet - if not I'll put one in.

MountainMan101
5th December 2007, 10:29 AM
There is a bug for the installed - now filed on for an installed system. Anyone know if you can install an F7 kernel on F8.

MountainMan101
5th December 2007, 11:30 AM
Actually, you don't need "acpi=off". It seems to work if you have "nohz=off" (same bug as some Dell laptops). Not sure what this does (turns back on the kernel ticks probably). I also changed "noapic" to "nolapic" but I'm not sure is either are needed. I just don't have the time for frequent reboots at the moment.

Has anyone with an nx6125 got Bluetooth working - the device seems to be missing "hcitool scan" says "Device is not available: No such device".

Philip

bbfuller
5th December 2007, 12:06 PM
Thanks for that MountainMan101

I can confirm that my nx6125 appears to work well with the only addition to the normal fedora installed bootup parameters being "nohz=off".

I'm not convinced that gkrellm is reporting the correct temperatures though.

glennzo
5th December 2007, 12:51 PM
I searched this thread and found no mention of the term 'USB'. I installed Fedora 8 on a third partition on this laptop while my thumb drive was inserted. The setup did indeed hang at /sbin/loader, for quite some time. Thinking that the thumb drive could be the culprit I reset the computer, removed the thumb drive and restarted the install. The pause at /sbin/loader was dramatically decreased, probably to around a 30 second delay, down from several minutes. Just wanted to throw this out there. If it's already been covered then flip this page over and use the other side. Don't waste the paper!

MountainMan101
6th December 2007, 09:30 AM
The bug for the "nohz=off" problem has been fixed in cvs and kernels -81 onwards according to the bugzilla report:

https://bugzilla.redhat.com/show_bug.cgi?id=411681

marc.covey
11th December 2007, 11:24 AM
I was having issues with getting past this point as well so after talking with someone on IRC he had me try this

vmlinus initrd=init.img ide=nodma \ apm=off acpi=off vga=normal nosmp and it worked. well so far I am still installing right now. 329 of 868 packages completed. lol

I am using a toshiba satelite a45-s150

bbfuller
11th December 2007, 11:28 AM
Hello marc.covey

Welcome to the forum.

There have been lots of ways attempted to get round this particular problem.

acpi=off has caused its own problems though in that often it will prevent a machine automatically powering off.

If that turns out to be the case for you then you may want to try some of the less draconian alternatives.

MEG
15th December 2007, 08:10 AM
acpi=off apm=off pci=noacpi
Finally , Fedora 8 was installed successfully :)

bbfuller
15th December 2007, 10:46 AM
Hello MEG

Do try some of the remedies mentioned earlier in this thread though.

acpi=off for example was necessary on one of my machines to get the thing to install. After install it was a nuisance as it prevented the machine from powering off automatically.

It turned out that once installed all it needed was:

nohz=off

It wouldn't boot without that, but would shut down properly without the rest of the parameters.

BobLfoot
31st December 2007, 05:45 AM
Found this on this wiki http://fedoraproject.org/wiki/Bugs/F8Common#head-ab9c2ff9166fa54eb2c08cd8c51162252b16ad8a and it works, but for a Noob would be nice if the hint said to press Tab to edit the kernel line. Took a while to figure out how to enter the nohz command.

HowardRoark
30th March 2008, 03:45 AM
Thanks, your boot parameters below solved this /sbin/loader problem perfectly on my HP/Compaq 6710b laptop!

HowardRoark


in the first menu where you choose to install/rescue etc. go on Install and press tab and add these after vmlinux...etc.

floppy.allowed_drive_mask=0 clocksource=acpi_pm

see if it works. I got this from another topic in this forum and the credit goes to people who discussed it in Bugzilla.

fengshaun
30th March 2008, 04:36 PM
worked? you're welcome :)

quarkhirad
11th April 2008, 12:24 PM
Thanks Fengshaun.

The code worked


floppy.allowed_drive_mask=0 clocksource=acpi_pm

however there is just one problem. When i start installing the system. It formats my hard disk the transfers the image to my HDD and then starts the installation. Suddenly an error pops up file ******** cannot be opened. This could be because of a broken page or the image is corrupt. Hence i rebooted and tested the dvd . The check said that the media check passed. Thus my dvd is ok. Next just to make sure i restarted the installation and this time it said file ##### is corrupt ( files ******* and#### are different files). I noticed that each time i restarted the process it gave me a new file. Then to make sure the DVD is perfect i put the dvd into my friends laptop and it installed fedora without any problems. Hence my dvd is perfect. Now what could be the problem ??

Heeeelllllpppppp :confused: :confused: :confused: :confused: :confused: :confused:

fengshaun
11th April 2008, 08:57 PM
try using other codes (above)! if it still doesn't work, I have no idea what is the problem!! O_O

fengshaun
11th April 2008, 08:59 PM
maybe try installing fedora from a live cd!!! just a suggestion! If you have a usb stick, you can use livecd-tools from your friend's laptop to put the live cd on your usb stick and install it from there!!

http://fedoraproject.org/wiki/FedoraLiveCD/USBHowTo

quarkhirad
14th April 2008, 03:06 PM
Thanks fengshaun

HowardRoark
19th April 2008, 04:29 PM
Hi quarkhirad:

I quoted your post and added some additional info and started a new thread with this topic so it will be easier for everyone to fined:

Dual Layer DVD (DL DVD) reliability...

Hope that's OK.

Regards,
HowardRoark