PDA

View Full Version : F8+nvidia livna driver + dual monitor + compiz fusion



carlainz
9th November 2007, 02:42 PM
hi

on my laptop i have F8, livna driver for nvidia and compiz fusion , and an external monitor.
i have try to enable twin view on the nvidia control panel , but when i open a program i have the windows on both screen , and also the toolbar is on both screen .
how can solve this ?
the laptop monitor is an 15.4 1280x800 and the external a 17 tft 1280x1024

thanks


more xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 64.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Karl_W_Lewis
9th November 2007, 02:55 PM
I *think* it might help if you add: ` Option "Xinerama" "on"` to the ServerLayout section... if you're trying to get one big desktop.

Of course, I've not tried that with two monitors with two resolutions.

Also, I don't see `Option "TwinView"` showing in your Screen section, so maybe nvidia's utility just isn't adjusting your xorg.conf file properly.

KWL