PDA

View Full Version : Can someone tell me exactly how to get Virtualbox 1.5.2 working correctly on Werewolf



episodic
9th November 2007, 06:17 AM
I'm a new user, and I need to know is getting virtualbox 1.5.2 working on Werewolf a possibility right now?

On virtualbox's site, there is an RPM for Moonshine. Will that work in Werewolf? Is it as simple as downloading the rpm and double clicking?



Thanks !

the4thchild
9th November 2007, 07:31 PM
I have the VirtualBox 1.5.2 Moonshine build installed and running on my Werewolf system. I had installed VirtualBox on Fedora 7 (Moonshine) and yum upgraded to Fedora 8 (Werewolf). When I tried to run VirtualBox, it stalled because of a lot of SELinux denials. I followed this thread:

http://forums.virtualbox.org/viewtopic.php?t=337&highlight=install+selinux

to chcon parameters for SELinux (with different file paths), and VirtualBox was up and running.

I'm not sure if this applies to a fresh installation on Fedora 8, but I hope it works for you.

-David

ADW
11th November 2007, 05:34 PM
I haven't been able get VirtualBox 1.5.2 running on Fedora 8 (upgraded from Fedora 7) either.
It asks me to run "/etc/init.d/vboxdrv setup" as root, which gives:
---
Stopping VirtualBox kernel module [ OK ]
Recompiling VirtualBox kernel module [FAILED]
(Look at /var/log/vbox-install.log to find out what went wrong)
---
And in "/var/log/vbox-install.log", it says:
---
Makefile:68: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.. Stop.
---

However, the sources of the F8 kernel don't seem to be available (at least not by doing a "yum update").

ADW
11th November 2007, 06:05 PM
I found the kernel sources here: http://rpm.pbone.net/index.php3/stat/4/idpl/5336392/com/kernel-devel-2.6.23.1-42.fc8.i686.rpm.html
Installed the RPM, ran "/etc/init.d/vboxdrv setup" as root and now VirtualBox 1.5.2 works fine.
Hope this helps.

4z0smq20kk
15th November 2007, 08:36 AM
I found the kernel sources here: http://rpm.pbone.net/index.php3/stat/4/idpl/5336392/com/kernel-devel-2.6.23.1-42.fc8.i686.rpm.html
Installed the RPM, ran "/etc/init.d/vboxdrv setup" as root and now VirtualBox 1.5.2 works fine.
Hope this helps.

ok, newbie question: how do you install the RPM??

I tried: "rpm kernel-devel-2.6.23.1-42.fc8.i686.rpm"
and then ran "/etc/init.d/vboxdrv setup" , but I'm still getting the same error in the log file:

** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.. Stop.

PsychoTrauma
15th November 2007, 08:57 AM
rpm -ivh kernel-devel-2.6.23.1-42.fc8.i686.rpm

Will install the package.

4z0smq20kk
15th November 2007, 09:07 AM
rpm -ivh kernel-devel-2.6.23.1-42.fc8.i686.rpm

Will install the package.

Tried it but still getting the same error

PsychoTrauma
15th November 2007, 09:28 AM
you might need the kernel headers.

su -
yum install kernel-headers

4z0smq20kk
15th November 2007, 09:35 AM
you might need the kernel headers.

su -
yum install kernel-headers

I tried that as well:

[root@localhost Desktop]# su -
[root@localhost ~]# yum install kernel-headers
livna 100% |=========================| 2.1 kB 00:00
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
Setting up Install Process
Parsing package install arguments
Package kernel-headers - 2.6.23.1-49.fc8.i386 is already installed.
Nothing to do

I tried "/etc/init.d/vboxdrv setup", but still no luck, still getting the same error

PsychoTrauma
15th November 2007, 09:51 AM
Haha

could you please do "uname -r" in a terminal for me.

I believe the problem is the kernel-devel package you installed was for 2.6.23.1-42 but you are currently using the 2.6.23.1-49 kernel.

su -
yum install kernel -devel

It pulls in the latest kernel-devel package for me.

4z0smq20kk
15th November 2007, 02:51 PM
Haha

could you please do "uname -r" in a terminal for me.

I believe the problem is the kernel-devel package you installed was for 2.6.23.1-42 but you are currently using the 2.6.23.1-49 kernel.

su -
yum install kernel -devel

It pulls in the latest kernel-devel package for me.

[root@localhost ~]# uname -r
2.6.23.1-49.fc8

After that I tried your suggestion:
su -
yum install kernel -devel

and now it works!!!!!!!!

Thanks for the help. You rock!!!