PDA

View Full Version : /sbin/loader hang on full install



KKJensen
9th November 2007, 04:59 AM
Hi there,

I've tested my machine with F7 (everything fine and compatible) and F8 test 3 LiveCD (again, everything fine)...now I'm getting hung up at the '/sbin/loader' stage of of the install, basically right after I choose "Upgrade or Install" at the first available menu.

I've come across some discussion of running "linux nousb nofb noscpi" but am not sure where these are supposed to be. I've tried adding these to the end of the 'vmlinux etc' command that the upgrade/install menu (after hitting 'Tab" of course).

Am I missing something obvious? I have been using linux for a little while now but have had pretty good luck with the installs so I've never had to do this before.

Once I find something out I'll post or link to the method to help others...

Much thanks in advance to anyone who can point me in the right direction...

Kristofor

KKJensen
9th November 2007, 06:55 AM
Here's what I had to do to get it working. Credit goes to the guys discussing this over at bugzilla.


1. Hit tab to see the command to start the install
2. Add the following two entries to the end (one got me past the /sbin/loader...the second past the scuzzy driver)



floppy.allowed_drive_mask=0 clocksource=acpi_pm


This all goes at the end of the "vmlinux etc etc" line


Good luck! Hope it works for everyone.

chocobanana
9th November 2007, 11:38 AM
Hi!

I had the same problem and the bugzilla solution worked!

Thanks!

spoilt
9th November 2007, 09:55 PM
I had the same problem... thanks for the help.
Sony Vaio VGN FE-41Z

daemonicpenguin
9th November 2007, 10:24 PM
Here's what I had to do to get it working. Credit goes to the guys discussing this over at bugzilla.


1. Hit tab to see the command to start the install
2. Add the following two entries to the end (one got me past the /sbin/loader...the second past the scuzzy driver)



floppy.allowed_drive_mask=0 clocksource=acpi_pm


This all goes at the end of the "vmlinux etc etc" line


Good luck! Hope it works for everyone.


Nice catch! This worked for me too on a PXE install of Fedora 8 i386 on my Thinkpad X40.

I added the kernel arguments KKJensen listed above to the append line of my pxeboot config (/tftpboot/pxelinux.cfg/default).


label linux
kernel vmlinuz
append initrd=initrd.img floppy.allowed_drive_mask=0 clocksource=acpi_pm


That got me past the /sbin/loader hang.

strikeforce
9th November 2007, 11:57 PM
https://bugzilla.redhat.com/show_bug.cgi?id=338061

cleece
13th November 2007, 04:49 AM
I have a HP Pavilion dv1040us and I ran into this problem as well. I was able to install using:

floppy.allowed_drive_mask=0 clocksource=acpi_pm

Hope this helps if anyone else has this same laptop.

rajihammer
18th November 2007, 05:41 PM
Hey boys and girls, It seems the problem resolves itself if you just have the patience to wait about 7-10 minutes. At least that's my experience.

scottro
18th November 2007, 10:04 PM
My experience (accidentally) echoed rajihammer's. I started it, noticed the hang, got a phone call and when I went back to it, it was on its merry install way. However, on the next install, I'll try the suggested solutions. :)

Dangermouse
18th November 2007, 10:16 PM
Hello all i had same problem strangely it only happened with 32 bit f8 and not 64 bit f8,(same machine) anyway i just waited 10 mins and it sorted itself out.

KKJensen
19th November 2007, 12:31 PM
That waiting sounds refreshingly yet boringly simple... :p

I swear I remember walking away and having supper or something like that...but then again who am I kidding...who'd walk away and do something frivolous like eat when their computer isn't working!?!?!

Thanks for the info. I'll keep it in mind for my traditional 30 day later reinstall when I do something really wrong and can't fix things.

scottro
19th November 2007, 01:30 PM
One reason I did it (last night, after what KKJensen calls the traditional 30 day reinstall--I started with test2, so it was time) is because neither the rescue nor boot CD seem to allow you to add kernel options. One hits tab to edit and is given a command line, but it's going to a vmlinuz and init image, and addding things, the way you would with the usual CD or DVD image didn't seem to work. So, I let it run at /sbin/loader and did something else--after a few tries, I figured that even if I were doing something wrong, it would be over soon. :)

(I tried removing the vmlinuz, init line entirely, and doing linux floppy blah blah, and adding the floppy part after the default target. When neither of those seemed to work, I gave up. This was on both the rescue CD and the boot.iso CD.)

If someone can tell me what I'm missing (I tried googling for terms like add option fedora rescue CD) that would be nice. Otherwise, I'd say the options are to either boot from a traditional install CD (I didn't try with a live CD) or be patient while it deals with its issues on /sbin/loader.

I suspect I missed something simple, but it becomes a matter of how much time do I want to spend to avoid a 5-10 minute wait where I can easily do something else in the interim.

RickyBrent
26th January 2008, 11:32 PM
Thank you! That worked for me.

Either there wasn't a timeout or it took longer than a half hour, but the options worked. I have an XPS Gen 2 laptop -- it previously had Suse on it, though.

This is actually my first time trying Fedora. :)

netrace
29th January 2008, 03:24 PM
Thanks a bunch. Adding floppy.allowed_drive_mask=0 clocksource=acpi_pm worked for me on an HP NC6000 machine that was hanging.

forkbomb
29th January 2008, 03:47 PM
Thanks a bunch. Adding floppy.allowed_drive_mask=0 clocksource=acpi_pm worked for me on an HP NC6000 machine that was hanging.

Worked for me, too.

Anybody know if it's still a problem in the latest respins?

Socra735
11th February 2008, 02:02 AM
Thanks for that - worked like you said.

JonR
20th March 2008, 11:29 PM
Also worked for a Tosh Tecra M5

Zylock
12th April 2008, 02:18 AM
I followed the instructions below and it worked perfect on a Sony Vaio PCG-GR370 laptop. To note, I'd tried everything else I could find, including the nousb, nofb, noacpi, nodam, and so forth. Nothing else worked.
Thanks for the help!


Here's what I had to do to get it working. Credit goes to the guys discussing this over at bugzilla.

1. Hit tab to see the command to start the install
2. Add the following two entries to the end (one got me past the /sbin/loader...the second past the scuzzy driver)


floppy.allowed_drive_mask=0 clocksource=acpi_pm

This all goes at the end of the "vmlinux etc etc" line

Good luck! Hope it works for everyone.

abaum
12th April 2008, 05:08 PM
floppy.allowed_drive_mask=0 clocksource=acpi_pm
Works for me on a Acer Travelmate 4021. The other boot options (nofb, nousb ...) didn't work.

planta
12th April 2008, 05:28 PM
In the installation of my vaio if i use the floppy.allowed etc etc its give me a error when i click in skip the cd verification... for fix this use only

clocksource=acpi_pm
if you use the floppy.allowed_drive_mask=0 u get the crash and a BSOD =]
with memory test stuff and etc...

so funny get a bsod in a linux... xD

timtcg
13th April 2008, 09:08 AM
Worked for me too! (Compaq Presario V4000 notebook)