PDA

View Full Version : Fedora 8 fails to boot after install



rudeboyskunk
8th November 2007, 11:37 PM
After installing Fedora 8, it hangs right after going through GRUB when it says Red Hat Nash something something something.

I'm going to try to reinstall and come back to let you know if this happens again.

rudeboyskunk
9th November 2007, 12:18 AM
Ok, re-installing did not solve this problem. It said Red Hat Nash version something.

igknighted
9th November 2007, 01:01 AM
Ok, re-installing did not solve this problem. It said Red Hat Nash version something.

Nothing after that at all? Weird, there should at least be some error message. That red-hat nash thing is normal, its part of the boot process.

leadgolem
9th November 2007, 01:03 AM
Have you tried booting into runlevel 3?

rudeboyskunk
9th November 2007, 01:45 AM
Ok, right before the Red Hat nash version part, it says this:

ACPI Invalid PBLK length [5]

Mean anything?

How would I boot into runlevel 3?

Gentoo Bob
9th November 2007, 02:27 AM
sounds like a hdd block error. try this. Go into your BIOS and make sure your hdd mode is set to ACHI if it is SATA and if its PATA set it to IDE. Some BIOS have it set to automatic.

leadgolem
9th November 2007, 03:05 AM
Try appending the grub boot line with acpi=off.

When you get the grub boot screen press any key to keep it from timing out. Then use the arrow keys to select you kernel line. Press "e" to edit that line. Add acpi=off to the end of the line. Then press "b" to boot. Your completed line should look something like this.
kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ quiet acpi=offEDIT: You can use the above method to append a "3" to your kernel line. Then the system will boot into runlevel 3.

richwest
9th November 2007, 04:22 AM
Hi, I just installed Fedora 8 x64 from the DVD, which went smoothly. However when I try to boot it GRUB loads as expected, but after selecting the Fedora OS the boot process stops. The only output I get is the following: -



Booting 'Fedora (2.6.23.1-42.fc8)'

root (hd0,1)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.23.1-42.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
[Linux-bzImage, setup=0x2c00, size=0x1d3c18]
initrd /initrd-2.6.23.1-42.fc8.img
[Linux-initrd @ 0x37c26000, 0x3c9eba bytes]


After that point the loading process just stops, and I'm left with that text and a flashing cursor below it forever.

I'd appreciate any help in trying to diagnose the problem. I did install to a software RAID volume using my motherboard's Intel ICH9R chipset, but this was detected automatically by the installer and since GRUB has installed fine and has no trouble booting to my secondary OS, I'm not sure that this is the issue.

Some basic system specs in case that's any help:
Abit IP35 pro motherboard
Intel Q6600 quad core processor
4GB DDR2 RAM
Nvidia Geforce 8800 GTS graphics card
2x500GB SATA hard disk using motherboard raid 0
SATA DVD/RW drive

Thanks for any help.

rudeboyskunk
9th November 2007, 05:23 AM
sounds like a hdd block error. try this. Go into your BIOS and make sure your hdd mode is set to ACHI if it is SATA and if its PATA set it to IDE. Some BIOS have it set to automatic.

My BIOS doesn't have any settings like this that I can find (I looked through the whole thing). It's an HP Pavilion 751n.

Also, I tried setting it acpi=off and adding a 3 (separately and together), and it didn't work. The installation media has to be fine because the OS installed without a problem (right?).

leadgolem
9th November 2007, 05:36 AM
The installation media has to be fine because the OS installed without a problem (right?).
Not necessarily, did you run the disk check?

rudeboyskunk
9th November 2007, 05:43 AM
No, I'll go ahead and do that now though.

brr872002
9th November 2007, 06:51 AM
Try 32 bit version

richwest
9th November 2007, 05:15 PM
Is there some particular reason that might help? I would prefer to run the 64 bit version, and am most certainly using a 64 bit system.

richwest
9th November 2007, 07:28 PM
Just FYI, I tried it with APM, ACPI etc. set to off in the kernel parameters, no difference, same issue. Not making much headway with this to be honest.

rudeboyskunk
9th November 2007, 10:08 PM
Ok, the media check says the cd is fine. I don't know what to do!

rudeboyskunk
9th November 2007, 10:33 PM
Is there maybe a bootlog file that I can access? I can mount that partition from Ubuntu no problem. I just don't know where any bootlog file would be.

Figment
9th November 2007, 10:41 PM
I've got the same problem. I did try changing a setting in the BIOS that makes SATA drives (which I use) appear as IDE drives. I thought that might be messing things up, but there's no change. Reinstalling with all default settings, just to see.

hclau
9th November 2007, 10:49 PM
I have the exact same problem here. I removed "quiet" from the kernel line in Grub and was able to see a lot more boot up messages. It hung after the message "Creating root device." I checked the installation CD and it was fine. I tried acpi=off and it didn't make any difference (I actually didn't see any ACPI errors with or without this switch). I also looked at /var/log while booted from another partition and there was no syslog or any new logs there except the installation log anaconda.log. I think I'm going to try to install it in a primary partition instead of the logical partition where it is installed right now. Or maybe try the DVD installer (I'm currently using the live CD, Gnome version), or even a previous RC CD.

Figment
9th November 2007, 11:04 PM
Yes, I thought about making it a primary partition, but that'll involve a fair amount of rearranging so I'm going to hold off. If you try it, let us know if it helps. This is the DVD installer, so I don't think that's the problem. Actually, it's /images/boot.iso from the DVD installer, loading the DVD image off the hard drive, but that should be the same, right?

rudeboyskunk
9th November 2007, 11:41 PM
Ok, I installed it as a logical and a primary because I thought maybe that was the problem. The same thing happened in both.

Right after it says "Red Hat nash version 6.0.19 loading" (or whatever), I see my usb mouse flash, meaning the system has read it. However, I do not hear the hard drive doing anything.

jjthomas
10th November 2007, 12:15 AM
It acts like it is not able to load the root partition.

I've edited fstb to point to the drive directly and did the same with the grub menu.lst file.

I also installed FC8 on just my SCSI drive.

My system consists of a SCSI drive, IDE (ATA-66) drive and a CD-ROM. I also have a Promise controller with two drives attached to it (ATA-100) .

The /var/log/messages is empty.

I was able to install ubuntu on this machine, but I had to do hack the gurb file and get everything pointed to the root drive. I had slackware running without any problems, as well. (I need some programs from GNOME) With FC8 everything looks okay, it just does not seem to be able to load the root partition.

Removing rhgb and quiet from the gurb kernel line and watching the messages go by, I don't see any error messages.

-JJ

drobbins
10th November 2007, 01:17 AM
I have an Abit IP35 and couldn't get through the installation
it wouldn't recognize my WD Raptor drive
I got around it by booting the live CD and then installing it to disc
a hack, but it worked
let us know what you find out, I'd rather just have a clean install off the DVD

Dave

Figment
10th November 2007, 01:24 AM
If you remove "rhgb quiet" from the kernel line, does it give you any additional information?
(I'm having a similar problem, though the boot process goes about two lines of text longer on mine before stopping)

rudeboyskunk
10th November 2007, 01:29 AM
Ok! I deleted "quiet" from the kernel line in GRUB, and I see now where it gets stuck. It says something along the lines of "attempting to resume from sda3." NOW, sda3 is my swap partition. I made it swap when I installed Ubuntu. Would I have had to remake it as swap under Fedora?

richwest
10th November 2007, 01:37 AM
If you remove "rhgb quiet" from the kernel line, does it give you any additional information?
(I'm having a similar problem, though the boot process goes about two lines of text longer on mine before stopping)

Afraid it doesn't for me, I removed those parameters and still got exactly the same output. Could be a different problem, who knows.

Dan
10th November 2007, 02:03 AM
As these two threads appear to be the same issue,

threads merged.

richwest
10th November 2007, 02:10 AM
As these two threads appear to be the same issue,

threads merged.

I'm not at all sure that they are the same issue to be honest, since in the other thread problems seem to occur further through the boot process, whereas I don't even get any error message...

Dan
10th November 2007, 02:20 AM
Just a hunch. And all the better opportunity to help each other out!


In other words ...

Now I've got 'em mixed up ...

I don't know if I could get 'em pulled apart right again. <..:p..>


Dan

richwest
10th November 2007, 02:22 AM
Haha fair enough ;)

I guess there's a good chance it could be something similar.

Figment
10th November 2007, 02:32 AM
Ok! I deleted "quiet" from the kernel line in GRUB, and I see now where it gets stuck. It says something along the lines of "attempting to resume from sda3." NOW, sda3 is my swap partition. I made it swap when I installed Ubuntu. Would I have had to remake it as swap under Fedora?

I wouldn't expect it to be necessary, but that doesn't mean it isn't. You don't have to reinstall to remake it, though. If you boot from the recovery CD, mkswap /dev/sda3, and make sure that the swap partition in /etc/fstab is listed as /dev/sda3, it should take care of anything left over from Ubuntu that Fedora isn't expecting.

jjthomas
10th November 2007, 05:04 AM
I completely removed the swap partition from my fstb file and the boot process went to the next step and hangs at the message "Creating root device." Booting FC8 on another machine the next step is to load the root partition, so I am thinking it is hanging when it tries to load the root partition.

I think I am having the same problems as the person that started this thread, I just removed the rhgb and quiet lines from the grub file so I could see the message as the computer boots. I am not seeing any errors, though. It just hangs at the "Creating root device." line.

-JJ

brr872002
10th November 2007, 07:43 AM
Just visit this page it may help you
http://fedoraproject.org/wiki/Bugs/F8Common

jjthomas
10th November 2007, 09:28 AM
https://fedoraproject.org/wiki/KernelCommonProblems#head-1879cb20fd3b729e938a6e8ac9da1c9cac8addd6

I'll check it out when I get home.

Thanks.

-JJ

Horas
10th November 2007, 01:04 PM
I have the same problems - both with i386 and x86_64

It always hangs on the redhat nash thingy, removing the quiet options shows that fedora hangs after mounting the root device.

On x86_64 there are some other error lines:
init[1] trap divide error rip:<some numbers> rsp:<more numbers> error:0

I tried an installation without swap partition, didn't help at all.

Fedora 7 and ubuntu work fine.

Figment
10th November 2007, 06:08 PM
Afraid it doesn't for me, I removed those parameters and still got exactly the same output. Could be a different problem, who knows.

From that last link:

If you get no output at all from the kernel, sometimes booting with earlyprintk=vga can sometimes yield something of interest.

richwest
10th November 2007, 10:03 PM
I tried adding earlyprintk=vga to the kernel line, and still got the same output. I'm not having any luck in working out what's causing it to stop booting sadly, it seems to continue hanging after the initrd line with no sign of an error message. Don't think this is going to be an easy one to solve.

richwest
10th November 2007, 10:36 PM
Also tried an install from the KDE x64 live DVD instead and had exactly the same problem. My guess is that it must be some kind of SATA/RAID issue since I can't see what else is different about running the installed version vs the live DVD/installer which seem to execute fine.

gnazio
11th November 2007, 02:18 AM
I have the "init[1] trap divide error" problem too.
I have 4 sata + 4 pata controller and f8 (amd64) installed on a pata disk.
Tried in vain disabling sata controllers, making a new initrd, running yum (which updated the kernel) from a rescue cd (which boot and mount the hd partitions perfectly!), changing label with device on /etc/fstab

The last lines before the messare are
Loading ata_generic.ko module
Loading sata_via.ko module
Waiting from driver initialization
Trying to resume from /dev/sda5 <-my swap
And then init[1] trap divide error rip:2aaaab56384a rsp:7fff1875ef1 error:0 repeated ad nauseam.

A bug has been filed, so please make your voice heard.
https://bugzilla.redhat.com/show_bug.cgi?id=374521

EDIT:
btw, f7 x86_64 was working on the same pc

EDIT #2:
Look, I have 0 posts!

jsc1959
11th November 2007, 03:49 AM
Im having the same exact problem... really like the look of fc8 too... hope this gets solved soon.

richwest
11th November 2007, 04:33 AM
I tried installing the 32-bit version from the KDE livecd, and interestingly that worked for me without problems. I'm not sure that the problem I'm having is the same as the others in this thread, but it's clearly specific to the 64 bit version. My best guess at the moment is that the initrd file is for some reason misconstructed after the 64 bit install. I'd submit a bug report, but since I don't appear to get any actual error message, it's a bit tricky to track down the root cause of the issue.

gnazio
11th November 2007, 04:56 AM
I'd submit a bug report, but since I don't appear to get any actual error message, it's a bit tricky to track down the root cause of the issue.Did you try removing quiet from the line which starts with kernel on /boot/grub/grub.conf?

richwest
11th November 2007, 04:59 AM
Yes, I tried that.

jjthomas
11th November 2007, 05:38 AM
I have the "init[1] trap divide error" problem too.
I have 4 sata + 4 pata controller and f8 (amd64) installed on a pata disk.

And then init[1] trap divide error rip:2aaaab56384a rsp:7fff1875ef1 error:0 repeated ad nauseam.

How long before the trap divide error starts showing up. I've left my computer sit for about 15 mins and have never seen that error. Actually it never gives me an error, it just sits there.

I have a Adaptec 2940 SCSI controller
Built in Motherboard PATA controllers (Asus CUSL2)
and a Promise ATA-100 controller with two drives in non-RAID configuration.

I did an install only on my SCSI drive and I still have the same problem. I'll pull the Promise controller out in the next day or so and see if that works.

-JJ

gnazio
11th November 2007, 03:34 PM
How long before the trap divide error starts showing up. I've left my computer sit for about 15 mins and have never seen that error. Actually it never gives me an error, it just sits there.No need to wait, it's fired after few seconds.
Just make sure you have removed quiet from the line which stats with kernel either from /boot/grub/grub.conf or from the grub screen. If you are sure you did that and you don't see the same message, maybe you are hitting a different problem.

rudeboyskunk
11th November 2007, 04:55 PM
Ok, what I did was completely deleted my swap and reinstalled Fedora. Now it hangs at detecting my USB devices. *grr*

vnpenguin
11th November 2007, 07:42 PM
Ok! I deleted "quiet" from the kernel line in GRUB, and I see now where it gets stuck. It says something along the lines of "attempting to resume from sda3." NOW, sda3 is my swap partition. I made it swap when I installed Ubuntu. Would I have had to remake it as swap under Fedora?

I have exactly same error with my swap partition /dev/sdb2 :(

Any solution ?

Horas
11th November 2007, 08:34 PM
Ok, i managed to make a working default install of Fedora 8 i386 (without modifying the packages selection) on an IDE-drive (previously I installed on a SATA device).

So there are two options:
Either it has something to do with the SATA-Device i.e. the SATA-controller or it has something to do with package selection.

vnpenguin
11th November 2007, 09:24 PM
Already tried "acpi=off libata.dma=0 libata.ignore_hpa=1 noapic" but it does not work :(
The error is always:

...
Waiting for driver initialization
Trying to resume from /dev/sdb2

Any help ?

partha06
11th November 2007, 10:07 PM
After installing Fedora 8, it hangs right after going through GRUB when it says Red Hat Nash something something something.

I'm going to try to reinstall and come back to let you know if this happens again.

Same problem with my acer aspire 4520.notebook.
It shows, can not mount /dev/sda3 - My linux root partition.
then, no /dev found. & /proc & /sys also. I install three times, same issue.

But one thing i noticed, I insert OpenSuse10.3 DVD. & there is an option " Boot From Hard Disk". Then I boot, & it boots fine..

& I install FC8 in my Sun Ultra 20 , Its works fine too here..

Pls. help.

Thanks

Partha

rudeboyskunk
12th November 2007, 12:00 AM
Ok, I had the same problem that partha is having when I tinkered around with my etc/fstab and renamed the swap or took it out or just completely removed my swap partition and installed fedora.

I haven't tried trying to boot from hard disk using my opensuse dvd, though. i'll try that.

also, choosing the partition option of "use empty space and use fedora default layout" yields the same problem i've been having.

jjthomas
12th November 2007, 05:37 AM
I don't have an SATA drive in my system.

I threw slackware 12 on the system and it booted just fine.

-JJ

partha06
12th November 2007, 10:35 AM
One thing, I notice also, sata_nv module, is not loading properly. But, I changed HDD type achi , but same issue. I think, HDD is going lock. But, what I said, Booting from Hard Disk Option of Suse DVD, works fine, I mean, it boots in IDE mode too..


So, I booted my system that way, But after booting, How can I fix that error?

Any help ?

Thanks

Partha

ladeng
12th November 2007, 10:48 AM
Already tried "acpi=off libata.dma=0 libata.ignore_hpa=1 noapic" but it does not work :(
The error is always:

...
Waiting for driver initialization
Trying to resume from /dev/sdb2 Trying to resume from /dev/sdb2


Any help ?
yes ,I've the same problem like you
always hang at the postion as you

when I chroot from rescue disk ,I use a new kernel compiled by me used ok in fc7,and I choose the hdx(hda ,hdb,hdc,bla bla) traditional drive,it said can't create root

can't setup
can't ......

and still hang

I replace the nash in f8 from f7, but still hang

i think it's not the kernel bug(I used the ok kernel in fc7 ,but failed with the same error in f8) ,but the mkinitrd bug and the nash bug(maybe udev?)

PS:I also used the kernel command like follows,but still failed and hang like above

title Fedora (2.6.23.1-42.fc8)
root (hd1,11)
kernel /boot/vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ nolapic libata.ignore_hpa=1 clocksource=acpi_pm nohz=off highres=off usbcore.autosuspend=-1 pci=nomsi,nommconf floppy.allowed_drive_mask=0 vga=791 initcall_debug earlyprintk=vga
initrd /boot/initrd-2.6.23.1-42.fc8.img

I test the fedora 8 common problem web page's method and none of them can solved this bug

ladeng
12th November 2007, 10:51 AM
I think it's not the kernel's bug

but some user space application's bug

because I replace a worked ok kernel from f7


it's still hang

vnpenguin
12th November 2007, 03:19 PM
I tried with updated kernel of Fedora 8 (by doing chroot & rpm -ivh from my Fedora 7 on the same box) but the same error :(

Any help ?

:( :( :(

jsc1959
12th November 2007, 03:46 PM
well i downloaded the install dvd, proceeded to reinstall via anaconda, and rebooted and it is now working. Not sure what i did different though. Just to let you all know that it did work. sorry I cant be more help. I originally installed from live cd.

Figment
12th November 2007, 05:39 PM
I tried copying the kernel, initrd, and modules over from F7, it got past "creating root device" finally, but fails with this error:

/etc/rc.d/rc.sysinit: line 680: 1364 Floating point exceptionfsck -T -t noopts=_netdev -A $fsckoptions

When I get a chance I'll see if manipulating rc.sysinit to skip filesystem checking helps, though if fsck is failing I'm guessing a lot of other things are going to as well.

partha06
12th November 2007, 10:51 PM
One thing, I notice also, sata_nv module, is not loading properly. But, I changed HDD type achi , but same issue. I think, HDD is going lock. But, what I said, Booting from Hard Disk Option of Suse DVD, works fine, I mean, it boots in IDE mode too..


So, I booted my system that way, But after booting, How can I fix that error?

Any help ?

Thanks

Partha


Got Solution..

1. Boot From any Linux Dvd , I used, Open Suse, ubuntu , & choose, " Boot From Hard Disk "
2. Then It will boot..
3. Compile the kernel

It was problem of sata support, hard disk was not found, then enable sata support, that's all..

Thanks

Partha

Horas
13th November 2007, 01:55 AM
I'm pretty sure that it is a SATA / SATA-Controller problem.

For me, installing Fedora 8 x86_64 on an pATA device worked just fine.

Nevertheless I wonder where the bug has its origin; this is hardly a good workaround.

gnazio
13th November 2007, 02:12 AM
Anyway it seems that the kernel is finding such devices.
I'm *not sure* not but maybe something about a sata controller was printed before the error.
Does the kernel bypass bios and ignore its settings?

Now I've installed 7.90 which works, tomorrow I will try with 7.92. It seems that 7.91 has been removed from the mirros (at least the ones I've visited). Could anyone provide a valid link?

EDIT:

@partha06
are you sure you were getting the *same* error (init[1] trap divide error) ?
or a different kind of lock while booting?

blc
13th November 2007, 02:19 AM
I had a similar problem with Fedara 8 x86_64 not booting after install from both LiveDVDs and the full DVD. I would get an error something like

Error 17: Unrecognized parition type 0xF

And it wouId stop before even starting Red Hat Nash. I finally tinkered with the hdd parameters in my grub.conf and that made it work. The hard disk I have it installed to is (I belive SDC in the partition setup). The grub.conf wanted to boot fedora from hdd(0,0). I thought that was strange so I played with with hard drive parameter and got it to boot from hdd(1,0). The strange thing is (and I know little about the workings of grub) that there is a file called device.map in /boot/grub that seems like it should map SDC to hd0. I have no idea why I need to tell grub to boot form hd1.

Anyway, after about 6 installs I am now happily running F8. Trying out GNOME for a little bit...

Tylerious
14th November 2007, 12:01 AM
https://fedoraproject.org/wiki/KernelCommonProblems#head-1879cb20fd3b729e938a6e8ac9da1c9cac8addd6

From the site:

Can't find root filesystem

* A lot of these bugs end up being a broken initrd due to bugs in mkinitrd. Get the user to attach their initrd for their kernel to the bz, and also their /etc/modprobe.conf, or have them examine the contents themselves if they are capable of that.
* Picking apart the initrd of a working and failing kernel and doing a diff of the init script can reveal clues.

My boot hangs on "Creating root device." with the "noresume" kernel option. Otherwise it hangs on "Trying to resume from LABEL=SWAP-sda4" even when my swap line is deleted/commented out from /etc/fstab!

partha06
14th November 2007, 12:21 AM
Anyway it seems that the kernel is finding such devices.
I'm *not sure* not but maybe something about a sata controller was printed before the error.
Does the kernel bypass bios and ignore its settings?

Now I've installed 7.90 which works, tomorrow I will try with 7.92. It seems that 7.91 has been removed from the mirros (at least the ones I've visited). Could anyone provide a valid link?

EDIT:

@partha06
are you sure you were getting the *same* error (init[1] trap divide error) ?
or a different kind of lock while booting?

i am getting,

no /dev/root , /proc, /sys found..

i compile kernel & and issue solve, check my last post about it...

thanks

Partha

ladeng
14th November 2007, 01:06 PM
I think it's no use to talk about questions in this forum

because it's a bug
not a setting question
Do the developers check this forum for this bug?

i think the bug is the new scaned the disk and set it on the desktop's application can't support the bsd partion or maybe other partion,then it'll timeout and all step later all timeout,then hang forever

maybe it's the behaver fedora's learning the unbuntu (auto lay out the disk on the desktop )

vnpenguin
14th November 2007, 01:16 PM
By removing my 2nd disc which has FreeBSD + swap partitions, I can boot F8 now.
The thing is very very strangle is my F8 installation does not use any partition on this disc :((

partha06
14th November 2007, 01:19 PM
But, I am sure, its a issue of hard disk support.. coz, in my Sun workstation, I dual boot, with F8 & Solaris 10, its work fine.. but only problem in my notebook..

Thanks

Partha

ladeng
14th November 2007, 01:50 PM
By removing my 2nd disc which has FreeBSD + swap partitions, I can boot F8 now.
The thing is very very strangle is my F8 installation does not use any partition on this disc :((
it scaned all disk then list on the desktop ,though you don't use the freebsd disk with you fedora 8

so ,it hangs always

hclau
14th November 2007, 02:47 PM
I've tried almost everything that people have tried in this thread, inculding installing from DVD and live CD, booting with various kernel flags, updating to the latest kernel (2.6.23.1-49.fc8), installing test release 7.92, all with the same result, i.e. hanging after the message "Creating root device." Finally when I installed test release 7.90, like gnazio did, it booted with no problem!

Then I upgraded to the latest packages for Fedora 8 using the upgrade procedure at http://fedoraproject.org/wiki/YumUpgradeFaq . When I booted the new kernel (2.6.23.1-49.fc8), it hung at the same place as before.

Now I booted the 7.90 kernel and everything seems to be working fine. So, something happened to either the kernel or mkinitrd or whatever after 7.90 (release test 1, I believe) that caused the booting process to hang.

In summary, what worked for me was install test release 7.90, upgrade to release 8 as described in the above link, boot the test release kernel (2.6.23-0.61.rc1.git9.fc8).

Now that I have a working system, I can try to compile a new kernel and see how it goes.

hclau
14th November 2007, 03:06 PM
People who have this problem may try to simply install the test 1 kernel kernel-2.6.23-0.61.rc1.git9.fc8.i686.rpm from here http://mirror.anl.gov/pub/fedora/linux/releases/test/7.90/Fedora/i386/os/Fedora/ (or another mirror) and see if it works.

genelake
14th November 2007, 04:02 PM
vnpenguin...your post was the solution to my booting problems.

I have been following this thread closely because I couldn't get Fedora 8 to boot at all. I had all the same problems mentioned in the previous posts. I had PC-BSD installed on partition 2 of my hard drive. I used cfdisk to delete the BSD partition, made a new partition in the same space and established the type as Linux. I then created a file system on that partition with mkreiserfs. Fedora 8 then booted just fine.

I remember that in the past I have had trouble with the Anaconda installer complaining about BSD partitions. And of course, Anaconda won't accept any partitions over 15. Seems like these 'features' need to be worked on.

A couple of off-topic notes...
D/L'ed the flash RPM from the Adobe website...YUM installed it perfectly.
Had flash but no sound in YouTube video's. D/L'ed 'libflashsupport' and installed with YUM...now have sound on YouTube.
Configured my printer with CUPS...works perfectly.
Ran the 'Soundcard Detector' wizard...detected my soundcard correctly...turned up the volume...sound works perfectly.

Vnpenguin...thanks for the solution!

-Gene-

SDD
14th November 2007, 04:08 PM
By removing my 2nd disc which has FreeBSD + swap partitions, I can boot F8 now.
The thing is very very strangle is my F8 installation does not use any partition on this disc :((
I've got this problem (boot stopping at red hat nash) and I am about to see if your solution works, however although my FreeBSD partition is currently dormant, when FreeBSD 7 arrives I will install it and I will still want fedora to boot properly. has anyone got any Ideas how to solve this?

SDD
14th November 2007, 05:29 PM
The solution worked but I still want to run FreeBSD 7 when it arrives. I have updated the kernel since managing to boot. Does the new kernel (2.6.23.1-49) have a fix in it?

rexbinary
14th November 2007, 07:22 PM
No, the *-49 kernel doesn't help.

There is a bug filled for it here

https://bugzilla.redhat.com/show_bug.cgi?id=375591

Please feel free to add to it's comments.

Tylerious
14th November 2007, 08:17 PM
Following hclau's advice, I'm trying to install the test kernel (2.6.23-0.61.rc1.git9.fc8) after booting with the F8 DVD. If I just try to install the test kernel, it complains that the current kernel is the newest version. When I uninstall the current kernel, then try to install the test kernel, I get the error message "grubby fatal error: unable to find suitable template."

So what's to proper procedure to install the test kernel if I already have F8 installed?

aslan963
14th November 2007, 08:35 PM
To install the kernel I used rpm -ivh --force <kernel>. However when I did that, it did not make a difference. Also I am getting the same 'grubby' error whenever I attempt to install a new (or older) kernel. Could this be part of the larger problem with the nash running the initrd init script?

ladeng
14th November 2007, 08:36 PM
I think it's nothing to do with the kernel

it's an application's bug

Tylerious
14th November 2007, 08:40 PM
Looks like the grubby error is a problem updating GRUB's menu.lst. It removed the old Fedora 8 entry, but didn't add a new one. Once I added an entry for the new kernel menually and booted, I still got the same errors as with the default kernel.

Ladeng, if it's an application bug, which application are you thinking of?

Figment
14th November 2007, 10:55 PM
I deleted my FreeBSD partition... boots like magic. Deleting it is not such a big deal because I was just playing around with FreeBSD, but this would be a tough decision if I cared about keeping it around. If anyone finds a solution that works with a BSD partition on the machine, it would be nice to hear about it.

aslan963
14th November 2007, 11:03 PM
I deleted my FreeBSD partition... boots like magic. Deleting it is not such a big deal because I was just playing around with FreeBSD, but this would be a tough decision if I cared about keeping it around. If anyone finds a solution that works with a BSD partition on the machine, it would be nice to hear about it.
I wonder if this is a related problem. I guess it could be if it is related to mkinitrd not recognizing partitions other than plan vanilla ext2/3. I do have RAID and LVM partitions on my systems but none belonging to other other operating systems. Has anyone tried downgrading the mkinitrd package and reinstalling their kernel?

gnazio
14th November 2007, 11:43 PM
Now I booted the 7.90 kernel and everything seems to be working fine. So, something happened to either the kernel or mkinitrd or whatever after 7.90 (release test 1, I believe) that caused the booting process to hang.I can add that in my not booting 7.92 i removed mkinitrd and nash and installed the ones that come with 7.90. Then I've created a new initrd but got the same exact problem.
So I'd vote for something in the kernel :)
Could someone check the default kernel configurations for X86_64 on 7.90 vs. 7.92 or 7.90 vs 8?

gnazio
14th November 2007, 11:58 PM
I deleted my FreeBSD partition... boots like magic.
Unfortunately FreeBSD is my primary OS: I have a 6-STABLE and a 7-STABLE on the same box on which I've tried to upgrade f7 to f8.

Well, after my experiences with the last two Fedora releases, I should better say THANK GOD!!!.

gnazio
15th November 2007, 12:07 AM
No, the *-49 kernel doesn't help.As I've said in #38 :)


There is a bug filled for it here

https://bugzilla.redhat.com/show_bug.cgi?id=375591

Please feel free to add to it's comments.Thanks!!!
This make sense!

aslan963
15th November 2007, 01:18 AM
/sbin/new-kernel-pkg: line 90: 2621 Floating point exception$grubby --add-kernel=$bootPrefix/$kernelName-$version $INITRD --copy-default $makedefault --title "$title" ${mbkernel:+--add-multiboot="$mbkernel"} ${mbargs:+--mbargs="$mbargs"} --args="root=$rootdevice $kernargs" --remove-kernel="TITLE=$title"

that is the output from trying to install a kernel. Can this be related to the issue of the init script within the initrd issuing the init[1] trap error?

gnazio
15th November 2007, 03:52 AM
/sbin/new-kernel-pkg: line 90: 2621 Floating point exception$grubby --add-kernel=$bootPrefix/$kernelName-$version $INITRD --copy-default $makedefault --title "$title" ${mbkernel:+--add-multiboot="$mbkernel"} ${mbargs:+--mbargs="$mbargs"} --args="root=$rootdevice $kernargs" --remove-kernel="TITLE=$title"

that is the output from trying to install a kernel. Can this be related to the issue of the init script within the initrd issuing the init[1] trap error?
I had the same error upgrading the original kernel shipped with F8 to the one yum upgraded to.
And I told few post before that downgrading nash and mkinitrd to the version in 7.90 was vain.

Do you have FreeBSD, or other BSD based OS, too on the same pc, even if on other HD?

jjthomas
15th November 2007, 05:17 AM
I'm not getting any errors. The system simply stops at creating root partition. FC8 was installed on the machine with bare drives and no other OS.

-JJ

EDIT: I've looked at the bug reports, they do not apply as I am not getting any errors.

erniehatt
15th November 2007, 05:55 AM
I downloaded Fedora8 iso, the checksome checked out ok , burned to CD, then tried the live boot, everything seemed to go ok, until it got to the end, then all I got was a rolling screen, any ideas on the cause. Ernie

hclau
15th November 2007, 08:15 AM
I deleted my FreeBSD partition... boots like magic.

I also have a FreeBSD partition. Maybe that's why I can't boot the new F8 kernel, but I don't want to delete the partition to find out. I tried to "fool" F8 by changing the FreeBSD partition system id to NTFS, without formatting the partition, but booting the new F8 kernel still hung at the same place. I also ran mkinitid to create a new image while the partition system id was changed to NTFS, but booting it still hung at the same place.

ladeng
15th November 2007, 08:59 AM
Looks like the grubby error is a problem updating GRUB's menu.lst. It removed the old Fedora 8 entry, but didn't add a new one. Once I added an entry for the new kernel menually and booted, I still got the same errors as with the default kernel.

Ladeng, if it's an application bug, which application are you thinking of?
I don't know which application

it always hang at create /dev/root,mount root, mount /sys,can't setup blabla

or errors in some script in the initrd's init

I think it somthing with the nash or something working depended on the nash

if you knonw which applications were called in these steps replace them with the same in the fedora 7 maybe work ok

aslan963
15th November 2007, 04:13 PM
I had the same error upgrading the original kernel shipped with F8 to the one yum upgraded to.
And I told few post before that downgrading nash and mkinitrd to the version in 7.90 was vain.

Do you have FreeBSD, or other BSD based OS, too on the same pc, even if on other HD?

I do not have another OS on this machine. You are correct about downgrading nash and mkinitrd to (pre 8 - post 7), no dice. Last night I reinstalled 7 and started the upgrade process yum upgrade (http://fedoraproject.org/wiki/YumUpgradeFaq#head-56b13936246769f517ac488a0098d193c7fc3600) . I will update how that goes.

jjthomas
16th November 2007, 08:33 AM
I wiped the drives clean and created partitions by hand and still get the same error.

-JJ

little.owl
16th November 2007, 01:10 PM
I have the same problem. I tried to install Fedora 8 on my notebook (Acer Extensa 5210WLMi), clean install and it failed reboot, because it was unable to mount the root partition. Really sad.

erniehatt
16th November 2007, 11:09 PM
Oh well, have decided that it is not worth the effort, I will stick with PCLinuxOS, it does work very well. Seems Fedora hasn´t changed much since version 5, had lots of problems with that.

jjthomas
17th November 2007, 12:12 AM
Here's another towel for the pile. I gave Ubuntu gutsy a try but it started eating away memory and so back to good old FreeBSD 6.2. I cut my baby Linux teeth on Red Hat. But if I can't get it to run, time to move on. :(

-JJ

rudeboyskunk
17th November 2007, 01:31 AM
I too removed my PCBSD 1.4 partition and Fedora booted up like a charm. Damn.

ladeng
17th November 2007, 01:50 PM
how can we know this bug have been fixed?

or it'll not be fixed directly until within the fedora 9 release?

sigh

it seems like it belongs to a low priority ,maybe it will delay for a long time

but without the fix ,we can not boot even

Pierre Juhen
17th November 2007, 05:10 PM
I get the same problem.

What I did is reinstalled f7 on a new partition, aside, with the same boot partition.

I then tried to boot using the vmlinuz and initrd of f7, with root kernel parameter pointing
to the F8 partition.

It worked much further, but ...

I have 2 LVM devices : one raid1 and one raid0.

The raid1 was detected by the initrd part.

The raid0 volume wasn't detected.

I did a manual vgscan ... nothing.

This leads to a lvm2 problem....

For further investigation....

Pierre Juhen
17th November 2007, 05:33 PM
This is probably a RAID problem.

mdadm --detail --scan --verbose

doesn't find my raid0 partition (the one that is not installed by initrd).

That seem to explain why it the initrd is not able to mount /dev/root.

Does the problem only occur when you have a root filesystem on a raid partition ?


PS: the problem with xxxBSD is probably different.

ladeng
17th November 2007, 08:07 PM
I return back to fedora 7

and 'll directly jump to fedora 9


have no wish to wait to fix this low priority bug

rexbinary
18th November 2007, 01:10 AM
have no wish to wait to fix this low priority bug

Well, I filed the bug as low priority as I didn't really know how the developers would view the severity of it. It's a high priority to me as I would like to install the newly released PC-BSD 1.4.1 and continue to be able to boot Fedora 8. I guess anyone could bump up the priority on the bug I suppose and see what happens.

EDIT: I changed the Severity to High. It would not allow me to change the Priority.

gnazio
18th November 2007, 02:58 AM
One thing I've noted is that 7.90 has util-linux-2.13-0.52.fc7.x86_64.rpm, while 7.92 (unbootable as 8) has util-linux-ng-2.13-1.fc8.x86_64.rpm
I've checked this rpm as it seems that it hangs while doing something related to mount.
They seems to have almost the same files, does anyone know if that ng means really something or if it is only a change in the name?

Looking at the content (from FreeBSD)
$ file 7.90/bin/mount
7.90/bin/mount: setuid ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), stripped

$ file 7.92/bin/mount
7.92/bin/mount: setuid ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), stripped

ladeng
19th November 2007, 02:51 PM
ng

maybe is the fastboot initng 's bug?

I found some application's name in the initng with "***ng"

Pierre Juhen
19th November 2007, 07:50 PM
For me, the problem lies before init-ng.

It's probably mdadm in the initrd that does not detect the raid disk of root.

I noticed that the mdadm version also changed between 7.90 ant f8 release.

gnazio
19th November 2007, 09:06 PM
It's probably mdadm in the initrd that does not detect the raid disk of root.
My root is not on a raid disk.
I have no raid disk at all.
Do you think it worths the time trying to create a new initrd without it or to rollback the mdadm to a previous version?

Pierre Juhen
19th November 2007, 09:23 PM
My root is not on a raid disk.
I have no raid disk at all.
Do you think it worths the time trying to create a new initrd without it or to rollback the mdadm to a previous version?

I think it's worth it.

I spent my time to reinstall f7, by I still have an unbootable f8 partition.

What I would do :

get mdam from 7.90
boot using rescue disk and install mdam from 7.90.
do a mkinitrd
reboot

Pierre Juhen
19th November 2007, 11:45 PM
Maybe it was not such a good idea, it didn't work :(

Situation

Grub present the right boot disk to the initrd init script.

During the init script, in the switchroot phase, mount doesn't find any disk anymore.

The pivotroot fails.

Why ?????

I have /boot on ext3 primary partition,and / as an lvm2 volume, on a raid1 array.

Any idea welcome....

Pierre Juhen
20th November 2007, 08:57 AM
I investigated further.

mount seems to be guilty, as ladeng suspected.

I was able to boot up to level 1, with a failure, but I had a shell.

mount indicated that /usr was mounted.

ls /usr -> empty

mount -a (complains about /dev/pts)

ls /usr -> now OK.

So it's probaly util-linux-ng

gnazio
20th November 2007, 10:43 AM
I investigated further.
mount seems to be guilty, as ladeng suspected.
It's was me :cool: :D

So it's probaly util-linux-ng
On post #100
http://forums.fedoraforum.org/forum/showpost.php?p=903812&postcount=100

https://bugzilla.redhat.com/show_bug.cgi?id=375591#c25

gnazio
20th November 2007, 10:54 AM
If it's really util-linux-ng the guilty, I wonder what thay have smoked before changing such an important component only on the last release candidate!

ladeng
20th November 2007, 11:19 AM
quote from fedora 8 release notes:

5.3.1. SCSI driver partition limits
Whereas older IDE drivers supported up to 63 partitions per device, SCSI devices are limited to 15 partitions per device. Anaconda uses the new libata driver in the same fashion as the rest of Fedora, so it is unable to detect more than 15 partitions on an IDE disk during the installation or upgrade process.

If you are upgrading a system with more than 15 partitions, you may need to migrate the disk to Logical Volume Management (LVM). This restriction may cause conflicts with other installed systems if they do not support LVM. Most modern Linux distributions support LVM, and drivers are available for other operating systems as well.

5.3.2. Disk partitions must be labeled
A change in the way that the linux kernel handles storage devices means that device names like /dev/hdX or /dev/sdX may differ from the values used in earlier releases. Anaconda solves this problem by relying on partition labels. If these labels are not present, then Anaconda presents a warning indicating that partitions need to be labelled and that the upgrade can not proceed. Systems that use Logical Volume Management (LVM) and the device mapper usually do not require relabeling

ladeng
20th November 2007, 11:32 AM
I replaced the mkinitrd and the nash(all applications of them in the sbin and the libs) from fedora 7

and rebuild a new kernel with the traditional hdx hardisk control driver(worked ok before)

and rebuild a new initrd

it hang at mount root and switch root

so, it is the *key* that the root always can't mount at the last

gnazio
21st November 2007, 12:13 AM
I can say that what you quoted from the release notes doesn't apply to my pc.:
5.3.1 no more than 15 partition per device, Anaconda detects all partition on all my devices, and I think my linux partitions have label since, uhm, red hat 7.3


I replaced the mkinitrd and the nash(all applications of them in the sbin and the libs) from fedora 7Been there, done that (previous posts).


and rebuild a new kernel with the traditional hdx hardisk control driver(worked ok before)Didn't try that. But did you use kernel sources form previous releases or just the same included in F8?
As it seems that we are not able to surely identify what is failing (and devs are lagging), it would be interesting to do a test using the kernel from fedora <7.92: if it doesn't work we can exclude it from the "list".
Also, with F7 my partitions were named with sd[a-d], no problem with that.


it hang at mount root and switch root

so, it is the *key* that the root always can't mount at the lastThat's the reason of post #100.

rpm -qf $/bin/mount

ladeng
21st November 2007, 04:26 PM
I used a initrd from f7 and reused it(libs ,bin)

replaced the kernel modules( ext3,jbd.ko.mbd.ko...)from f8

it mount and switch root ok

but when ude started

it crashed at fsck error at /etc/rc.d/rc.sysinit and a float exception and dropped a shell asked to input root password or CRTL-D to exit.

then ,I replaced all /etc from f7

it still crash like the formerly

later I replaced all ude*

it still crash like before with drop a shell at fsck error in /etc/rc.d/rc.sysinit 690

gnazio
21st November 2007, 07:22 PM
I've tried replacing just /bin/mount from the one in 7.90: no luck.
Both the mount, booting from a rescue cd and after chrooting, can't mount ufs partitions: mount -t ufs ... says something like unknown filesystem type 'ufs'. It used to work on f7. Could it be just a not builded module for ufs support on the kernel on the rescue iso ?

rexbinary
21st November 2007, 07:35 PM
Disk Druid does detect a UFS partition as 386/BSD during Fedora 8's installation. I'm not savvy enough to know if that depends on the support being built into the kernel or not.

ladeng
21st November 2007, 11:05 PM
I boot the fedora8 good with replaced some file and edited some file,though with many errors

the libs in the initrd with fedora8 have bug(always can't mount root)(I don't know what 's bug )

and the /etc/rc.d/rc.sysinit also have bug)(float exception and crash with drop a shell to fsck)


I replayced them and boot ok

fedora 8 is slower than fedora 7 for it new theme enginee

arsenic0
22nd November 2007, 03:02 AM
Sigh what the hell...

I just installed Fedora 8 and it gives me an Error 15 File not found for my vmlinuz-<version>.fc8 file..what the hell

rexbinary
24th November 2007, 02:27 AM
Please try to also comment any troubleshooting steps related to F8 not booting with *BSD installed on this bug thread:

https://bugzilla.redhat.com/show_bug.cgi?id=375591

Konoha
24th November 2007, 06:25 AM
I bothered with init[1] trap divide error rip:2aaaab5638a4 rsp:...

After I deleted FreeBSD 6.2 partition, not only changing partition ID to something other, but deleting its entry in partition etable, I could boot F8.

In my PC, Solaris Nevada and FreeBSD 6.2 of amd64 and some NTFS partitions in sda, WinXP and F8 of x86_64 in sdb, and Debian lenny of amd64 in sdc. sda and sdb are AHCI, and sdc is si31xx connection, where all but F8 can boot nicely.

Above trap happened in init script, which is interpreted by nash, stored in initrd.
And by ldding nash, address 0x2aaaab5638a4 seems in /lib64/libblkid.so.1, which starts from 0x2aaaab55e000, so offset is 0x58a4.
With objdump disassembling libblkid.so, div op. was found at 0x58a4.
libblkid is in e2fsprogs package, and I compiled it. That package also includes the simple tool, blkid, and I met froating exception at the same address 0x58a4(!), where probe_fat() is. I don't know why fat, but I wonder file system(fs) type determination failed.
With gdb, blkid just occured error at sda2 partition, where FreeBSD is, so that something wrong is in libblkid or its related code.
By the way, just looking at libblkid code, probe.c, not simply partition ID but some magic number (string) with specified offeset seems to be used to determine fstype, then partition ID changing trick may not work well.

gnazio
24th November 2007, 01:44 PM
I bothered with init[1] trap divide error rip:2aaaab5638a4 rsp:...This seems interesting.
Could you post what you have found in bugzilla or can I do it for you?
You'll find the link in the previous post from rexbinary, just above your.

Konoha
25th November 2007, 09:05 AM
FreeBSD in my PC is release 6.2 amd64 edition.

When I run blkid, bad correspondence in blkid_verify() of libblkid.so for FreeBSD partition seemed to occur at the entry { "vfat", 0, 0x1fe, 2, "\125\252", probe_fat } of type_array[] in lib/blkid/probe.c of e2progs src package.
And then float exception occured in probe_fat(), jumped from blkid_verify(),
because, of course, the actual content in partition was not VFAT's one.
Actually I could see 0x55aa=\125\252 in FreeBSD partition at the offset 0x1fe.

So, if you want to use F8 with FreeBSD 6.2 amd64 ed. (and maybe other editions),
only delete the above element in probe.c, and make libblkid.so, and make new initrd with your new libblkio, and then reboot.

Or simply to write a byte other than \252 in FreeBSD partition with the offset 0x1ff from the top may be nice....but I don't know if you can correctly boot FreeBSD :)

ladeng
25th November 2007, 11:14 AM
fdisk -l

Disk /dev/hda: 30.7 GB, 30734499328 bytes
16 heads, 63 sectors/track, 59551 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 4275 2154568+ c W95 FAT32 (LBA)
/dev/hda2 4276 14445 5125680 a5 FreeBSD
/dev/hda3 14446 59550 22732920 f W95 Ext'd (LBA)
/dev/hda5 14446 22575 4097488+ b W95 FAT32
/dev/hda6 22576 30705 4097488+ b W95 FAT32
/dev/hda7 30706 38835 4097488+ c W95 FAT32 (LBA)
/dev/hda8 38836 46965 4097488+ 83 Linux
/dev/hda9 46966 59550 6342808+ c W95 FAT32 (LBA)

Disk /dev/hdb: 81.9 GB, 81963220480 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 574 4610623+ 7 HPFS/NTFS
/dev/hdb2 575 9963 75417142+ f W95 Ext'd (LBA)
/dev/hdb5 575 1148 4610623+ 7 HPFS/NTFS
/dev/hdb6 1149 1722 4610623+ b W95 FAT32
/dev/hdb7 1723 2296 4610623+ b W95 FAT32
/dev/hdb8 2297 2933 5116671 b W95 FAT32
/dev/hdb9 2934 3570 5116671 b W95 FAT32
/dev/hdb10 3571 4845 10241406 c W95 FAT32 (LBA)
/dev/hdb11 4846 6120 10241406 b W95 FAT32
/dev/hdb12 * 6121 7745 13052781 83 Linux
/dev/hdb13 7746 7777 257008+ 82 Linux swap / Solaris
/dev/hdb14 7778 8797 8193118+ b W95 FAT32
/dev/hdb15 8798 9963 9365863+ 7 HPFS/NTFS

Disk /dev/hdc: 81.9 GB, 81963220480 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 1275 10241406 c W95 FAT32 (LBA)
/dev/hdc2 1276 2550 10241437+ 7 HPFS/NTFS
/dev/hdc3 2551 3825 10241437+ c W95 FAT32 (LBA)
/dev/hdc4 3826 9964 49311517+ f W95 Ext'd (LBA)
/dev/hdc5 3826 5100 10241406 b W95 FAT32
/dev/hdc6 5101 6375 10241406 b W95 FAT32
/dev/hdc7 6376 7650 10241406 b W95 FAT32
/dev/hdc8 7651 9964 18587173+ b W95 FAT32







Program received signal SIGFPE, Arithmetic exception.
0x427b0ca5 in probe_fat (probe=0xbfd7b254, id=0x427b56c0, buf=0x804d778 "�<")
at probe.c:289
289 if (cluster_count > FAT32_MAX)
(gdb) bt
#0 0x427b0ca5 in probe_fat (probe=0xbfd7b254, id=0x427b56c0,
buf=0x804d778 "�<") at probe.c:289
#1 0x427b16c0 in blkid_verify (cache=0x804b3f0, dev=0x804d728) at probe.c:994
#2 0x427ae808 in blkid_get_dev (cache=0x804b3f0,
devname=0x804d718 "/dev/hda2", flags=<value optimized out>) at devname.c:82
#3 0x427aea3f in probe_one (cache=0x804b3f0, ptname=0xbfd7ce32 "hda2",
devno=770, pri=0, only_if_new=0) at devname.c:145
#4 0x427af5f5 in probe_all (cache=0x804b3f0, only_if_new=0) at devname.c:511
#5 0x427af7d6 in blkid_probe_all (cache=0x804b3f0) at devname.c:540
#6 0x0804920c in main (argc=1, argv=0xbfd7d534) at blkid.c:209
#7 0x42ffa390 in __libc_start_main () from /lib/libc.so.6
#8 0x08048a61 in _start ()

gnazio
25th November 2007, 12:07 PM
Konoha, great work!
I've replaced libblkid.so.1.0, created a new initrd and I can finally boot.

As silence gives consent, I've created a new bug report, this time against e2fsprogs.

https://bugzilla.redhat.com/show_bug.cgi?id=398281

Konoha
25th November 2007, 12:11 PM
The following partition may be wrong for F8 booting...
/dev/hda2 4276 14445 5125680 a5 FreeBSD

so,
1. dd if=/dev/hda2 of=/tmp/foo bs=512 count=1
2. cp /tmp/foo /tmp/foo.orig
3. modify the last 2 bytes of foo, 0x55aa, to some other value by binary editor.
4. then dd if=/tmp/foo of=/dev/hda2 bs=512 count=1
5. reboot F8

do not boot FreeBSD after modification....

gnazio
26th November 2007, 10:49 PM
More info here
https://bugzilla.redhat.com/show_bug.cgi?id=398281

For who can't wait, go with your browser to
http://koji.fedoraproject.org/scratch/sandeen/task_258089/
and download these files

for i686:
e2fsprogs-1.40.2-10.bz398281.1.fc8.i386.rpm
e2fsprogs-libs-1.40.2-10.bz398281.1.fc8.i386.rpm

for x86_64:
e2fsprogs-1.40.2-10.bz398281.1.fc8.x86_64.rpm
e2fsprogs-libs-1.40.2-10.bz398281.1.fc8.x86_64.rpm
e2fsprogs-libs-1.40.2-10.bz398281.1.fc8.i386.rpm

Copy the files on a removable media or on a partition accessible from linux.
You can also download them later directly from the chrooted rescue environment, after setting up networking, using tools like wget, curl etc.

Boot from the Fedora cd/dvd, select Rescue Installed System from the menu, select your options and then, when you'll get a terminal run chroot /mnt/sysimage.
Then change your current directory to where you have stored the rpms and run
rpm --force -Uvh e2fsprogs*.rpm
cd /boot
mv initrd-2.6.23.1-49.fc8.img initrd-2.6.23.1-49.fc8.img.orig
mkinitrd initrd-2.6.23.1-49.fc8.img 2.6.23.1-49.fc8You may have to change the last two lines if you have not upgraded to the last kernel version, in this case it should be 42 instead of 49 (check with uname).

Beware! Probably yum will offer you to upgrade e2fsprogs: make sure to skip the upgrade of e2fsprogs until the new rpms find their way to the official repositories!!!
You may want to check the versionlock plugin for yum.

I wish to publicly thanks Konoha for his great work and Eric Sandeen for his very fast response.

marcovje
28th November 2007, 11:33 PM
More info here
https://bugzilla.redhat.com/show_bug.cgi?id=398281

For who can't wait, go with your browser to
http://koji.fedoraproject.org/scratch/sandeen/task_258089/
and download these files


Thanks, I tried for x86, and had to make two minor mods fwiw:

- rpm kept complaining about dependancies on e2fsprogs-libs.. so I forced with --nodeps
- mkinitrd is not in path, so /sbin/mkinitrd ....

For the rest it worked like a charm, thanks.

rexbinary
29th November 2007, 02:23 PM
The fix has been pushed to testing:

e2fsprogs-1.40.2-11.fc8 has been pushed to the Fedora 8 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
su -c 'yum --enablerepo=updates-testing update e2fsprogs'

https://bugzilla.redhat.com/show_bug.cgi?id=398281

ladeng
1st December 2007, 07:35 AM
if I use the libata driver
still can' t boot as before( no message extra)

when I change to the tradional harddisk control driver
it said
can't setup root

can't find /dev/root

bla bla

and said boot faild and hang at there

while I change the boot option from "root=LABEL=/1 to root=/dev/hdb12"

it boot ok(above all have update the newest e2fs* after installtion with chroot)


mmh,it seemed somthing still has bug in the setup root step


this setup command Interpreted by nash

maybe somthing have bug in the nash or the libraries of nash

Frédéric COIFFI
4th December 2007, 10:52 AM
I still have the problem. In fact, at boot, it seems hard disk are not found (but SATA bus but are correctly displayed). Usually, there is a message with the disk model, partitions, etc... but not in my case : nash loads ahci.ko, displays SATA bus, display "Waiting for drivers initialization" (this message takes 1-2 seconds), load ata_generic.ko and fails as /dev/root wasn't found.

Strangely, if I use a live CD (RescueCD) to boot on hard disk, it works : hard disks are correctly found after the SATA bus discovery.

Is it a problem with the SATA controller driver ? The problem occurs with Fedora 8 and Mandriva 2008.0 but there is no problem with OpenSUSE 10.3.

laotzutao
6th December 2007, 12:01 AM
I was having the same issue, formatting my FBSD partition did the trick, Fedora then booted right up, no problems. Strange.

Frédéric COIFFI
6th December 2007, 09:21 AM
I was having the same issue, formatting my FBSD partition did the trick, Fedora then booted right up, no problems. Strange.

But, I have no FBSD partition and I don't understand why a partition contain could avoid SATA disk to be detected.

In fact, I had the following partitions (Acer 7220 latop is installed with Windows Vista by default) :

/dev/sda1 1 1274 10233373+ 27 Inconnu
/dev/sda2 * 1275 7183 47457280 6 FAT16

But I have changed the partition ID to :

/dev/sda1 1 1274 10233373+ 83 Linux
/dev/sda2 * 1275 7183 47457280 7 HPFS/NTFS

and I have formated /dev/sda1 (and I don't want to lost the contain of /dev/sda2)

Frédéric COIFFI
6th December 2007, 09:26 AM
I posted details of my problem in this bug report :

https://bugzilla.redhat.com/show_bug.cgi?id=411171

Pierre Juhen
6th December 2007, 09:28 AM
I think the problem is not limited to xxxBSD. Mine was linked to the fact I had an encrypted partition.

We can formulate it that way : "When there is an "unkwnown" partition type mkinitrd will create a "wrong" initrd". This occurs only on first install.

If you are able, by any mean to boot, and do a fresh initrd, the problem might vanish (that what's happened to me and I was not able to reproduce it since then).

Frédéric COIFFI
6th December 2007, 10:09 AM
Yes, I can boot by using a LiveCD which calls the HD Grub. I have regenerated several initrd to test e2fsprogs* patch but it doesn't work.
As explained in the bug report, the problem exists with Mandriva 2008.0 and someone get it with the same laptop with Ubutu (seen on Ubuntu forum, but his correction [all_generic_ide option] doesn't work in my case).

jahLux
14th December 2007, 01:47 PM
The PCBSD problem is also being experienced here.A few posts ago, there was mention of a "fix" being 'on the way' - Is there any further development of this? If so, where can I find it?

rexbinary
14th December 2007, 03:26 PM
The PCBSD problem is also being experienced here.A few posts ago, there was mention of a "fix" being 'on the way' - Is there any further development of this? If so, where can I find it?

The fix has been pushed out. If you Fedora installation is fully updated you have it. You may need to perform the following step though:


mkinitrd -f /boot/initrd-2.6.23.8-63.fc8.img 2.6.23.8-63.fc8

Make sure the numbers match your kernel version.

jahLux
16th December 2007, 03:45 AM
The fix has been pushed out. If you Fedora installation is fully updated you have it. You may need to perform the following step though:


mkinitrd -f /boot/initrd-2.6.23.8-63.fc8.img 2.6.23.8-63.fc8

Make sure the numbers match your kernel version.
Thanks REXBINARY, but remember I said that my Fedora 8 installation wouldn't boot - so a 'full-update' is unachievable.
Now that the 'fix' has been 'pushed-out' - does that mean a fresh download of the .iso image will contain it?
Which bring up another consideration, how could the 'fix' codeline offered, be inserted into an 'as yet to be booted' installation?

rexbinary
16th December 2007, 05:37 AM
Ah sorry your right, wasn't thinking. In my case I had re-formatted my BSD partition into fat32 as a place holder until the fix went in. Not sure how you would go about inserting the fix into a non-booting installation.

gnazio
17th December 2007, 07:05 AM
Ah sorry your right, wasn't thinking. In my case I had re-formatted my BSD partition into fat32 as a place holder until the fix went in.There is no need to remove your BSD partition


Not sure how you would go about inserting the fix into a non-booting installation.Boot from the Fedora cd/dvd, select Rescue Installed System from the menu, select your options and then, when you'll get a terminal run chroot /mnt/sysimage.
Then yum update. Your kernel should be upgraded and a new initrd, build with the new e2fsprogs should be created.

jahLux
19th December 2007, 02:26 PM
Thanks GNAZIO - I'd gone back to Fedora 7 in the interim, I'll give F 8 another attempt via the "Update" route, this time and see what happens . . . . stay tuned!

jahLux
19th December 2007, 05:30 PM
Here we go again - partial sucess! Your instructions, GNAZIO, enabled the updated [from Fedora 7] Fedora 8 partitoin to boot sucessfully -BUT - somehow it 'screwed-up' the bootloader on the PCBSD partitopn.

Boot attempts on the PCBSD partition result in a "Read Error" notification and cessation of the boot-sequence.

Oh well . . . . . . !! Fedora 8 still needs to 'learn' to 'play nice with the other kids'

Maybe I can rebuild the PCBSD bootloader now - without blowing-up something else - (sml)

fabbo
1st January 2008, 10:09 PM
Similar problem here (well, it's a dual-boot PC mainly where Windows is mainly used, so it's not too serious, but...)

Installed Fedora 8: at boot time, the kernel panics, because it cannot find the root partition.
Downgraded to Fedora 7: the same.

Those messages are printed on screen:
ata1.00: exception emask 0x00 SAct 0x0 Serr 0x0 action 0x2
ata1.00: BMDMA stat 0x64
ata1.00: cmd c8/00:08:00:00:00/00:00:00:00:00/e0 tag 0 cdb 0x0 data 4096 in
(several times)

and

Buffer I/O error on device sda logical block 0
(once)

I tried to edit the GRUB command line which specifies the kernel, by adding libata.dma=0, but it just says that libata.dma is an unknown option, and does the same.

Knoppix 5.1.1, with kernel 2.6.19, also gives some IDE errors, but it can mount the Linux partitions anyway.

fabbo
1st January 2008, 11:35 PM
One more detail: when booting from Fedora 8 install disc, and choosing rescue option, adding libata.dma=0 makes the Linux partitions work. When booting from GRUB, libata.dma seems to be unknown. And the kernel version is the same! (2.6.23.1-42)

fabbo
6th January 2008, 01:47 AM
This solution worked for me:

- boot with the rescue DVD
- add 'options libata dma=0' to /etc/modprobe.conf
- run mkinitrd to create a new initrd. mkinitrd detects the options line in modprobe.conf, so, when libata.ko is loaded from initrd, the right parameter is passed.

Parameters for modules in initrd are passed through the file init, contained in the initrd itself. They cannot be changed by the command line

rexbinary
11th January 2008, 01:34 AM
In my case I had re-formatted my BSD partition into fat32 as a place holder until the fix went in.

There is no need to remove your BSD partition
There was at the time for me, as there was no fix yet. ;)

kitgerrits
22nd April 2008, 09:07 AM
Ok! I deleted "quiet" from the kernel line in GRUB, and I see now where it gets stuck. It says something along the lines of "attempting to resume from sda3." NOW, sda3 is my swap partition. I made it swap when I installed Ubuntu. Would I have had to remake it as swap under Fedora?

When an O/S goes into standby, it parks the active memory in the swap partition.
If you booted a different O/S between the suspend and the resume, the suspend-dump is 'broken' by the other O/S storing data in the swap partition.