PDA

View Full Version : Fedora Kickstart Install - Post Section Problems



phatmack18
9th November 2007, 02:57 AM
SOLVED

Turns out, if you edit your ks.cfg file in windows it puts windows carriage returns (^M) at the end of each line. Once I figured this out, I tried creating the ks.cfg file in Linux and then transferring it to Window (WinSCP) and then adding it to the ISO (UltraISO) and burning the CD (Nero). Even when the original file, in Linux, didn't have the ^M at the end of every line, once it ended up on CD the carriage return was back! In other words, WinSCP (possible), UltraISO (likely), or Nero (no way) was adding this character to my config file!!! WTF?! I don't even know how this happens... one more case for Linux I suppose. Baffled me though that's for sure!

Anyway, I was able to fix by editing the iso in Linux. Creating the ks.cfg file in Linux and then repacking/creating the iso (make sure you copy your .discinfo file into the iso!!!!) and burning it. Problem solved.

Hope this helps some others out...

QUOTE: First time posting... but I've used these forums for a LOT of support so I must throw a thanks to everyone that has ever replied and tried to help someone out. You all are a huge benefit to the Linux community!

That being said, I can't find ANYONE that is having a similar problem to mine when trying to do a cd based kickstart install. My problem is this:

Everything installs fine using the anaconda generated kickstart file... until it gets to the %post section. Once here, it doesn't matter WHAT commands I give it to run, it crashes and errors out every time. For the sake of simplicity, and since the rest of the install runs, I'll only include the post section. It is:

%post --erroronfail
/usr/sbin/useradd -c "test" -m -d /home/test2 test
%end

That's it. I just want to add a user. When it runs, it completes the install and the crashes upon entering the post section. When I jump over to tty3 I see this error message (no, it's not a typo, this is exactly what it says):

'seradd: invalid user name 'test

It doesn't matter what user name I give it and it doesn't matter if I put the full path in or not... it ALWAYS gives me that error. Talk about frusterating.

Luckily, I've found a CD-RW so I'm not having to take a second mortgage out on my house to pay for all the CD-Rs I'm turning into coasters.... ANY help would be GREATLY apprecaited. I've exhausted all my options and I'm throughly confused as to how something so simple could be such a PITA.

As an aside, when I perform the install using PXE and pull the ks.cfg file off of an http server, all my %post section scripts/commands run beautifully. Therefore, I can't see that my ks.cfg file is incorrectly formatted or syntatically incorrect.

Problem is, I NEED to be able to install from a CD and have the ks.cfg file located ON that CD. I can't use a floppy or have the machine connected to the net. It must be on a CD.

HELP!!!!

Thanks in advance.
-Dan