PDA

View Full Version : /sbin/loader



scottae
9th November 2007, 12:42 AM
Hi

I'm trying to upgarde FC 7 to FC 8 from an ISO disc. My laptop hangs when it gets to running /sbin/loader.

My laptop is a Sony Vaio VGN A397XP. I've tried going into the BIOS to disable the USB support (as suggested in other posts on various sites) but I can't see any way of doing this from the BIOS.

A) Can I resolve the loading problem? If so, how?
B) If not, are there any other ways of upgrading to FC 8? I would need full instructions as I'm a bit of a newbie (e.g. if adding a repo, I'd need to know exactly how to do that).

Hope someone can help! :confused:

leadgolem
9th November 2007, 12:52 AM
I'm not sure about the disk issue, but there are a couple other ways to upgrade. The principal alternative is to use yum.
su
yum upgradeThere are a few know conflicts, so remove compiz and/or beryl before you try that. Also, if your using freshrpms or atrpms repositories expect massive headaches.:) Livna and dribble seem to be online.

KKJensen
9th November 2007, 04:44 AM
Any news if there is a command line way of getting past this?

I've read a few things about using 'linux nousb nofb noacpi' but I'm also a newbie and don't know where to find a command line to punch this in.

cr4ck3r
9th November 2007, 05:01 AM
Hi KKJensen, I have the same problem with /sbin/loader, but in different situation. It hang when I try to boot my laptop from DVD to install F8.
At boot time, press Tab to edit options and then add those stuff to the end of line, and then enter.
For my situation, I have append: linux acpi=off apm=off pci=noacpi
Hope this may help.

KKJensen
9th November 2007, 07:01 AM
Thanks for the reply. Over on bugzilla there was some discussion and adding a couple lines helped. I've got them both on another thread I started:

http://forums.fedoraforum.org/showthread.php?t=171230

They're different than what you have but seemed to get me past the hangs and allow me to install. Everything is booting up fine now. Definately good info to write on the install disk!!!

OstermanA
5th May 2008, 12:47 AM
I've got a Sony Vaio FS-742/w with the same problem, and while I haven't tried the disable options yet, I have found that if you take a walk, it'll resolve itself after an hour or so & continue as if nothing untoward happened. Not sure why that would be & the problem seems to be solved in the Fedora 9 Beta, but thought I'd throw it out there.