PDA

View Full Version : Yum update problems



mhelal
6th November 2007, 03:49 AM
Hello

Some times (actually getting too much recently) I get this error after I finish the download of the update and b4 the installation or update:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package R needs perl(File::Copy::Recursive), this is not available.
Complete!

shouldn't be resolving all dependencies automatically?


I used the following command:

yum -t -y --skip-broken update

any help is very much appreciated,

I have another question, about how to update or install from already downloaded files, like in this instance, I finished the downloads, and the files must be cached somewhere, where I can do the update from, or in case I have a network, how can I update one machine, and take the cached files to update from on the other machines? This will really help me,

Thank you very much for helping out in advance,

Kind Regards,

Manal

Seve
6th November 2007, 04:06 AM
Hello:
Can you tell us which version of Fedora you are using ?
and
do a
yum clean all
then
yum check-update
and post the complete output.

Seve

mhelal
13th November 2007, 12:44 AM
Sorry for the late reply, here is the output on my machine "Linux manallpt 2.6.23.1-21.fc7 #1 SMP Thu Nov 1 21:09:24 EDT 2007 i686 i686 i386 GNU/Linux" thank you very much for you help

# yum clean all
Loading "skip-broken" plugin
Loading "refresh-updatesd" plugin
Loading "security" plugin
Loading "allowdowngrade" plugin
Cleaning up Everything

#yum -t -y --skip-broken check-update
Loading "skip-broken" plugin
Loading "refresh-updatesd" plugin
Loading "security" plugin
Loading "allowdowngrade" plugin
primary.sqlite.bz2 100% |=========================| 1.9 MB 00:00
Skipping security plugin, no data

acl.i386 2.2.39-6.fc7 updates
attr.i386 2.4.32-3.fc7 updates
coreutils.i386 6.9-5.fc7 updates
cpio.i386 2.6-28.fc7 updates
cups.i386 1:1.2.12-7.fc7 updates
cups-libs.i386 1:1.2.12-7.fc7 updates
firefox.i386 2.0.0.9-1.fc7 updates
flac.i386 1.2.1-1.fc7 updates
gthumb.i386 2.10.7-1.fc7 updates
libacl.i386 2.2.39-6.fc7 updates
libacl-devel.i386 2.2.39-6.fc7 updates
libattr.i386 2.4.32-3.fc7 updates
libattr-devel.i386 2.4.32-3.fc7 updates
libsmbclient.i386 3.0.26a-6.fc7 updates
mono-core.i386 1.2.3-5.fc7 updates
mono-data.i386 1.2.3-5.fc7 updates
mono-data-sqlite.i386 1.2.3-5.fc7 updates
mono-web.i386 1.2.3-5.fc7 updates
mono-winforms.i386 1.2.3-5.fc7 updates
nas.i386 1.9a-3.fc7 updates
ncurses.i386 5.6-9.20070812.fc7 updates
ncurses-devel.i386 5.6-9.20070812.fc7 updates
netpbm.i386 10.35.32-1.fc7 updates
netpbm-progs.i386 10.35.32-1.fc7 updates
openoffice.org-calc.i386 1:2.3.0-6.4.fc7 updates
openoffice.org-core.i386 1:2.3.0-6.4.fc7 updates
openoffice.org-draw.i386 1:2.3.0-6.4.fc7 updates
openoffice.org-graphicfilter.i386 1:2.3.0-6.4.fc7 updates
openoffice.org-impress.i386 1:2.3.0-6.4.fc7 updates
openoffice.org-math.i386 1:2.3.0-6.4.fc7 updates
openoffice.org-writer.i386 1:2.3.0-6.4.fc7 updates
openoffice.org-xsltfilter.i386 1:2.3.0-6.4.fc7 updates
perl.i386 4:5.8.8-25.fc7 updates
perl-CPAN.i386 1.76_02-25.fc7 updates
perl-ExtUtils-Embed.i386 1.26-25.fc7 updates
perl-ExtUtils-MakeMaker.i386 6.30-25.fc7 updates
perl-Test-Harness.i386 2.56-25.fc7 updates
perl-Test-Simple.i386 0.62-25.fc7 updates
perl-devel.i386 4:5.8.8-25.fc7 updates
perl-libs.i386 4:5.8.8-25.fc7 updates
python-urlgrabber.noarch 3.0.0-3.fc7 updates
qt4.i386 4.3.2-4.fc7 updates
qt4-x11.i386 4.3.2-4.fc7 updates
samba.i386 3.0.26a-6.fc7 updates
samba-client.i386 3.0.26a-6.fc7 updates
samba-common.i386 3.0.26a-6.fc7 updates
tomboy.i386 0.6.1-2.fc7 updates
tzdata.noarch 2007i-1.fc7 updates
yelp.i386 2.18.1-7.fc7 updates