PDA

View Full Version : Fedora 7 hanging/black screen on first boot up...



dawolfman666
1st November 2007, 05:30 PM
Hi, I'm pretty fresh to all this Linux stuff. I've got a alienware laptop with a Quadro FX go 1000 gfx card....external USB keyboard and mouse.I've installed fedora 7 to an external USB drive, with the grub loader on my internal drive.

The install went fine, after it finished it asked for a reboot, which I did. Then it seem to take an age booting back up loading all the services...pausing on 'starting CUPS' and 'starting HAL daemon' for at least 30secs. Up came the GUI for setting up the system, I clicked next and then it hangs...mouse locks up. Re boot and try again...this time it doesn't get in to the GUI it locks up before.

Trying again this morning with 'rhgb quiet' (in the grub loader) turned off...it started booting up, then it started displaying the text.

scsi 0:0:0:0: rejecting I/O to the dead drive (see pics below)and its also comes up with insmod: error inserting '/lib/usb-storage.ko': -1 File exists

http://www.lukewoolfson.co.uk//linux_2.jpg

http://www.lukewoolfson.co.uk//linux_1.jpg

someone thought it might be something to do with a IRQ conflict, so I disabled my parallel port and IR port in my BIOS, and removed my external Mouse/keyboard.....still no joy. The last few times I've booted it up all the services load fine...although a bit slow. Then after the last service is loaded , it displays loading the graphics card driver and the screen goes blank.

please help!

PS: one more thing, when I look at the drive in windows it shows nothing being on the disk....is this normal. under the disk management the disk has a 102mb partition and a 55.79GB partition

dawolfman666
1st November 2007, 07:13 PM
re booting a few times it seems to pause on the following services

cups
Sendmail
avahi daemon
HAP daemon

I tried the interatactive start-up...but after 7/8 enterys the keyboard would stop responding. I tried disconnecting the external keyboard, and disabling the touch pad...didn't make a diference. A hardware issue perhaps?

dawolfman666
2nd November 2007, 12:55 PM
I got it working in some half cocked way.

I changed the boot option to boot in mode 3 and let it run its course. It either halted on 'starting cup' or 'starting sendmail'.......what are these services anway? I then hit a few keys on the keyboard to see if it was completely dead...they were displayed on the screen but then started to repeat until the screen was full. I think its somthing to do with the keyboard/mouse rather than the graphics now.

There is a keyboard on the laptop, with a touch pad. On the boot up it displays the touch pad as 2 mice even though there is only one and its disabled in the bios...very odd.

Anyway I rebooted and again put 3 at the end of the boot up line. When it came to laoding the services I went No for everything. It then went in to the command line and it typed startX.....the GUI booted up fine. I went in to the termal window and started up the network service.. then the mouse/keyboard frooze up...so I plugged i nthe external mouse keyboard and seems to be ok now.

I think one of the services is through my systme in to highwirte how I do find out which one?